Home » Kerio User Forums » Kerio Connect » 9.2.6 build 3811 - Faulting module name: MSVCR100.dll (Kerio Connect 9.2.6 crashes)
  •  
SIBJaborek

Messages: 21
Karma: -1
Send a private message to this user
Hello everyone!

So. We had the same problem. Kerio crashed and the eventlog showed the appcrash with MSVCR100.dll. The Kerio service stopped, restarted, stopped, restarted and stopped. We had also a corrupted mail and those repair informations about it.

The solution in the end was pretty simple for us.
1. Install latest Kerio Connect Update
2. Make a backup from the corrupted mails if you can and then delete them all from the user account. In our case there was one corrupted mail in a drafts folder of a user. I was able to open the mail in the webclient and print a PDF to save the content. Also download the files from the mail if there are any in it.
3. Deactivate all user accounts who have corrupted mails in it.
4. Change the password of every user account who has corrupted mails in it. (Making sure that the client cant access the account.)
5. Remove these accounts completely from all client devices of the users. Remove it from every device which syncs with Kerio. Even the smartphone. Clean it up.
6. Reactivate the accounts and re-index them.
7. Reconfigure the accounts for the users on the client devices. Make a new Outlook profile for it. On the smartphone i switched from ActiveSync to IMAP + Kerio App Sync.

It works fine now. It seems the client was the problem. As soon as the client with the corrupted mails could not access / sync anymore the Kerio service worked well. No more crashes. It's kinda weird that one corrupted mail on the client device was able to stopp Kerio again and again and again.

EDIT:

It seems like this error is a combination of the version 9.2.6 (and later) and the activesync on Samsung Galaxy S8 smartphones. We had the same problem with two other mail accounts. Both of them are used on those smartphones. After going to IMAP the server worked again. I guess a it's a communication problem between the smartphone activesync and the kerio server.




[Updated on: Tue, 08 May 2018 13:14]

  •  
viki

Messages: 23
Karma: -1
Send a private message to this user
Got the same issue with crap called 9.2.6, since update to 9.2.6 there are only problems, first Timezone problem and now it by it seflt started to crash afret minute from service start...Reverting back from this piece of sh*t...

Downgraded to 9.2.5p3 and working fine...

[Updated on: Tue, 08 May 2018 16:31]

  •  
Maerad

Messages: 210
Karma: 38
Send a private message to this user
SIBJaborek wrote on Thu, 03 May 2018 13:40

It seems like this error is a combination of the version 9.2.6 (and later) and the activesync on Samsung Galaxy S8 smartphones. We had the same problem with two other mail accounts. Both of them are used on those smartphones. After going to IMAP the server worked again. I guess a it's a communication problem between the smartphone activesync and the kerio server.


FYI - we had the same problem, but I couldn't link it to be the problem for kerio to kill itself.

One User with a Samsung S8 tried to send a mail (simple forward to an internal address) and it didn't get out, with me getting tons of errors in the error log (active sync related). Also later on even a iPhone...6? user mad the same error msg in the log. This was with Kerio 9.2.6 SP 2.

It really seems that it's an active sync problem, because we removed/readded the mobile more the one time and the error kept happening.

Also my Pixel 2 connects with ActiveSync 16, the Samsung Phone even when readded with AS 14. Same could be true for the iPhone, but can't check it, because I downgraded and deleted the logs (to start from new)
  •  
wuti

Messages: 2
Karma: 0
Send a private message to this user
My Kerio Connect 9.2.6 patch 2 has service stop every few minutes. Thanks Maerad pin point that it is all about ActiveSync. And thanks to SIBJaborek shown that somehow clearning old cache is the key.

So I change the "User Access Policy" which default policy was "Allow all protocols". I changed it to "Deny ActiveSync" and "Allow all" for the rest protocols to go on. Kerio Connect service then works fine after that.

And I created another "User Access Policy" as "Allow all protocols" and I apply that access policy to a small group of user 5 at a time. I use this method to discover the mobile phone that caused Kerio Connect to stop service.

So I go to that mailbox. Right click the mailbox -> More Action -> Mobile device menu. I deleted that mobile device and let user Re-Sync. The mobile device will not caused Kerio Connect to stop service anymore.

Hope this help.

Wuti

[Updated on: Wed, 23 May 2018 05:53]

  •  
chrisgi

Messages: 9
Karma: 0
Send a private message to this user
Hello, on a customer install on 9.2.6 we also have some crash, i ve disable activesync it seems more stable.

Anyone have tried 9.2.7 ? (changelog say : "- Crash due to malformed email (To, Cc, Bcc, From) in Drafts from emails in ActiveSync ")

Regards,

Christophe
  •  
SiriusMac

Messages: 87
Karma: 10
Send a private message to this user
chrisgi wrote on Wed, 11 July 2018 07:21
Hello, on a customer install on 9.2.6 we also have some crash, i ve disable activesync it seems more stable.

Anyone have tried 9.2.7 ? (changelog say : "- Crash due to malformed email (To, Cc, Bcc, From) in Drafts from emails in ActiveSync ")

Regards,

Christophe


I have not run 9.2.7, but the (still officially beta) 9.2.7 p1 (4058) seems pretty stable, as long as you have Apple Mail.app configured as IMAP, and not as EWS. My understanding from other posters is that the released 9.2.7 (June 4) version still has ActiveSync issues that I am not seeing under 9.2.7 p1 (4058).

[Updated on: Wed, 11 July 2018 17:52]

  •  
wuti

Messages: 2
Karma: 0
Send a private message to this user
I am using 9.2.7 (3949) and ActiveSync problem that caused the crash was gone as stated in the release note. However, I have found that Outlook for Mac 2011 that connect to Kerio Connect using native "Exchange account" type. Cannot delete the mail in the shared folder. No matter that folder is shared with given right as Editor or Owner.

Contact Kerio support and confirmed from their L3 support staff that this is confirmed Bug.
Previous Topic: Users with Editor privilege can delete shared calendar
Next Topic: Kerio, CentOS7 and AD LDAP KDC Authentication
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Nov 15 03:42:31 CET 2018

Total time taken to generate the page: 1.00764 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.