Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » can't send mail to Yahoo-mail account
  •  
remstedt

Messages: 6
Karma: 0
Send a private message to this user
I'm running KMS-6.3.1 build2402 on FC5, trying to send from both KMS Web-Mail and Evolution

* extract from mail-log:

[19/Mar/2007 09:31:02] Recv: Queue-ID: 45fe4a46-00000006, Service: SMTP, From: <glenn<.a.t.>remstedt.org>, To: <glenn_z1010<.a.t.>yahoo.co.uk>, Size: 590, Sender-Host: 127.0.0.1, User: glenn<.a.t.>remstedt.org, SSL: yes
[19/Mar/2007 09:31:02] Sent: Queue-ID: 45fe4a46-00000006, Recipient: <glenn_z1010<.a.t.>yahoo.co.uk>, Result: delayed, Status: 4.4.1 Cannot connect to remote host

Help on this are most appreciated,
Glenn.
  •  
mkjellman

Messages: 69
Karma: 0
Send a private message to this user
i'd like to bet that this is a DNS issue...are you running your own dns server? who is dealing with your forwards?
  •  
remstedt

Messages: 6
Karma: 0
Send a private message to this user
yes, I do run my own DNS, and my forwards is going via DynDNS.
  •  
mkjellman

Messages: 69
Karma: 0
Send a private message to this user
i meant more, if you are hosting your own dns (which you are), who are you using for your external dns requests

for instance workstation.internaldomain.com resolves based on your own dns server, but google.com should resolve based on the forwarder you have setup for those external dns issues.

many large isps (yahoo, msn, and hotmail) now require that you have the sqf settings on your dns settings correct....if you are using dyndns.org (which i am as well, love them)

-create a TXT record in your domain
-research the correct SPF record for your domain but this should work, "v=spf1 a ~all"
-note the " should be in the field too

-make sure you can ping the yahoo.co.uk mx servers from your machine inside your mail server's internet connection


-also, i really recommend the use of OpenDNS.com .... i love their DNS services, fast and reliable


let me know if you need more help, hopefully this will get you on the right path. your issue is almost certainly because of a incorrect DNS setup and not and issue with Kerio
  •  
remstedt

Messages: 6
Karma: 0
Send a private message to this user
Sorry for the late reply, but I've been away ...

So now I've the following setup:

A. Configure a dns server on my linux machine to support my private 192.168.1.0/24 network of devices.
B. Make sure those internal address ARE NOT public or publicized to the open internet.
C. Make sure my local dns does not answer public internet queries.
D. Provide some sort of backup to client machines, in case I turn off my linux machine (I never do but...)
E. Allow dynamic updates to support a few planned dhcp clients

Implementing these objectives I was forced to;

1. decide on a local (in-house) domain name. Any name will do because it will not be public and thus cannot conflict.
2. decide if I was or was not going to support a mail server in-house: yes, I used to install Kerio.
3. the machine to become the DNS-server must have a STATIC address: I choose 192.168.1.100

My ISP does just supply a dynamically assigned IP-addr. and they are not block port 25 for incoming/outgoing --> Cable Modem --> Cisco PIX FW --> FedoraCore 6

** How can I from this lay-out, configure my KMS 6.3.1 - what kind of further info do I need to find out for to have this running?
  •  
mkjellman

Messages: 69
Karma: 0
Send a private message to this user
it is very frequent for large email providers to block blocks of dynamic ip addresses that isps make public. this helps them reduce spam. if you want to reliably setup a email server for use, you will need to get one static public ip address.

however, that is more applicable to sending to aol than any other large provider. Your issue looks to be that your dns server is not setup correctly and Kerio can not locate the MX records for yahoo.co.uk

i would suggest changing the DNS settings on the mail server to 4.2.2.2 or another known working external DNS service and try to send a message to the yahoo account. these settings are made in linux itself and not in kerio. Kerio has options to use mx records to deliver but this is the default behavior of the server. nothing on your kerio is most likely causing your inability to send messages to yahoo subscibers. If the message goes through, you will need to research how to setup BIND (assumption here) on your linux distribution.

hope that helps ;)
  •  
shaggie16

Messages: 99
Karma: 0
Send a private message to this user
I have seen issues whereby you cannot sent to AOL or Yahoo if one or both of the following are true:

1) You have no SPF record set or your domain
2) You have no (accurate!) reverse DNS lookup for your mail server
  •  
remstedt

Messages: 6
Karma: 0
Send a private message to this user
I've it all solved right now - most of a DNS-issue!
Thanks for your assistance!
Glenn.
Previous Topic: Company Contact without Full Name
Next Topic: Message sending problem
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Nov 19 02:11:25 CET 2017

Total time taken to generate the page: 0.00513 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.