Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Kerio Administration Console on Linux CentOS - Newbie Question
  •  
teclis22

Messages: 4
Karma: 0
Send a private message to this user
Hi Folks !

I am a linux newbie playing around with Kerio, so please bear me with me.

So far i used kerio on my win2k server in a homenetwrok and everything is fine.

Well now my parents are pointing out the electricity bill and i have to slowly consolidate some of my for-fun machines into something more efficent.

so my Plan was to use my old sun cobalt qube 3 running Strongbolt (=Cent OS 4.4) as my mail server .

I downloaded the two linux rpms (mailserver and admin console) and installed them on the machine.

i started the mail server

[root<.a.t.>qube3 init.d]# ./keriomailserver restart
Shutting down Kerio MailServer:                            [  OK  ]
Starting Kerio MailServer:                                 [  OK  ]
[root<.a.t.>qube3 init.d]# 


ok so far so good, now i wanted to start the admin interface so i could use a gui to administrate the server

[root<.a.t.>qube3 admin]# dir -l
total 21180
drwxr-xr-x  2 root root     4096 Mar 27 19:35 icons
-rwxr-xr-x  1 root root  3296586 Dec  8 12:16 kadmin
lrwxrwxrwx  1 root root       17 Mar 27 19:35 libqt-mt.so.3 -> libqt-mt.so.3.3.6
-rwxr-xr-x  1 root root  8196386 Dec  8 11:02 libqt-mt.so.3.3.6
-rwxr-xr-x  1 root root 10146612 Dec  8 12:16 mailadmin603
drwxr-xr-x  2 root root     4096 Mar 27 19:35 translations
[root<.a.t.>qube3 admin]# ./kadmin
./kadmin: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory
[root<.a.t.>qube3 admin]#


And thats where i am stuck. I dont know how to solve the encountered error to get the admin console to work.

For kicks i went to my current win2k machine and used the admin console from that to connect to the qube3 kerio mail server, wich works fine so the server itself seems to be running.

But since i want to take the win2k machine off the net i would like to have the qube run the admin interface as well.

Is that even possible ? If so, how would i go about it ?
Or am i misunderstanding the concept ?

Hope you folks find the time to help a newbie out.

Best regards

tec

[Updated on: Tue, 27 March 2007 20:44]

  •  
teclis22

Messages: 4
Karma: 0
Send a private message to this user
Hi all !

Ok got the first problem fixed by doing a :

yum -y install lib*


then changing to usr/bin and doing a

./kerioadmin


and i get a

kadmin: cannot connect to X server 



OK i am confused. The server is running how comes the console cant conenct ?

Even when i do the ./kerioadmin command with the ip or the loop back address it doesnt work.

I am stumpd.

Help is apreciated.

regards

tec
  •  
darylhurst

Messages: 8
Karma: 0
Send a private message to this user
Are you running a graphical desktop under X? If so which one e.g. KDE/Gnome etc?
  •  
teclis22

Messages: 4
Karma: 0
Send a private message to this user
Hi there !

I am not currently running a graphic desktop.

The hosting machine is a Sun Cobalt Qube wich does not support a GUI of any kind.

Is that required to get the admin console to work? Cant you just administrate it over a web browser ?

Regards

tec

P.S: sorry for beeing such a noob but learnig linux from scratch is much harder then clicking around in windoofs :/
  •  
darylhurst

Messages: 8
Karma: 0
Send a private message to this user
The Admin Console requires a graphical environment to run. I'm not aware of a web interface for the console - unless anyone else knows of one.
  •  
darylhurst

Messages: 8
Karma: 0
Send a private message to this user
If you have port 44337 open on your firewall you can install the Admin client on another machine e.g. a Windows PC (or another Linux machine with a GUI) and administer your server remotely.
  •  
teclis22

Messages: 4
Karma: 0
Send a private message to this user
Hi !

Thanks for the input. I will give that a try :)

regards

Tec
Previous Topic: Searching in outlook 2003
Next Topic: McAfee update error: update.ini is corrupt or missing
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon Nov 20 10:38:16 CET 2017

Total time taken to generate the page: 0.00440 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.