Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » CA eTrust Antivirus r8.1 does not work with Kerio 6.3.1
  •  
pbwells

Messages: 24
Karma: 0
Send a private message to this user
I just upgraded from eTrust 7.1 which doesn't appear to be doing a very good job anymore. After installing and scanning with eTrust r8.1 it found 9 infected files on my server. Anyhow, I restarted Kerio and now I'm getting the following

[29/Mar/2007 09:16:21] mail_avir.cpp: Antivirus check of mail from <blah<_a.t_>blah.net> to <blah<_a.t_>blah.net> failed: Error running scanner

This is a full version, Enterprize edition license before anybody asks if I'm trying to us a EZ or Personal ed.

I tried one of the old faq's that says to go into filters and create exclusions for the working directory of Kerio and that didn't have any effect.

Here is the error I get when I try to enable scanning using the drop down option "eTrust InoculateIT"

eTrust InoculateIT failed to start: Unable to initialize plugin, error:Cannot load scanner DLL (InoScan.dll) error code 126

Need some help with this please if anybody has encountered this already.
  •  
pbwells

Messages: 24
Karma: 0
Send a private message to this user
ok I called support, evidently the plugin for eTrust in Kerio doesn't work with the latest version of eTrust. At first we thought we'd gotten it to work by adding the path to the .dat files where the virus definitions live. Here's the debug after we did that.

[29/Mar/2007 10:27:03][3392] {avir} Running antivirus check on mail from <blah.net> to <blah.net> size 18944 B
[29/Mar/2007 10:27:03][3392] {avir} Client: requesting check for file C:\Program Files\Kerio\MailServer\store/tmp/460bccb6-00000448/avfile.tm p, mail from <blah.net> to <blah.net>
[29/Mar/2007 10:27:03][3392] {avir} Checking file C:\Program Files\Kerio\MailServer\store/tmp/460bccb6-00000448/avfile.tm p for JPEG vulnerabilities
[29/Mar/2007 10:27:03][3392] {avir} Client: waiting for result...
[29/Mar/2007 10:27:03][3392] {avir} External plug-in scanning avfile.tmp (C:\Program Files\Kerio\MailServer\store/tmp/460bccb6-00000448/avfile.tm p) - verdict: No Virus found
[29/Mar/2007 10:27:03][3392] {avir} Client: check result: (0) Clean

So I check the message queue which is starting to fill up again, so I look at the mail logs and find this:

[29/Mar/2007 10:29:27] Sent: Queue-ID: 460bcd45-0000045e, Recipient: <blah.net>, Result: delayed, Status: 4.6.5 Antivirus check cannot be performed
[29/Mar/2007 10:29:27] Sent: Queue-ID: 460bcd45-0000045e, Recipient: <blah.net>, Result: delayed, Status: 4.6.5 Antivirus check cannot be performed
[29/Mar/2007 10:29:27] Sent: Queue-ID: 460bcd45-0000045e, Recipient: <blah.net>, Result: delayed, Status: 4.6.5 Antivirus check cannot be performed

Not sure what's going on, the issue is being escallated, the filed a bug report: # 23776

I'll update this with more info as I get it incase there are others out there running the latest version of eTrust.

[Updated on: Thu, 29 March 2007 17:04]

  •  
pbwells

Messages: 24
Karma: 0
Send a private message to this user
This has been refered to the Kerio design team. Sounds like they're going to have to rewrite the plugin for eTrust to work.
  •  
linuxbox

Messages: 139
Karma: 0
Send a private message to this user
man, it's not good that you cannot use CA Antivirus 8
still doesn't work with kerio..yuck!
  •  
pbwells

Messages: 24
Karma: 0
Send a private message to this user
I'm not sure if this is still the case, eventually I did hear back from the engineering team and they state that it will work with the latest version of CA. However, my life has been quite busy with network upgrades, phone system upgrade, the decommission of a facility, breaking ground on 2 new sites, and general day to day insanity that I haven't tried to reinstall. If I do get around to it in this lifetime I'll post as to weather or not it worked.
  •  
linuxbox

Messages: 139
Karma: 0
Send a private message to this user
well i have version 8.4.0.24 installed of CA Antivirus and it does NOT work with kerio 6.4.1. already tried...get the same error "cannot load blah blah blah" there is an option for some path in the kerio setup but who knows what to put there.
if there is a way that it works someone from the kerio team should chime in and actually post what needs to be done to make it work. CA is a great antivirus program.
  •  
pbwells

Messages: 24
Karma: 0
Send a private message to this user
yeah I know what you're talking about, where it says you can put the path to, you want to put the path to the CA virus checker engine. It's been too long since this was a in my face issue to remember but I think the file extension is unique enough you could search for it and not come up with more than one or two results. Then just enter that path in Kerio and give it a whirl, the problem I had was that even after we did that and it "appeared" like it was then working, I went to the logs and watched as the failure messages continued to stream past. Ultimately I was told to totally uninstall my version of CA, and reinstall it. Like I said, when I get a chance I'll try it again. If anything else comes to me I'll post it later. The sky is falling here this morning... the best things in life never change Wink
Previous Topic: Cannot read from connection socket
Next Topic: KMS in General (My days in testing)
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Nov 17 20:24:00 CET 2017

Total time taken to generate the page: 0.00465 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.