Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » User_stats.cpp
  •  
tqlkerio

Messages: 3
Karma: 0
Send a private message to this user
Seen a couple of threads about this particular issue we noticed in 6.3.1 and were hoping it might be fixed in 6.4.0.

Small excerpt from our error log:

Quote:

[29/May/2007 14:46:04] user_stats.cpp: Storage quota for user XXXXX<_a.t_>XXXXX.co.uk falls below zero: attempt to decrement from 0 by 392042
[29/May/2007 14:46:04] user_stats.cpp: Message quota for user XXXXX<_a.t_>XXXXX.co.uk falls below zero: attempt to decrement from 0 by 1
[29/May/2007 14:46:04] user_stats.cpp: Storage quota for user XXXXX<_a.t_>XXXXX.co.uk falls below zero: attempt to decrement from 0 by 392042
[29/May/2007 14:46:04] user_stats.cpp: Message quota for user XXXXX<_a.t_>XXXXX.co.uk falls below zero: attempt to decrement from 0 by 1
[29/May/2007 14:46:04] user_stats.cpp: Storage quota for user XXXXX<_a.t_>XXXXX.co.uk falls below zero: attempt to decrement from 0 by 265847
[29/May/2007 14:46:04] user_stats.cpp: Message quota for user XXXXX<_a.t_>XXXXX.co.uk falls below zero: attempt to decrement from 0 by 1


Big difference now though is we know how to reproduce this error!

We have a few "generic" users whom we use to catch various bits of miscellaneous mail. The INBOX of these users is shared and problems start when someone deletes or copies the messages in these folders. Invariably both the "shared" and users own user_stats.cpp file becomes corrupted.

Other than removing the user_stats.cpp files anyone have a better solution?
  •  
willowsv

Messages: 119
Karma: 0
Send a private message to this user
I cant remeber how we solved this one :S

I thik it had something to do with re-indexing the users store directory although I cant remeber for sure.
  •  
tqlkerio

Messages: 3
Karma: 0
Send a private message to this user
At the moment we're having to re-index every night otherwise the user stats are nonsense and the error continues to appear in the log.
  •  
winkelman

Messages: 2119
Karma: 3
Send a private message to this user
tqlkerio wrote on Tue, 29 May 2007 17:41

We have a few "generic" users whom we use to catch various bits of miscellaneous mail.

We have the same problem over here. My log is a complete garbage because of this. Has been happening ever since I started using KMS 2 years ago. At some point it was reported in the changelog that this issue was solved: well, it wasn't/isn't.

But I think you're absolutely right: it has something to do with people dealing with messages in shared folders of this 'generic' user. It messes with the quota's, for some reason.

Kerio: go bug-hunting! Razz

Oh yes: the reported way of dealing with this (KB) doesn't help in this specific case...

[Updated on: Wed, 30 May 2007 12:44]

Previous Topic: backup server delivery question
Next Topic: Message flagging with Windows Mobile 6?
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Nov 24 16:07:27 CET 2017

Total time taken to generate the page: 0.00404 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.