Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Windows Mobile Calendar "All Day" Events not syncing
  •  
andrewrob

Messages: 70
Karma: 3
Send a private message to this user
I have several users with Windows Mobile 5 devices and they are all having similar issues. When Syncing with the server through activesync it does not sync "All Day" events. only events with times attached to them. I have no idea why. We have the latest Kerio Mailserver version running on Mac OS X 10.4.10
  •  
Matt S

Messages: 230
Karma: 6
Send a private message to this user
Did you get anywhere with this problem? I'm having the same difficulty, but not if the WM device calendar is clean. Initial sync brings everything across, but from then on it's not reliable. So pretty useless.
  •  
Matt S

Messages: 230
Karma: 6
Send a private message to this user
Done a bit more digging with this.

If I create an all day even on the WM device, it syncs with Kerio and will also be synced back to iCal on my Mac.

Deleting this event on the mac, the wm device or Kerio webmail will sync correctly.

But creating an all day event on the Mac or in Kerio will not be synced to the WM device.

Which makes the entire activesync functionality of Kerio useless.... Anyone else having this problem or know what to do about it?
  •  
andrewrob

Messages: 70
Karma: 3
Send a private message to this user
Thats exactly the fault. I have a ticket open with Kerio Support but no luck as yet.
  •  
Matt S

Messages: 230
Karma: 6
Send a private message to this user
Hmmm, when did you open the ticket? I've just raised one with them too.

It's a bit worrying. A quick search finds a few other references to this problem with other products so it could be a WM or Activesync problem... Either way it's pretty fundamental.

It makes the Activesync facility useless as far as I'm concerned. That was a big reason for going with Kerio in the first place so I'd like some answers from them.
  •  
danoli

Messages: 41
Karma: 0
Send a private message to this user
I have the same problem.
  •  
andrewrob

Messages: 70
Karma: 3
Send a private message to this user
FROM KERIO SUPPORT:

I did some more digging into this problem and unfortunately this was listed as a bug in our system. I have added your details to the bug and I will place you in the 'Awaiting Bug Fix' and as soon as this problem is fixed then a member of staff will be in touch. Feel free to get in touch with us if you would like an update on the status of this bug.

Best Regards,

Vicky Cinelli
Technical Support Engineer
  •  
Matt S

Messages: 230
Karma: 6
Send a private message to this user
Hi Vicky, this is a pretty significant bug considering Kerio sells KMS as being compatible with Activesync OTA out of the box... and it isn't. Not completely anyway.
  •  
andrewrob

Messages: 70
Karma: 3
Send a private message to this user
I am not Vicky. Vicky was the support person. I suggest everyone opens a ticket saying how they think its unnacceptable that there is such a flaw in the system.
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
Hi,
Our developers were unable to reproduce the problem. All day events are being synchronized properly to WM device. That's why we requested the debug log. Debug log clearly shows that new calendar event has been successfully synchronized to the WM device. Can you please provide more information? What kind of Windows Mobile device you use? Smartphone or PDA?
  •  
andrewrob

Messages: 70
Karma: 3
Send a private message to this user
All the devices have been different. I have been using a Palm Treo 750 and an O2 XDA II Mini. One is using Windows Mobile 5 and one Windows Mobile 6. I have been trying it with different user accounts too but it is the same. I really have no idea how to solve this one. It has to be a Kerio Server issue as I have tried these different options. Maybe there is a setting somewhere on the server that would restrict this? Interestingly, if you create a "All day event" on the Mobile device, it syncs with the server no problems. Its only if you have created it on the Webmail, or Entourage.
  •  
danoli

Messages: 41
Karma: 0
Send a private message to this user
I am using the XDA Exec with WM 5.0
  •  
Matt S

Messages: 230
Karma: 6
Send a private message to this user
Sorry andrewrob, that'll teach me not to read the post properly. Thought it was odd that support were suddenly posting to the forum.

I'm going to see if I can get any debug information on this and pass it on.

Although support are dragging their feet on this one, and the ticket I've raised hasn't been addressed yet, so I haven't been asked for debug info...


  •  
Matt S

Messages: 230
Karma: 6
Send a private message to this user
Should anyone want to take a look at this.... Here's a log from my WM device as the server hands it an all day event.... that it doesn't sync.


=-= Build 18125 =-=
=-= No XIP Information Available =-=
mail.stmichaelsyork.org

=-=- [8/1/2008 10:51:49.0] -=-=
=-=-=-= Client Request =-=-=-=
OPTIONS Microsoft-Server-ActiveSync?User=matt<_a.t_> fivesmallponies.com&DeviceId=A69CD48EE135984466D7F55872B B88BF&DeviceType=PocketPC
Accept-Language: en-gb
MS-ASProtocolVersion: 2.5
X-MS-PolicyKey: 1

-=-=-=- Start of Body -=-=-=-


=-=- [8/1/2008 10:51:49.0] -=-=
=-=-=-= Server Response =-=-=-
HTTP/1.1 200 OK
Allow: OPTIONS, POST
Connection: Keep-Alive
Content-Length: 0
Content-Type: application/vnd.ms-sync.wbxml
Date: Tue, 8 Jan 2008 10:51:50 GMT
Keep-Alive: timeout=900, max=99
MS-ASProtocolCommands: Sync,SendMail,GetAttachment,SmartForward,SmartReply,GetHiera rchy,CreateCollection,DeleteCollection,MoveCollection,Folder Sync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetIte mEstimate,MeetingResponse,Ping,Provision,Search
MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
MS-Server-ActiveSync: 6.5.7638.1
Public: OPTIONS, POST
Server: Kerio MailServer 6.4.2


-=-=-=- Start of Body -=-=-=-


=-=- [8/1/2008 10:51:51.0] -=-=
=-=-=-= Client Request =-=-=-=
POST Microsoft-Server-ActiveSync?User=matt<_a.t_> fivesmallponies.com&DeviceId=A69CD48EE135984466D7F55872B B88BF&DeviceType=PocketPC&Cmd=GetItemEstimate
Accept-Language: en-gb
MS-ASProtocolVersion: 2.5
Content-Type: application/vnd.ms-sync.wbxml
X-MS-PolicyKey: 1

-=-=-=- Start of Body -=-=-=-
<?xml version="1.0" encoding="utf-8"?><GetItemEstimate xmlns="GetItemEstimate:" xmlns:A="AirSync:"><Collections><Collection><Class>Contacts </Class><CollectionId>90d69acd-ccea-47d3-8b98-974c887cd524 </CollectionId><A:FilterType>0</A:FilterType><A:SyncKey>VD0yMDA4MDEwN1QxMTI3MTdaO1U9MDtGPTA7TT0yNDU7 </A:SyncKey></Collection><Collection><Class>Calendar</Class ><CollectionId>a97ef65d-a050-47ac-8824-7ede74b696d6</CollectionId ><A:FilterType>0</A:FilterType><A:SyncKey>VD0yMDA4MDEwOFQxMDQ1NDFaO1U9MDtGPTA7TT01NTU3Ow== </A:SyncKey></Collection><Collection><Class>Tasks</Class ><CollectionId>610ac92d-f827-43b0-bf1d-9b0110b97601</CollectionId ><A:FilterType>0</A:FilterType><A:SyncKey>VD0yMDA4MDEwNlQxMjQwMDRaO1U9MDtGPTA7TT02Ow== </A:SyncKey></Collection></Collections></GetItemEstimate>

=-=- [8/1/2008 10:51:51.0] -=-=
=-=-=-= Server Response =-=-=-
HTTP/1.1 200 OK
Cache-Control: no-cache
Connection: Keep-Alive
Content-Length: 203
Content-Type: application/vnd.ms-sync.wbxml
Date: Tue, 8 Jan 2008 10:51:51 GMT
Keep-Alive: timeout=900, max=98
MS-Server-ActiveSync: 6.5.7638.1
Pragma: no-cache
Server: Kerio MailServer 6.4.2


-=-=-=- Start of Body -=-=-=-
<?xml version="1.0" encoding="utf-8"?><GetItemEstimate xmlns="GetItemEstimate:"><Response><Status>1</Status><Collection ><Class>Contacts</Class><CollectionId>90d69acd-ccea-47d3-8b98-974c887cd524 </CollectionId><Estimate>0</Estimate></Collection></Response ><Response><Status>1</Status><Collection><Class>Calendar </Class><CollectionId>a97ef65d-a050-47ac-8824-7ede74b696d6 </CollectionId><Estimate>1</Estimate></Collection></Response ><Response><Status>1</Status><Collection><Class>Tasks</Class ><CollectionId>610ac92d-f827-43b0-bf1d-9b0110b97601</CollectionId ><Estimate>0</Estimate></Collection></Response></GetItemEstimate >

=-=- [8/1/2008 10:51:51.0] -=-=
=-=-=-= Client Request =-=-=-=
POST Microsoft-Server-ActiveSync?User=matt<_a.t_> fivesmallponies.com&DeviceId=A69CD48EE135984466D7F55872B B88BF&DeviceType=PocketPC&Cmd=Sync
Accept-Language: en-gb
MS-ASProtocolVersion: 2.5
Content-Type: application/vnd.ms-sync.wbxml
Accept-Encoding: gzip
X-MS-PolicyKey: 1

-=-=-=- Start of Body -=-=-=-
<?xml version="1.0" encoding="utf-8"?><Sync xmlns="AirSync:"><Collections><Collection><Class>Calendar </Class><SyncKey>VD0yMDA4MDEwOFQxMDQ1NDFaO1U9MDtGPTA7TT01NTU3Ow== </SyncKey><CollectionId>a97ef65d-a050-47ac-8824-7ede74b696d6 </CollectionId><DeletesAsMoves/><GetChanges/><WindowSize>100 </WindowSize><Options><FilterType>0</FilterType><Truncation >4</Truncation><RtfTruncation>4</RtfTruncation><Conflict >1</Conflict></Options></Collection></Collections></Sync >

=-=- [8/1/2008 10:51:51.0] -=-=
=-=-=-= Server Response =-=-=-
HTTP/1.1 200 OK
Cache-Control: no-cache
Connection: Keep-Alive
Content-Length: 554
Content-Type: application/vnd.ms-sync.wbxml
Date: Tue, 8 Jan 2008 10:51:52 GMT
Keep-Alive: timeout=900, max=97
MS-Server-ActiveSync: 6.5.7638.1
Pragma: no-cache
Server: Kerio MailServer 6.4.2


-=-=-=- Start of Body -=-=-=-
<?xml version="1.0" encoding="utf-8"?><Sync xmlns="AirSync:" xmlns:A="POOMCAL:"><Collections><Collection><Class>Calendar </Class><SyncKey>VD0yMDA4MDEwOFQxMDUxNTJaO1U9MDtGPTA7TT01NTU3Ow== </SyncKey><CollectionId>a97ef65d-a050-47ac-8824-7ede74b696d6 </CollectionId><Status>1</Status><Commands><Add><ServerId >6522</ServerId><ApplicationData><A:Timezone> AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAoAAAAFAAIAAAAAAAAAAAAAAAAA AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA AAAAAAAAAAAAAAAAAAAAAAAAAAMAAAAFAAEAAAAAAAAAxP///w== </A:Timezone><A:DtStamp>20080108T105141Z</A:DtStamp><A:StartTime >20080108</A:StartTime><A:Subject>test all day event</A:Subject><A:UID>&lt;20080108105141.1519a7da<_a.t_ >mail.stmichaelsyork.org&gt;</A:UID><A:OrganizerName>Matt Seymour</A:OrganizerName><A:OrganizerEmail>matt<_a.t_>fivesmallponies.com </A:OrganizerEmail><A:EndTime>20080109</A:EndTime><A:Sensitivity >0</A:Sensitivity><A:BusyStatus>2</A:BusyStatus><A:AllDayEvent >1</A:AllDayEvent><A:MeetingStatus>0</A:MeetingStatus></ApplicationData ></Add></Commands></Collection></Collections></Sync>
bigmountain

Messages: 116

Karma: 0
Send a private message to this user
Ok, I have the exact same issue here, except my client is using a newer Palm Treo Centro mobile phone. We have been troubleshooting why his recurring events would not sync with the mobile and then we stumbled upon the all day events issue. When we set a specific time, they synced up just fine. Take it back to an all day event and they disappeared. This had nothing to do with them being recurring, they have to do with them being add day events. This is not an issue specifically with a windows mobile device, this has to be with ActiveSync and all day events issue.

Preferred Kerio Partner and Cloud Solutions Provider - Offering both shared and dedicated Kerio Connect hosting solutions.
Visit us at http://bigmountainmail.com
Previous Topic: Kerio Sync Connector Last Synchronization failed
Next Topic: KOFF 80070057 Error
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Nov 19 11:45:05 CET 2017

Total time taken to generate the page: 0.00579 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.