Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » ClamAV link from KB no good
  •  
scottwilkins

Messages: 654
Karma: 7
Send a private message to this user
Hi guys,

I was looking to add ClamAV to my server for additional protection, and the link in the KB article for Windows seems to be no good any more. (this one: http://www.sosdg.org/clamav-win32/index.php from this article: http://support.kerio.com/index.php?_m=knowledgebase&_a=v iewarticle&kbarticleid=426 )

Where can it get it now?

Thanks,
Scott
  •  
scottwilkins

Messages: 654
Karma: 7
Send a private message to this user
Nevermind, I figured it out, http://www.sosdg.org/clamav-win32/ is the correct address. Just take the index.php of the end. Kerio might want to update the KB articles.
  •  
winkelman

Messages: 2119
Karma: 3
Send a private message to this user
Thought I might add a little comment, perhaps it might help:

I use ClamAV on KMW under Windows. Now it runs smoothly, but at first at was not very stable. Every few days ClamAV would choke on scanning a file, thus causing fairly big troubles, because when the AV scanner is no longer available Kerio assumes all attachments to contain viruses. (Logic of that: you ask KMS to scan, it can't, then takes the precautionary position that everything contains a virus).

By default (and by the Kb article if I remember correctly) ClamAV and Kerio are set to just pass the file path to be scanned to ClamAV. This is very efficient (no need for copying data), but seemed to cause problems for me. When I set ClamAV and Kerio to not just send the file path, but to actually send the complete message along a (internal) TCP-pipe, all my problems vanished. In theory this is somewhat more work and might adversely effect your servers performance. In practice, (in my case) the difference in system load is unmeasurable.
  •  
reny75

Messages: 29
Karma: 0
Send a private message to this user
hello,
I am trying to install clamav for windows and use it with KMS.
I have downloaded the file clamav-0.91.2-5 from the link http://www.sosdg.org/clamav-win32/.
I installed it and before to configure as service I tried to execute it manually.
It give me always an error that says "Impossible execute specified application. cygclamav-3.dll was't found.a new installation could solve problem."
I have read some documentation but I can't find a solution.
Can someone help me?

thank you
Renato
  •  
reny75

Messages: 29
Karma: 0
Send a private message to this user
in the directory c:\clamav-devel\bin there is cygclamav-2.dll.
Can I change only this library?
If yes, where can I found new library?

thank you
renato
  •  
winkelman

Messages: 2119
Karma: 3
Send a private message to this user
Download ClamAV again, there was a problem with the packaging and the '3' dll was accidentally left out. It's solved in the new package.
  •  
reny75

Messages: 29
Karma: 0
Send a private message to this user
thank you I'll download it immediately
  •  
microalps

Messages: 168
Karma: 0
Send a private message to this user
As of yesterday some of the mirrors did not have the latest version. The Google Code Mirror did have the latest. Majorgeek and Betanews still have an outdated copy. You need clamav-0.91.2-5a.exe not clamav-0.91.2-5.exe...
  •  
reny75

Messages: 29
Karma: 0
Send a private message to this user
ok ,I have installed latest version 5a but I am unlucky or I miss something.
I tried to configure clamd.conf and I think that is ok
but when I start "START CLAMD" batch it always give me
this error "Impossible find access point cli_ac_setdepth of procedure in the dynamic link library cygclamav-3.dll".
I have read all documentation but I can't find anything.
Can someone help me please?

thank you

[Updated on: Tue, 20 November 2007 09:04]

  •  
reny75

Messages: 29
Karma: 0
Send a private message to this user
all is ok!!

thank you
Previous Topic: Move server, or use different mail storage location?
Next Topic: Windows Active Directory Authentication Problem
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Nov 18 05:30:25 CET 2017

Total time taken to generate the page: 0.00503 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.