Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » KOC with Outlook 2003 Error
  •  
andykap

Messages: 5
Karma: 0
Send a private message to this user
I know this is an Outlook message, but I can't get past the following error message using Kerio Outlook Connector with Outlook 2003 SP2:

"The specified default store could not be opened."

I'm using the latest version of Kerio Mail Server (6.4.2 build 4490) and KOC. I have Kerio Firewall on the server. I verified that I can bring up WebMail both securely and not on the standard ports (443 and 80, respectively). When I setup the Kerio account in Outlook I can successfully check the connection and it return back my name and e-mail address. IMAP works just fine, too. The Kerio Synchronization plugin works just fine, but I would like to make use of the KOC.

I just don't know what to do at this point and would appreciate any help.

Andy
  •  
simonkenning

Messages: 34
Karma: 1
Send a private message to this user
Hello Andy,

Have you tried disabling your antivirus client on your PC - especially any email scanning agent that could interfere with KOC? I have found this to be a problem in the past.

Regards,
Simon Kenning
  •  
andykap

Messages: 5
Karma: 0
Send a private message to this user
Simon,

Yes, I did, but thanks for the thought. I have Symantec at work and AVG Free (which as far as I know doesn't even scan e-mails) at home and both have the same problem, which is why I was looking at the server as the problem.

Andy
  •  
simonkenning

Messages: 34
Karma: 1
Send a private message to this user
Hi Andy,

It must be a firewall issue then. If you are using KOC with SSL connection then you will need to ensure that port 993 is open (IMAPS) on the firewall, or otherwise for unsecured connection ensure port 143 is open (IMAP). I believe that the test function in KOC uses HTTP or HTTPS and not IMAP/IMAPS so that would possibly explain why it returned your account details. Let me know if this helps further.

Best Regards,
Simon
  •  
andykap

Messages: 5
Karma: 0
Send a private message to this user
Once again, thanks Simon, but that's not it either. I can successfully use both IMAP and IMAPS from Outlook without KOC. For a sanity check I added debugging on the mail server. Here's my log when attempting to open Outlook using a profile that only contains an account for KOC:

[20/Dec/2007 23:04:47][6740] {imaps} IMAPS server session begin; client connected from MyIPaddress:1070
[20/Dec/2007 23:04:47][6740] {imaps} Command LOGIN UserID <password>
[20/Dec/2007 23:04:47][6740] {imaps} User UserID<_a.t_>domain.com logged in
[20/Dec/2007 23:04:47][6740] {imaps} Command K1 STATUS "INBOX" (MESSAGES RECENT UIDNEXT UIDVALIDITY UNSEEN AMESSAGES GUID)
[20/Dec/2007 23:04:47][6740] {imaps} Command K2 LOGOUT
[20/Dec/2007 23:04:47][6740] {imaps} Server session end
[20/Dec/2007 23:05:00][4016] {imaps} Command ZZZZ LOGOUT
[20/Dec/2007 23:05:00][4016] {imaps} Server session end
[20/Dec/2007 23:05:09][8168] {imaps} IMAPS server session begin; client connected from MyIPaddress:1072
[20/Dec/2007 23:05:09][8168] {imaps} Command LOGIN UserID <password>
[20/Dec/2007 23:05:09][8168] {imaps} User UserID<_a.t_>domain.com logged in
[20/Dec/2007 23:05:09][8168] {imaps} Command K1 X-CHECKVERSION 6.4.2
[20/Dec/2007 23:05:09][8168] {imaps} Command K2 CAPABILITY
[20/Dec/2007 23:05:09][8168] {imaps} Command K3 LIST (GUID MYRIGHTS X-CLASS MESSAGES AMESSAGES UNSEEN X-MAILBOXSIZE X-MAPPED X-ALL) "" "*"
[20/Dec/2007 23:05:09][8168] {imaps} Command K4 GETANNOTATION "__keriomapi__STORE" ("*" value)
[20/Dec/2007 23:05:09][8168] {imaps} Command K5 X-USERINFO
[20/Dec/2007 23:05:09][8168] {imaps} Command K6 CREATE (X-TODO) "Tasks"
[20/Dec/2007 23:05:09][8168] {imaps} Command K7 LOGOUT
[20/Dec/2007 23:05:09][8168] {imaps} Server session end

I tried it twice and both times Outlook gave the error after the 2nd "Server session end", yet obviously something is still happening. I don't know if any of that information is meaningful or if it's normal as I have nothing to compare it to.

Thanks again,

Andy
  •  
andykap

Messages: 5
Karma: 0
Send a private message to this user
No sooner did I send that last message then I realized from the log what the problem was. My Tasks folder was just a regular mail items folder. I had had the same problem with Calendar and Contacts and fixed those to get the Synchronization plugin working, but didn't fix Tasks.

I copied the Task folder from another user since I don't use it at all and KOC started working just fine.

Simon, thanks for taking the time to help me.

Andy
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
Please NEVER copy any folder or mailbox directly in the message store. It will broke synchronization to many e-mail clients because there will be duplicate folder identifiers (GUIDs).

Remove the file status.fld and it will be automatically re-created with new GUID by KMS.
  •  
andykap

Messages: 5
Karma: 0
Send a private message to this user
Thanks, Pavel. That's good to know. I didn't see a problem, but that's probably because the account I copied from doesn't use any of those folders (neither from WebMail nor Outlook), so I guess there was no sync issue.

I deleted the 3 status.fld files in the 3 affected folders and everything seems to be working.

Andy
Previous Topic: the fabled KOC Offline
Next Topic: Can't connect to localhost with 6.4.2-4490 for windows
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Nov 24 21:20:14 CET 2017

Total time taken to generate the page: 0.00427 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.