Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Control » DNS error (DNS lookup failed)
  •  
pradeep

Messages: 11
Karma: 0
Send a private message to this user
Network setup: workgroup,no dns dhcp servers, i have installed the winroute version 6.0 on a windows xp professional machine, after configuration it was working fine with about 30 users until one day everyone was getting the message DNS lookup failed, i researched and tried doing an ipconfig /flushdns, as well as editing the registry under hkey_local_machine\system\currentcontrolset\services\dnscach e\parameters, created a new DWORD stating MaxNegativeCacheTtl with value 0, also created anther DWORD MaxCacheTtl with value 14400 as decimal base. This worked fine under dialup settings but when i changed to dsl the error returned, now no one is getting through i tried flushing the dns again but nothing working still.

Please help, what do i do now, i am stuck
  •  
winkelman

Messages: 2119
Karma: 3
Send a private message to this user
Why are you running such an old version of KWF? It must be years old...
  •  
pradeep

Messages: 11
Karma: 0
Send a private message to this user
hi, i know i am running kerio winroute firewall ver6.0, i believe the latest is 6.4, if i am not mistakken, because we puchased this in the middle of last year, i just want to resolve that DNSlookup failed error on the clien machines, since i changed from dialup to dsl, i used the dial basically to test and configure while the company network was using the dsl, so i came on a saturday to switch to the dsl and error proped up, any suggestions guys i really need this resolved,thanks
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
Well, let's strart with basic questions:

1. Do you use DNS forwarded in KWF or you are using another DNS server in client PCs?
2. Did you configure proper DNS servers in DNS forwarded in KWF. Remember that changing internet conenction usually means that DNS servers must be changed too.
3. What does the error and debug log say?
  •  
pradeep

Messages: 11
Karma: 0
Send a private message to this user
Hi,

OK, the error occured on the 5th of january after transferring from the dial up to the dsl, the error and debug log for that day is, see below. No, DNS forwarder is not enabled in the kerio winroute, i do not have any dns servers configured here. Could this be the reason after the change in the internet connection from dialup to dsl is causing this, if so could you explain why, also, what other matters to take into place and should i enable the dns forwarder.

error : Unable to initialise IP pool, unable to read VPN adapter configuration. Unable to open VPN driver. Unable to create VPN server oject - VPN library not initialised.

debug : see attachment please
  •  
winkelman

Messages: 2119
Karma: 3
Send a private message to this user
If you don't use DNS Forwarding, your clients must be using your ISP's DNS servers directly. Since you've changed ISP (or at least changed the access method), you should change those DNS servers to the proper ones as well.
  •  
pradeep

Messages: 11
Karma: 0
Send a private message to this user
Ok I have enabled the DNS forwarding on the winroute. I had two options 1) to forward DNS queries to the server automatically selected from DNS servers known to the operating system. 2) forard DNS queries to the specified DNS server.

I tried both but on the client machines i am still getting DNS lookup failed. For the second option i chose as the DNS server the ip address of the machine accessing the internet (the same winrote firewall machine). On the client machine i put in for the gateway and preferd DNS settings the ip address of the machine.

Can you provide me other alternatives it is getting pretty drastic now.
  •  
pradeep

Messages: 11
Karma: 0
Send a private message to this user
can you provide me with any other info on what could i do now to fix. Also by upgrading to kerio winroute firewall 6.4 be a possible fix. Help please.
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
Please follow standard troubleshooting procedure (as described in the manual). Enable debug logging for DNS and create a packet dump pf DNS (UDP port 50) by Wireshark.
  •  
armandox

Messages: 1

Karma: 0
Send a private message to this user
pradeep wrote on Thu, 17 January 2008 07:55
Hi,

tengo este error la vpn me aparece de esta forma: Unable to Open VPN Driver
necesito habilitarla sin problemas alguno si sabes como te agradeceria.

OK, the error occured on the 5th of january after transferring from the dial up to the dsl, the error and debug log for that day is, see below. No, DNS forwarder is not enabled in the kerio winroute, i do not have any dns servers configured here. Could this be the reason after the change in the internet connection from dialup to dsl is causing this, if so could you explain why, also, what other matters to take into place and should i enable the dns forwarder.

error : Unable to initialise IP pool, unable to read VPN adapter configuration. Unable to open VPN driver. Unable to create VPN server oject - VPN library not initialised.

debug : see attachment please

Previous Topic: Client IP address / HTTP_X_FORWARDED_FOR
Next Topic: 2 Multiple websites behind firewall
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Sep 26 03:55:02 CEST 2017

Total time taken to generate the page: 0.00431 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.