Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Mcafee Not Updating (Mcafee Not Updating)
  •  
neilwr

Messages: 40
Karma: 0
Send a private message to this user
[11/Feb/2008 00:58:49] AvPlugin.cpp: Antivirus Server error(0): Downloaded file update.ini is corrupted or missing
[11/Feb/2008 00:58:49] AvPlugin.cpp: Antivirus Server error(0): Cannot load actual version from server.
[11/Feb/2008 00:58:49] AvModule.cpp: Antivirus update failed: McAfee Scanning Engine (5209/5.2.00), plugin will be restarted
[11/Feb/2008 05:58:53] AvPlugin.cpp: Antivirus Server error(0): Downloaded file update.ini is corrupted or missing
[11/Feb/2008 05:58:53] AvPlugin.cpp: Antivirus Server error(0): Cannot load actual version from server.
[11/Feb/2008 05:58:53] AvModule.cpp: Antivirus update failed: McAfee Scanning Engine (5209/5.2.00), plugin will be restarted
[11/Feb/2008 06:58:47] AvPlugin.cpp: Antivirus Server error(0): Downloaded file update.ini is corrupted or missing
[11/Feb/2008 06:58:47] AvPlugin.cpp: Antivirus Server error(0): Cannot load actual version from server.
[11/Feb/2008 06:58:47] AvModule.cpp: Antivirus update failed: McAfee Scanning Engine (5209/5.2.00), plugin will be restarted
[11/Feb/2008 07:45:49] AvPlugin.cpp: Antivirus Server error(0): Downloaded file update.ini is corrupted or missing
[11/Feb/2008 07:45:49] AvPlugin.cpp: Antivirus Server error(0): Cannot load actual version from server.
[11/Feb/2008 07:45:49] AvModule.cpp: Antivirus update failed: McAfee Scanning Engine (5209/5.2.00), plugin will be restarted

I have to manually update the virus definitions.

I have also updated the scan engine to reflrect mcafee new engine 5.2.00

Any help in updating or do I have to do it manually.

update.ini points to wrong location by looks of it.
[SCM]
EngineVersion=0
DATVersion=5226
FileName=scm-5226.zip
FilePath=/pub/antivirus/datfiles/4.x/ = incorrect
FilePath=/pub/datfiles/english/ = correct
FileSize=21412466
Checksum=CAF7,3F52
MD5=9a3c6bfc70108cc8007686d7023fe54c

[Updated on: Sun, 10 February 2008 23:00]

  •  
winkelman

Messages: 2119
Karma: 3
Send a private message to this user
neilwr wrote on Sun, 10 February 2008 22:55


I have also updated the scan engine to reflrect mcafee new engine 5.2.00

This makes me suspicious... How did you update the scan engine? If you use the KMS integrated McAfee, you cannot/should not update the scan engine, except if KMS updates it itself. (The only way the scan engine will be updated is if an KMS update includes a McAfee scan engine update...)
  •  
freakinvibe

Messages: 1552
Karma: 62
Send a private message to this user
When did this happen for the first time? After you have updated the scan engine?

You should not update the scan engine yourself.

If you have just overwritten the McAfee DLL, try to restore the old version.

Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
  •  
neilwr

Messages: 40
Karma: 0
Send a private message to this user
Ok it seems that the scan engine was the problem.

I updated it by stopping the services and copying over the mscan32.dll then starting the services again.

Kerio should allow you to update the scan engine at will and not be relient on other files.

I replaced it back to the old version and update checking seems to be working now.
  •  
freakinvibe

Messages: 1552
Karma: 62
Send a private message to this user
No, Kerio can't allow to update that DLL. They have no control what changes and new functions are included with newer versions. Only McAfee has control over this. So Kerio has first to test newer releases and then include them in the latest Kerio version.

Why have you upgraded to 5.2? Any important new features you need? Or did you just do it for the sake of upgrading?

Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
Previous Topic: Calander/Tasks Font Formatting
Next Topic: KMS in Bridgehead setup
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Nov 18 11:32:46 CET 2017

Total time taken to generate the page: 0.00412 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.