Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Serious problem. Not sure if Kerio or Outlook caused. (MIME formated message from draft save is wrong...)
  •  
scottwilkins

Messages: 654
Karma: 7
Send a private message to this user
We found a serious problem and I'm unsure if it caused by Kerio's Outlook Connector or by Outlook itself. We tested this in Outlook 2003 and 2007, and with KOC and KOFF 6.5.0. It occurs in all versions.

Our Outlook is setup normally to send HTML encoded messages. Which for a MIME message will actually send both raw unformatted text and HTML, both contained in the same message. One of our employees wrote an e-mail, and before sending saved to drafts. Later he opened the e-mail, changed some of it and sent it. The recipient replied asking about the message, and it turned out the message they received was the original un-edited version. Yet a CC'd employee recieved the correct version.

You can imagine the trauma that followed...

Examining the messages in the message store, I found that the message had kept the original unedited version in the raw text, and the edited version in the HTML side. So the recipient apparently had an e-mail client that only accepted the raw text format, and discarded the HTML formated message. Our CC'd employee saw the edited HTML in her inbox, so all appeared correct, but actually was not.

So, is this problem caused by the Kerio Connector, or by Outlook itself? It is odd that it happens in 2003 and 2007 Outlook, and with either the off or on-line version of the connector. Anyone heard of this before?
  •  
sedell

Messages: 1168
Karma: 1
Send a private message to this user
Confirmed. I'm getting the same behavior with Outlook 2003 and KOFF. The plain text portion of the message is not modified. Time to fill out a support ticket. This one could be a serious problem if recipients view mail in plain text only.

Scott
  •  
scottwilkins

Messages: 654
Karma: 7
Send a private message to this user
Ticket is filled out and waiting... Definitely a problem, but I think I found a work-around. It seems this problem does not occur if your message format is rich text or plain text rather than HTML. Unfortunately Outlook's default is HTML. I haven't tested all scenarios yet on this, but if this works for now, at least it will keep us from serious embarrassment.
  •  
scottwilkins

Messages: 654
Karma: 7
Send a private message to this user
sedell wrote on Wed, 12 March 2008 13:20

Confirmed. ... This one could be a serious problem if recipients view mail in plain text only.


I'd also like to point out that if the recipient is using a Blackberry or WM phone or other PDA/Smartphone, the text version is what they'll get. The text version of any formated e-mail is what's shows on these handheld devices through their normal e-mail software. That's how we found out the problem.
  •  
sedell

Messages: 1168
Karma: 1
Send a private message to this user
Mine is in too.

We don't have RTF available to us. I had to disable it across the board because of compatibility issues we had with some companies we deal with. It wasn't the first time I've seen RTF mail issues, and I'm sure it won't be the last.

I did test it with plain text, and that seems to work properly. Try convincing users to use that over HTML, though. We also have a couple of applications that tie into Outlook and require HTML mail, so those would be broken if I disabled HTML.

Scott
  •  
Lukas Petrlik (Kerio)

Messages: 117
Karma: 7
Send a private message to this user
There is a workaround - save the message before you send it.

Lukas Petrlik
Kerio Technologies
  •  
scottwilkins

Messages: 654
Karma: 7
Send a private message to this user
petrlik wrote on Fri, 14 March 2008 12:43

There is a workaround - save the message before you send it.

Lukas Petrlik
Kerio Technologies


Awesome! Thanks Lukas!
  •  
rfisher

Messages: 17
Karma: 0
Send a private message to this user
can we expect a permanent resolution in an up and coming release of Kerio?
  •  
Lukas Petrlik (Kerio)

Messages: 117
Karma: 7
Send a private message to this user
rfisher wrote on Fri, 14 March 2008 21:40

can we expect a permanent resolution in an up and coming release of Kerio?


We are working on this one. We will issue a patch.

Lukas Petrlik
Kerio Technologies
  •  
rfisher

Messages: 17
Karma: 0
Send a private message to this user
  •  
  •  
rfisher

Messages: 17
Karma: 0
Send a private message to this user
  •  
jtoussaint

Messages: 13
Karma: 0
Send a private message to this user
As reported above the issue is happening in both KOC and KOFF, but the change log only states KOFF is affected. Does the patch correct the issue in both KOC and KOFF? We are still on KOC and I am wondering if I need to jump on this patch yet or if I can wait until I get some users on KOFF.
Previous Topic: mail_queue.cpp failure
Next Topic: Temporarily rejected: sender domain does not resolve
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Nov 23 06:45:44 CET 2017

Total time taken to generate the page: 0.00508 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.