Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Control » SVN through http proxy (bad request on svn commands)
  •  
PaulIsh

Messages: 2
Karma: 2
Send a private message to this user
Is it allowed somehow to enable 'REPORT' 'PROPFIND' and other svn requests on http proxy? Without that users cannot use built-in http proxy with svn client software.

Please help.
  •  
PaulIsh

Messages: 2
Karma: 2
Send a private message to this user
Does anybody have problems with that? If so then whether this in todo?
  •  
HughesR

Messages: 1
Karma: 1
Send a private message to this user
I have exactly the same problem that PROPFIND requests are being blocked meaning I can't access SVN. Its been two years, is this working yet?
  •  
agattorno

Messages: 8
Karma: 1
Send a private message to this user
I have exactly the same problem and i use the last version...
Any solution?
  •  
agattorno

Messages: 8
Karma: 1
Send a private message to this user
I have the proxy configured like the documentation and the browsers too. My problem is with subversion. I´m trying to connect to my svn server to update the files of my proyects and i get an 400 error.

On the TortoiseSVN site I found something about this 400 error:
You're behind a firewall which blocks DAV requests. Most firewalls do that. Either ask your Administrator to change the firewall, or access the repository with https instead of http

But i need access to http.

svn use others HTTP methods like PROPFIND, REPORT, MERGE, MKACTIVITY, and CHECKOUT, and not all proxy server support it.

Seems like Kerio Control not support all http methods. with svn desktop clients like tortoise i have a error but with the browser i can access to the repository url. And with the previous proxy of my company (ISA Server) don´t had this problem.

Kerio not suport the webDav http methods?
  •  
agattorno

Messages: 8
Karma: 1
Send a private message to this user
is official, this problem look like a bug of Kerio Control. I probe in others lan with other proxys like squid and isa server and all be fine...

how i can report this bug??? i need solve this problem or i will have to migrate to another proxy sistem...

please any idea or suggestion???
Sad Sad Sad Sad
  •  
agattorno

Messages: 8
Karma: 1
Send a private message to this user
***SOLVED***
the update 8.3.3 solved this problem. Now i can update and commint correctly, thanks.
Previous Topic: Forced logout from web admin
Next Topic: Found a bug in Control
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Aug 24 01:04:50 CEST 2017

Total time taken to generate the page: 0.00454 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.