Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » bad locale name
  •  
sedell

Messages: 1168
Karma: 1
Send a private message to this user
Since upgrading to 6.5.0, I've been seeing the following periodically in my warning logs:

[12/May/2008 18:14:29] Locale support for language zh (Chinese) is not installed on the system: bad locale name

Any idea what causes that - a webmail login, errors on a client machine, message encoding on something that was delivered to the server? We don't have anyone here using Chinese languages. I can't find anything in the other log files that correlate with the times on these warnings, so I'm at a loss. I'd start enabling more in the debug log, but I don't know what to enable to look for it. Enabling everything isn't an option - this only happens once or twice a day, and full debugging for an entire day would swallow the HDs on the machine I think.

Scott
  •  
winkelman

Messages: 2119
Karma: 3
Send a private message to this user
I've had such a thing happen to me a few years back after starting to use KMS. The message here was about the Japanese language.

We are a company with 'Webmail only' (well, 98%) and a lot of our partly Japanese staff set their Webmail to Japanese. Now I don't know why this would affect the server, but it seems the server also needs that language supported. I got the same message as you and it went away after I gave my server Japanese language support.

Well, I didn't even do that properly in the OS; I just surfed to a Japanese website on the server and Internet Explorer then asked me if I'd like to install a Japanese language pack. I went along and gone was the error message...

Perhaps some of your users set Webmail to Chinese? You may try my 'solution' for Chinese. (Having a Chinese language pack on the server doesn't affect anything, you don't have to make it default or whatever. It's harmless to try. Mind you, I did not even install the language properly in the OS through Regional Settings etc. Yes, it surprised me as well that it helped Smile)
  •  
sedell

Messages: 1168
Karma: 1
Send a private message to this user
You nailed that one on the head. I logged into webmail, set the preferred language to Chinese, and instantly got the same warning entered in the warning log - then had to struggle to set it back because I couldn't read the menus Wink. I've never seen that before. I didn't think web or mail servers needed to have language packs installed on them.

Scott
Previous Topic: Out of Memory error
Next Topic: Kerio 6.5.1 & M$ Active Directory
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Sep 21 07:07:44 CEST 2017

Total time taken to generate the page: 0.00395 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.