Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Control » Port mapping...
  •  
edblars

Messages: 3
Karma: 0
Send a private message to this user
I'm sure someone has asked a similar question before, but i still haven't been able to fix my problem, so i hope someone can help me here...

First of all, this is the situation:

I have a network, consisting of about 6 computers, all connected to the internet via the firewall computer, from now on refered to ass the LAPSERVER. This LAPSERVER has two network cards, one connected to the adsl-modem, the other one goes to a switch, which the rest of the network is connected to.

On the firewall/LAPSERVER there is a webserver running, and i had no problem configuring the firewall to work with this service. However, my problem is that i have another service running on another computer on the network, the TVSERVER. The address to the service running on the TVSERVER is TVSERVER:8080.

What i want to achieve is that when "myip:someport" is accessed, it should be mapped on to TVSERVER:8080

Does anyone know how i can configure the firewall (Winroute 5.1.8 ) to do this? If yes, please give me a step-by-step explanation, or a screenshot of the configuration?!

  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
edblars wrote on Wed, 24 March 2004 13:44

I'm sure someone has asked a similar question before, but i still haven't been able to fix my problem, so i hope someone can help me here...

First of all, this is the situation:

I have a network, consisting of about 6 computers, all connected to the internet via the firewall computer, from now on refered to ass the LAPSERVER. This LAPSERVER has two network cards, one connected to the adsl-modem, the other one goes to a switch, which the rest of the network is connected to.

On the firewall/LAPSERVER there is a webserver running, and i had no problem configuring the firewall to work with this service. However, my problem is that i have another service running on another computer on the network, the TVSERVER. The address to the service running on the TVSERVER is TVSERVER:8080.

What i want to achieve is that when "myip:someport" is accessed, it should be mapped on to TVSERVER:8080

Does anyone know how i can configure the firewall (Winroute 5.1.8 ) to do this? If yes, please give me a step-by-step explanation, or a screenshot of the configuration?!




I assume the "myip" address is an IP address of the Internet (external) interface on the firewall. If not, let me know.

Create a new rule in Traffic Policy:

Source: external interface (Internet)
Destination: Firewall
Service: TCP "someport"
Action: Allow
Translation: destination address "myip", destination port 8080

Now the TVSERVER will be accessible as "myip:someport" from the Internet.
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
PavelDobry wrote on Wed, 24 March 2004 16:54

edblars wrote on Wed, 24 March 2004 13:44

I'm sure someone has asked a similar question before, but i still haven't been able to fix my problem, so i hope someone can help me here...

First of all, this is the situation:

I have a network, consisting of about 6 computers, all connected to the internet via the firewall computer, from now on refered to ass the LAPSERVER. This LAPSERVER has two network cards, one connected to the adsl-modem, the other one goes to a switch, which the rest of the network is connected to.

On the firewall/LAPSERVER there is a webserver running, and i had no problem configuring the firewall to work with this service. However, my problem is that i have another service running on another computer on the network, the TVSERVER. The address to the service running on the TVSERVER is TVSERVER:8080.

What i want to achieve is that when "myip:someport" is accessed, it should be mapped on to TVSERVER:8080

Does anyone know how i can configure the firewall (Winroute 5.1.8 ) to do this? If yes, please give me a step-by-step explanation, or a screenshot of the configuration?!




I assume the "myip" address is an IP address of the Internet (external) interface on the firewall. If not, let me know.

Create a new rule in Traffic Policy:

Source: external interface (Internet)
Destination: Firewall
Service: TCP "someport"
Action: Allow
Translation: destination address "myip", destination port 8080

Now the TVSERVER will be accessible as "myip:someport" from the Internet.


Sorry, there is a typo..
It should be:

Source: external interface (Internet)
Destination: Firewall
Service: TCP "someport"
Action: Allow
Translation: destination address TVSERVER, destination port 8080
  •  
edblars

Messages: 3
Karma: 0
Send a private message to this user
thanks for the reply, but it still doesn't work... Have a look at the screenshot i've attached, does it look correct? And yes, by "myip" I did mean my external internet ip. Smile

  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
edblars wrote on Thu, 25 March 2004 07:09

thanks for the reply, but it still doesn't work... Have a look at the screenshot i've attached, does it look correct? And yes, by "myip" I did mean my external internet ip. Smile


Yes, it's correct.
Enable 'Log matching packets' option in the traffic rule.
Try to access myip:9090 from the Internet and have a look at the filter log.
  •  
Jeff Wadlow (Kerio)

Messages: 162
Karma: 6
Send a private message to this user
Is the default gateway of the tvserver the IP address of the WinRoute host machine? If not then set your rule to do source NAT too with the IP address of the LAN network card.

Example:
Source: external interface (Internet)
Destination: Firewall
Service: TCP "someport"
Action: Allow
Translation:source NAT with Local Area Connection
destination address "tvserver", destination port 8080
  •  
edblars

Messages: 3
Karma: 0
Send a private message to this user
Hi

Still not working... Sad The default gateway of the tvserver is the winroute host machine, 192.168.0.1

When i try the http://myip:9090 i just get the "The page cannot be displayed" message. I've turned of the "show friendly http error messages", but i still get the same message... Maybe you could have a look at the new screenshot i've attached, just to check that i haven't done anything wrong there...?

Cheers

Previous Topic: Users
Next Topic: users/ hosts and traffic chart problem
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Nov 24 03:07:25 CET 2017

Total time taken to generate the page: 0.00408 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.