Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » ClamAV Crashes
  •  
rproctor

Messages: 2
Karma: 0
Send a private message to this user
I'm using kero mailserver 6 with clam av. I frequently receive errors that: "Antivirus check of mail from ... Plugin is not responding." I then have to restart the service and then wait for the next error. Is this a known issue with clamav? Is there a fix for it?
  •  
winkelman

Messages: 2119
Karma: 3
Send a private message to this user
On what platform are you running KMS and ClamAV?
  •  
rproctor

Messages: 2
Karma: 0
Send a private message to this user
  •  
winkelman

Messages: 2119
Karma: 3
Send a private message to this user
Ah, I had similar issues on my win 2003 server a few years back when starting to use ClamAV. What solved it for me is putting ClamAV into network mode instead of the default local mode.

Default Kerio is just passing file locations to ClamAV to scan. So Kerio stores a temporary file somewhere and that tells ClamAV to scan 'C:\Temp\xxxx.tmp' (totally fake path). This is very economical, because the email itself does not have to be transferred in total to ClamAV, just the path. But this turns out to give issues (for me anyway, perhaps for you as well).

Note: in theory network mode is more work for the server, because it has to pass along the entire to-be-scanned message to the ClamAV scanner. In practice though: I didn't find any performance loss.

Some relevant clamd.conf entries:
Quote:

# The daemon works in a local OR a network mode. Due to security reasons we
# recommend the local mode.

# Path to a local socket file the daemon will listen on.
# Default: disabled (must be specified by a user)
# LocalSocket /cygdrive/c/clamav-devel/clamd.sock

# Remove stale socket after unclean shutdown.
# Default: no
# FixStaleSocket yes

# TCP port address.
# Default: no
TCPSocket 3310

# TCP address.
# By default we bind to INADDR_ANY, probably not wise.
# Enable the following to provide some degree of protection
# from the outside world.
# Default: no
TCPAddr 127.0.0.1


And then instruct KMS to use this new mode as well:
Quote:

Kerio Mailserver --> Configuration --> Content Filter --> Antivirus --> Options:
Address: 127.0.0.1
IgnoreStartupErrors: 0
Port: 3310
StartupTimeout: 90
UseStreamOnLocalhost: 1


Since I set it like this I haven't had a single issue with ClamAV. Cool
Previous Topic: footer message
Next Topic: calendar folder limit
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Sep 23 09:34:19 CEST 2017

Total time taken to generate the page: 0.00412 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.