Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » iPhone 2.0 Exchange Settings for KMS 6.5
  •  
markbucher17078

Messages: 1
Karma: 0
Send a private message to this user
Am unable to achieve successful connection with Kerio Mailserver 6.5 from iPhone 2.0 Exchange settings.
Could someone reply with successful settings for each option under Exchange server configuration.

Thanks.
  •  
fastred

Messages: 16
Karma: 0
Send a private message to this user
Hi Mark

I don't think that the iPhone is yet *fully* supported by Kerio. However, I have had success with the following, to some extent:

[Removed by Moderator ]

Then restart the server.


This works - but not completely. I cannot download/view attachments. But at least I get my email.

Presumably Kerio will be releasing an update for Mailserver soon, to bring full compatibility with the iPhone.

Jeremy

[Updated on: Thu, 17 July 2008 18:14] by Moderator

  •  
My IT Indy

Messages: 1262
Karma: 40
Send a private message to this user
Out of the box your iPhone won't work with 6.5.1. The iPhone has a different version of Activesync than KMS supports. You will need an update to KMS for *full* support of the iPhone.

That's all I'm gonna say.

-
My IT Indy
Kerio Certified Reseller and Hosted Provider
http://www.myitindy.com
  •  
vizion

Messages: 7
Karma: 0
Send a private message to this user
do calendars and contacts work ?
  •  
fastred

Messages: 16
Karma: 0
Send a private message to this user
Yes - contacts and calendars work, using the "workaround" above.

Jeremy
  •  
jshaw541

Messages: 462
Karma: 0
Send a private message to this user
Is anyone else encountering a severe battery drain issue with today's released 2.0 ROM for the 1st generation iPhone, and an Exchange account?

No matter what push/fetch settings i set globally, or for the Kerio Exchange account, it pushes constantly with the server (according to the debug.log). Battery dies after about 2.5 hours.

I don't want to file an official bug at this point. Engineers can hit me on gtalk at perdurabo at gmail, if they wish...

[Updated on: Fri, 11 July 2008 21:34]


Kerio MailServer 6.7.1 w/AD
Windows Server 2003 SP 1
Dell PowerEdge 2850 (Dual Xeon 3.2ghz and 2 GB RAM)
~1300 users
~1000+ concurrent IMAPS connections
iPhone users
Outlook 2007 KOFF users
Apple iCal 10.5/10.6 users
  •  
My IT Indy

Messages: 1262
Karma: 40
Send a private message to this user
Sadly enough I wasn't able to get an iPhone today, having to order one from ATT Wireless instead. I'll probably get it in a week or so.

I hope the battery doesn't die that quickly, I know my HTC TyTN would get low around 2pm if I let it get email as it came in.

-
My IT Indy
Kerio Certified Reseller and Hosted Provider
http://www.myitindy.com
  •  
vizion

Messages: 7
Karma: 0
Send a private message to this user
Turning off 3G will conserve power.
  •  
microalps

Messages: 168
Karma: 0
Send a private message to this user
6.5.2 will introduce partial iPhone support with full support in a later version.

See http://forums.kerio.com/index.php?t=msg&th=13669&sta rt=0&S=79f767fe058c46502e4189e2a054b3c8#msg_num_2 for an "official" replu from Kerio Staff.

[Updated on: Sun, 13 July 2008 07:27]

  •  
bigmountain

Messages: 116

Karma: 0
Send a private message to this user
I had gone ahead and modified my config to allow for unsupported devices as per the other post. It works just as described. I noticed two things:

1. images are not downloaded within received html messages, nor are attachments made available. You can see that there is an attachment by the paper clip in the message list, but when you scroll down the message, the attachment is not there. I had one client who said that some jpg and pdf's were going through ok, but all else was missing.

2. If you have access to any shared contacts or calendar folders, they will be made available in the calendar and contacts on the iPhone. This is very cool, but it does generate an error in the error logs every time the phone tries to sync up any changes. I am not sure what the error is and had forgotten to write it down when it happened. Basically it just said that my username was trying to access the shared calendar. Anyway, all else seemed to work just fine and I did not notice anything that was not working.

I have dozens of iPhone users and everyone is extremely anxious to get this rolling. I am a little surprised that Kerio has not released the new version yet, but because I have so many people waiting for it and getting a little upset that we were not able to support them on day 1, that I allowed the "unsupported" service with the known bugs. I basically am telling each one of them what the issues are and if they choose to use ActiveSync prior to the actual Kerio supported version being released, then it is do so at your own risk. I do not see that it is breaking anything, just a few things not working properly and a few log error entries.

Does anyone else have any experiences they can share or any bugs that they have noticed in addition to the two I mentioned above?

Preferred Kerio Partner and Cloud Solutions Provider - Offering both shared and dedicated Kerio Connect hosting solutions.
Visit us at http://bigmountainmail.com
  •  
curmudgeon

Messages: 36
Karma: 0
Send a private message to this user
For the technically challenged, how does one modify the setting when running KMS 6.5 under Mac 10.5.4? Thanks for anyones help...
  •  
monsterfreecity

Messages: 60
Karma: 2
Send a private message to this user
[Removed by Moderator]

[Updated on: Thu, 17 July 2008 18:14] by Moderator

  •  
curmudgeon

Messages: 36
Karma: 0
Send a private message to this user
monsterfreecity,

Thank you very much, worked perfectly...

  •  
jshaw541

Messages: 462
Karma: 0
Send a private message to this user
bigmountain wrote on Sun, 13 July 2008 14:45


I have dozens of iPhone users and everyone is extremely anxious to get this rolling. I am a little surprised that Kerio has not released the new version yet, but because I have so many people waiting for it and getting a little upset that we were not able to support them on day 1, that I allowed the "unsupported" service with the known bugs.


Why would you be a little surprised? The official 2.0 software upgrade and the new iPhones only came out on Friday. You posted this on a Sunday, not even one full working day later. That's a little unfair.

Kerio aren't magicians, they need a little time to test, patch their software and test some more. In fact, I briefly worked with them on a rather serious issue with 2.0 and EAS on Friday.

In IT, it would not be wise to push the bleeding edge, if you're the impatient type. I'm kind of shocked that you're using unsupported hacks in a production environment, as well.

Just be patient, I have a strong hunch you'll see something this week. Kerio's as excited about getting the technology out as we are getting it.

Kerio MailServer 6.7.1 w/AD
Windows Server 2003 SP 1
Dell PowerEdge 2850 (Dual Xeon 3.2ghz and 2 GB RAM)
~1300 users
~1000+ concurrent IMAPS connections
iPhone users
Outlook 2007 KOFF users
Apple iCal 10.5/10.6 users
bigmountain

Messages: 116

Karma: 0
Send a private message to this user
I completely understand that the 2.0 release came out on Friday and I posted the comment on Sunday. The reason I was a little surprised has to do more with the fact that marketing has been contacting me for iPhone user's testimonials in preparation for a press release/marketing purposes, the fact that they had momentarily updated their website Friday morning (iphone page) supporting 2.0 release with Push and that I believed they had already had a copy of the 2.0 software under beta. I am sure that Kerio didn't just get the 2.0 update on Friday like the rest of us, at least I hope not!

Anyway, I understand your point of view and under normal circumstances I would agree 100% with you, including running this under a production environment. Trust me, if I saw any errors or anything else that indicated a compromise to my server or other client accounts, I would certainly pull this option for limited access. But so far, I have not seen anything other than what I mentioned and I monitor my servers and the logs multiple times a day, everyday. If there is something that I missed, please let me know. Other than that, I have told my clients to be patient and to not use the ActiveSync for iPhone yet, but if they do, I made sure they knew of the existing bugs and are ok with that. Most want to wait, but a couple opted to go ahead and use it.

Preferred Kerio Partner and Cloud Solutions Provider - Offering both shared and dedicated Kerio Connect hosting solutions.
Visit us at http://bigmountainmail.com
Previous Topic: LDAP Search Base in Apple's Address Book
Next Topic: Bounce messages
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Nov 22 21:31:06 CET 2017

Total time taken to generate the page: 0.00535 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.