Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Control » Remote Desktop not working (Remote Desktop not working)
  •  
sumit777

Messages: 5
Karma: 0
Send a private message to this user
i have newly installed Kerio Winroute Firewall (KWF) at home. Everything is working fine accept Remote Desktop. i m not able to configure it. however, i have tried the rule:

source: any
destination: firewall
service: rdp
action: enabled
translation (destination NAT): ip of remote computer

when i apply this rule all my computers stop working i.e. internet is blocked.(i have only 4 computers, 2 Laptops, 1 P-4, 1 p3. all have windows xp pro).

pls help.
  •  
dwar08

Messages: 6
Karma: 0
Send a private message to this user
sumit777 wrote on Tue, 30 September 2008 08:13

i have newly installed Kerio Winroute Firewall (KWF) at home. Everything is working fine accept Remote Desktop. i m not able to configure it. however, i have tried the rule:

source: any
destination: firewall
service: rdp
action: enabled
translation (destination NAT): ip of remote computer

when i apply this rule all my computers stop working i.e. internet is blocked.(i have only 4 computers, 2 Laptops, 1 P-4, 1 p3. all have windows xp pro).

pls help.


Are you trying to use Remote Desktop from within your network from one computer to another or from outside your network, like from work or a friends house? My remote desktop worked fine from within my own network with only the default rules applied. In fact, it's one of the few things I have not had trouble configuring.

Even from remote locations I do not have to have the rdp service enabled in a rule.... I just use the Client VPN to connect and then connect to the computer that has remote desktop enabled.

Did your Remote Desktop work before you installed the KWF firewall?
  •  
sumit777

Messages: 5
Karma: 0
Send a private message to this user
yes, it was working fine. however i m trying to view remote desktop of the pc on internet. i do not have any issue within the network. i m trying to view the remote desktop of a remote computer which is in another city from one of the computer in my network.
  •  
dwar08

Messages: 6
Karma: 0
Send a private message to this user
Is the remote computer behind a KWF firewall also? How are you trying to connect to it? Are you using a VPN? Is the remote computer behind any kind of firewall or gateway? Have you tried having the remote computer connect to one of your local computers? If so, does that work?
  •  
sumit777

Messages: 5
Karma: 0
Send a private message to this user
well! i think i m not able to explain you. let me explain you in detail.
i have installed kwf at my home where i have 4 computer systems. i m trying to view my friends computer through "remote desktop" which is in america at my friends place. i could do the same before i have installed KWF. i can also view the computer on my LAN at my home. but i m not able to view the computer which is in America via internet.
  •  
dwar08

Messages: 6
Karma: 0
Send a private message to this user
Try enabling the RDP service in your NAT traffic policy.
  •  
rykn21x

Messages: 12
Karma: 0
Send a private message to this user
hi sir i'm kind of new here in the forum... i just want to share the solution I did with regards to the problem you have...

in TRAFFIC POLICY add NEW POLICY

Name = Remote Desktop
Source = WAN
Destination = Firewall
Service = (just put Remote Desktop TCP & UDP Port)
Action = Permit
Log = (I log all incoming connections to my KWF)
Translation = MAP 192.x.x.x:xxxx (e.g MAP 192.168.0.1:3348) this is the IP address of the pc you want to remote and the :xxxx is the remote desktop port


This is working for me... and make sure you create this policy under the FIREWALL TRAFFIC..

I hope this helps!


  •  
raldridge

Messages: 9
Karma: 0
Send a private message to this user
I'm seeing this same issue. I've created an RDP rule to a PC on the trusted network using MAP translation, but it doesn't work. My RDP rule to the firewall PC works fine.
  •  
dgorman

Messages: 20
Karma: 0
Send a private message to this user
raldridge wrote on Thu, 16 October 2008 19:02

I'm seeing this same issue. I've created an RDP rule to a PC on the trusted network using MAP translation, but it doesn't work. My RDP rule to the firewall PC works fine.


So you are trying to RDP from a Remote location to a pc behind KWF??
If you can rdp to the server running RDP I think that might be the problem. KWF cannot do load balancing fro incoming connections, basically they way you have it configured at the moment is that you have two rules, first rule allowing RDP to the firewall, second rule a rdp rule traslation to the pc.
Kerio is top heavy so it will use the first rule it sees that qualifies ....I think

You will need to disable your rule for the rdp to the firewall temporarily, and then try connect to the pc with the Translation to ip rule..

** make sure you dont disable your console rule :)**
  •  
winkelman

Messages: 2119
Karma: 3
Send a private message to this user
If you want to have 'multiple RDP' destination, you have to map a different external port for each one.

For example:

Leave port 3389 unmapped, you'll use that to RDP to the firewall itself (connect to firewall.domain.com).

Map external port 3390 to internal PC-1 port 3389. You then tell the Remote Desktop client to connect to non-standard port 3390 if you want to view PC-1 (by specifying the port number in the client as firewall.domain.com:3390 )

Map external port 3391 to internal PC-2 port 3389.

Etc.
Previous Topic: Portscan from server
Next Topic: Cache uses only 1GB?
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Nov 24 06:56:39 CET 2017

Total time taken to generate the page: 0.00961 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.