Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » KOFF - Outlook 2007 SP1 Problems
  •  
vf1917

Messages: 5
Karma: 0
Send a private message to this user
Mail Server Version: 6.6.0 on Windows 2003 Enterprise SErver
Mail Client Version: Outlook 2007 SP1
KOFF Version: 6.6.0

Hi,

I'm currently running Kerio MailServer 6.6.0 on a Windows 2003 server platform and for some reason, I'm having trouble sending e-mail's via KOFF using Outlook 2007 SP1.

Upon sending from KOFF, a message pops up saying "Cannot connect to network. Verify your network connection or modem." The e-mail sits in the Outbox for a few seconds, disappears and re-appears in the local "Sent Items" folder. However, the message does not get sent and according to Kerio's console, that message never reached the server and never got sent.

What's also odd is that some e-mail's in the KOFF inbox open while others don't. I get a "Cannot open this item. Unknown error" message for the ones that don't open up. In the ones that do open up, those with attachments also error out with the message "Unknown error." I can see the text but I get the error message when trying to open the attachment.

What's weird is that all other e-mail accounts in Outlook, POP3, IMAP, HTTP etc... all work fine. It's just KOFF acting up. I've tried re-installing KOFF, repairing Office, deleting the account from the server and recreating it etc... and it doesn't seem to work.

We're looking at purchasing Kerio Mailserver for 3 more servers but this troublesome issue might result us in reconsidering.

Anyone else experiencing these problems?

Thanks,

Vince
  •  
vf1917

Messages: 5
Karma: 0
Send a private message to this user
I temporarily reverted all affected clients to IMAP and removed KOFF. IMAP is working fine so this setup will have to do until the KOFF issue is resolved. I would really like the Public Folders, meeting space, and Shared resources capabilities available in Kerio but until KOFF is fixed, it's tough to take advantage of them.

If anyone at Kerio or the user community is interested in the technical details, I've pasted some of the prominent errors found in debug.log. Many of these kept on repeating themselves over and over again within seconds of each other.

Thanks and have a great weekend.

Vince

[01/11/2008 21:29:37.062](3180){err}{mapi-interface} In MapiProvider\Utilities/MapiPropImpl.h:503 (Utilities::MapiPropImpl<struct IMessage,class MessageImpl,1>::OpenProperty)
                                                     Exception of class HResultException: MapiProvider\Utilities/MapiPropImpl.h(480), Utilities::MapiPropImpl<struct IMessage,class MessageImpl,1>::OpenProperty:
                                                     0x80040155
                                                     Requested property: 0x10130102 


[01/11/2008 20:07:39.140](4088){err}{database} In .\DbSearchFolder.cpp:392 (CDbSearchFolder::AS_getSearchCriteria)
                                               Exception of class HResultException: .\DbSearchFolder.cpp(365), CDbSearchFolder::AS_getSearchCriteria:
                                               0x80040605 MAPI_E_NOT_INITIALIZED
                                               HRESULT: 0x80040605 MAPI_E_NOT_INITIALIZED 


[01/11/2008 20:07:45.437](4088){err}{mapi-interface} In .\MAPIStatusImpl.cpp:591 (Utilities::MapiStatusImpl::askIdentity)
                                                     Exception of class HResultException: .\IdentitySharingXP.cpp(62), Utilities::IdentitySharingXP::ask:
                                                     0x80040401 MAPI_E_TIMEOUT 


 [25/10/2008 23:08:49.843](2340){err}{notif} In .\DbNotificationEngine.cpp:473 (CDbNotificationEngine::dispatchEvent)
                                            onNotify call failed (array of 1 notifications)
                                            HRESULT: 0x800706ba 
  •  
sedell

Messages: 1168
Karma: 1
Send a private message to this user
Did you ever find a solution to this? I've just run into a similar thing with a user on Outlook 2003 SP3/KOFF. He can send mail so far, but mail from two people can't be read and get an unknown error popping up.

Thanks.

Scott
  •  
Petr Silar (Kerio)

Messages: 107
Karma: 6
Send a private message to this user
vf1917,
vf1917 wrote on Sun, 02 November 2008 02:49


[01/11/2008 21:29:37.062](3180){err}{mapi-interface} In MapiProvider\Utilities/MapiPropImpl.h:503 (Utilities::MapiPropImpl<struct IMessage,class MessageImpl,1>::OpenProperty)
                                                     Exception of class HResultException: MapiProvider\Utilities/MapiPropImpl.h(480), Utilities::MapiPropImpl<struct IMessage,class MessageImpl,1>::OpenProperty:
                                                     0x80040155
                                                     Requested property: 0x10130102 


This is the only interesting error from your list. The error code means "Interface is not registered". The simple reason is that KOFF is not properly installed. However you wrote you had reinstalled your KOFF already. Try the following:
- close Outlook and make sure there is no running Outlook.exe and KoffBackend.exe.
- open cmd and go to KOFF's installation directory.
- execute the following:
koffbackend.exe regserver
regsvr32 dbserverps.dll
regsvr32 koffaddin.dll

Check if there is no error appeared.

vf1917 wrote on Sun, 02 November 2008 02:49


[01/11/2008 20:07:39.140](4088){err}{database} In .\DbSearchFolder.cpp:392 (CDbSearchFolder::AS_getSearchCriteria)
                                               Exception of class HResultException: .\DbSearchFolder.cpp(365), CDbSearchFolder::AS_getSearchCriteria:
                                               0x80040605 MAPI_E_NOT_INITIALIZED
                                               HRESULT: 0x80040605 MAPI_E_NOT_INITIALIZED 


This one is because Outlook asked KOFF incorrectly. AFAIK harmless.

vf1917 wrote on Sun, 02 November 2008 02:49

[01/11/2008 20:07:45.437](4088){err}{mapi-interface} In .\MAPIStatusImpl.cpp:591 (Utilities::MapiStatusImpl::askIdentity)
                                                     Exception of class HResultException: .\IdentitySharingXP.cpp(62), Utilities::IdentitySharingXP::ask:
                                                     0x80040401 MAPI_E_TIMEOUT 


This can appear durring Outlook's startup because of incorrect oreder of providers. Harmless.

vf1917 wrote on Sun, 02 November 2008 02:49

 [25/10/2008 23:08:49.843](2340){err}{notif} In .\DbNotificationEngine.cpp:473 (CDbNotificationEngine::dispatchEvent)
                                            onNotify call failed (array of 1 notifications)
                                            HRESULT: 0x800706ba 


This error typically appeared in the log right before the end. There is trailing notification wich cannot be delivered because Outlook is already down.
  •  
vf1917

Messages: 5
Karma: 0
Send a private message to this user
Thank You.

It looks like this problem has been solved with the suggestions provided.

After a few more tests, we might consider Kerio again for three more deployments.

Have a great day.
Previous Topic: Issues Syncing Calendars
Next Topic: Anti Virus Not Running -- avir_mcafee cannot be initialized
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Sep 21 19:32:21 CEST 2017

Total time taken to generate the page: 0.00449 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.