Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » How to make sure the "from:" field is not changed?
  •  
Barlad

Messages: 1
Karma: 0
Send a private message to this user
Hello,

We have a KMS server for companydomain.com. We have an user checking up his emails through an iphone (using activesync) on his account: joe<_a.t_>companydomain.com.

In his iphone, he configured the "e-mail address" to be: joe<_a.t_>anotherdomain.com because we want the mails sent by this user through our KMS activesync server to appear as joe<_a.t_>anotherdomain.com and not joe<_a.t_>companydomain.com.

Problem is that every time he sends a mail, the "From:" field is automatically switched from "joe<_a.t_>anotherdomain.com" to "joe<_a.t_>companydomain.com". Is there any way to modify this behaviour in KMS so that Joe can use whatever "from:" email address he wants please?

Thanks a lot!
  •  
marook

Messages: 520

Karma: 3
Send a private message to this user
Hi,

Log into Webmail, and under Setting -> Mail: Set the Default From address to the desired from address.

You will then get headers like this:

Return-Path: <account_main_id<_a.t_>humac.dk>
...
From: User <address_set_in_webmail<_a.t_>humac.dk>
...

Just tested on 6.6.0 7007

Other than that, I would file it as a Bug/ER to Kerio, so they can have a look at it.
But it could be the iPhone/ActiveSync agent not submitting it... ?
File it..

Update: This setting is propagated to your Open Directory, so if needed you could mass-update some users, if you know how..

[Updated on: Tue, 11 November 2008 01:29]


Regards,

Jakob Peterhänsel
Consultant - Humac A/S

Apple Certified Support Professional (ACSP)
Apple Certified Technical Coordinator (ACTC)
AppleSeed/CQF member since 1998
Kerio Messaging Partner
  •  
Will Mayall

Messages: 177
Karma: 7
Send a private message to this user
marook wrote on Tue, 11 November 2008 01:27

Log into Webmail, and under Setting -> Mail: Set the Default From address to the desired from address.

I'm responding to this post to make sure that folks looking for a solution to the problem can find this post.

Setup: iPhone (currently v2.2) using ActiveSync to connect to a Kerio server (currently 6.6.2) as an Exchange client.

Problem: Even though the email address in the iPhone settings is set to use a different address from the username setting, received emails show the username (account) as the from address.

Solution: Use a browser to log into the account via the Kerio webmail interface. Click the Settings button and then the Mail tab. Change the Default From Address to the desired from address.

Will Mayall

[Updated on: Thu, 01 January 2009 19:06]

Previous Topic: How do i catch outgoing and incoming all users email
Next Topic: How to change the event to the meeting
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Oct 20 10:50:02 CEST 2017

Total time taken to generate the page: 0.00889 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.