Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » ASyncMailData.cpp and **AirSync.cpp errors (Error Log Entries)
  •  
nbgrant

Messages: 49
Karma: 0
Send a private message to this user
I am running into a few errors on a number of my KMS that have iPhone users. I am getting an entry in the error log every so often that repeats for a huge block and then dies off...
[16/Dec/2008 18:31:44] ASyncKeyDatabase.cpp: ActiveSyncKeyInMemoryDatabase::GetKey: Unable to find synckey VD0yMDA1MTIyM1QxNDM0MzRaO1U9MTtGPTA7TT0xOw== in SyncKey table
[16/Dec/2008 18:41:18] ASyncAirSync.cpp: ActiveSyncAirSync::ProcessChanges: Unable to find item with id: 0x93
[16/Dec/2008 18:41:18] ASyncMailData.cpp: ActiveSyncMailData::ReadFromMessage: Unable to get envelope for message: 0x0
[16/Dec/2008 18:41:47] ASyncAirSync.cpp: ActiveSyncAirSync::ProcessChanges: Unable to find item with id: 0xC5
[16/Dec/2008 18:41:47] ASyncMailData.cpp: ActiveSyncMailData::ReadFromMessage: Unable to get envelope for message: 0x0
[16/Dec/2008 18:41:47] ASyncAirSync.cpp: ActiveSyncAirSync::ProcessChanges: Unable to find item with id: 0xDA
[16/Dec/2008 18:41:47] ASyncMailData.cpp: ActiveSyncMailData::ReadFromMessage: Unable to get envelope for message: 0x0
[16/Dec/2008 18:41:47] ASyncAirSync.cpp: ActiveSyncAirSync::ProcessChanges: Unable to find item with id: 0x104
[16/Dec/2008 18:41:47] ASyncMailData.cpp: ActiveSyncMailData::ReadFromMessage: Unable to get envelope for message: 0x0
[16/Dec/2008 18:41:47] ASyncAirSync.cpp: ActiveSyncAirSync::ProcessChanges: Unable to find item with id: 0x14F
[16/Dec/2008 18:41:47] ASyncMailData.cpp: ActiveSyncMailData::ReadFromMessage: Unable to get envelope for message: 0x0
[16/Dec/2008 18:41:47] ASyncAirSync.cpp: ActiveSyncAirSync::ProcessChanges: Unable to find item with id: 0x181
[16/Dec/2008 18:41:47] ASyncMailData.cpp: ActiveSyncMailData::ReadFromMessage: Unable to get envelope for message: 0x0
[16/Dec/2008 18:41:47] ASyncAirSync.cpp: ActiveSyncAirSync::ProcessChanges: Unable to find item with id: 0x182
[16/Dec/2008 18:41:47] ASyncMailData.cpp: ActiveSyncMailData::ReadFromMessage: Unable to get envelope for message: 0x0
[16/Dec/2008 18:41:47] ASyncAirSync.cpp: ActiveSyncAirSync::ProcessChanges: Unable to find item with id: 0x183
[16/Dec/2008 18:41:47] ASyncMailData.cpp: ActiveSyncMailData::ReadFromMessage: Unable to get envelope for message: 0x0
[16/Dec/2008 18:41:47] ASyncAirSync.cpp: ActiveSyncAirSync::ProcessChanges: Unable to find item with id: 0x1A5
[16/Dec/2008 18:41:47] ASyncMailData.cpp: ActiveSyncMailData::ReadFromMessage: Unable to get envelope for message: 0x0
[16/Dec/2008 18:41:47] ASyncAirSync.cpp: ActiveSyncAirSync::ProcessChanges: Unable to find item with id: 0x2BA
[16/Dec/2008 18:41:47] ASyncMailData.cpp: ActiveSyncMailData::ReadFromMessage: Unable to get envelope for message: 0x0
[16/Dec/2008 18:41:47] ASyncAirSync.cpp: ActiveSyncAirSync::ProcessChanges: Unable to find item with id: 0x43F
[16/Dec/2008 18:41:47] ASyncMailData.cpp: ActiveSyncMailData::ReadFromMessage: Unable to get envelope for message: 0x0
[16/Dec/2008 18:41:47] ASyncAirSync.cpp: ActiveSyncAirSync::ProcessChanges: Unable to find item with id: 0x4A3
[16/Dec/2008 18:41:47] ASyncMailData.cpp: ActiveSyncMailData::ReadFromMessage: Unable to get envelope for message: 0x0


Anyone know what to make of this or how I could gather more information about it? Similar errors are showing up on a few of my servers.
  •  
p0ddie

Messages: 242
Karma: -3
Send a private message to this user
I saw this today on two iPhones I messed around with. It seemed to happen when I moved mail out of my inbox with a local mail client while there is an ActiveSync in progress.

Situation:

KMS receives 20 new messages into your inbox (scheduled pop3 poll or something). Your local mail rules, mail user or spam filter moves/alters 10 of those mails immediately.

Same time your desktop mail client received those 20 messages, the iPhone gets a 20 mail push job, but when it starts downloading those mails, 10 are gone already. Message ID gone, iPhone freaks out.

Plausible solution to your problem?
  •  
nbgrant

Messages: 49
Karma: 0
Send a private message to this user
Unfortunately POP is not a solution for these users. They have to stick with IMAP (the Entourage users are setup as Exchange inboxes).
  •  
p0ddie

Messages: 242
Karma: -3
Send a private message to this user
hey,

actually, pop3 was not my recommendation as a solution to your problem, more a hint to what could be going on! I will never recommend pop3 mailboxes Wink


  •  
nbgrant

Messages: 49
Karma: 0
Send a private message to this user
p0ddie wrote on Fri, 19 December 2008 10:56

hey,
actually, pop3 was not my recommendation as a solution to your problem, more a hint to what could be going on! I will never recommend pop3 mailboxes Wink



You and me both! Smile


I'll just ignore the error until it really causes trouble. Razz
Previous Topic: Webmail CSS missing in Firefox
Next Topic: Change outgoing email address in Outlook Offline connector
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Sep 20 23:50:48 CEST 2017

Total time taken to generate the page: 0.00396 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.