Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Sending email from the command line (How to send an email using sendmail on a Suse box)
  •  
tony@incasolutions.co.za

Messages: 2
Karma: 0
Send a private message to this user
Hello,

I have Kerio 6.7.0 installed on a suse box - this works very well.
I have also installed Hylafax on this box and this also works fine.
Except that I can't receive the fax as an email. The Hyalfax system uses sensmail and this requires postfix which has been diabled - how do I get Kerio to do my emailing ?

Thanks
  •  
snorlax

Messages: 31
Karma: 0
Send a private message to this user
I'm also very interrested in this matter because I want my UPS to be able to send me email alerts when power goes down...
The only way for the UPS is to use cmdline "mail" command.
It works fine if the UPS sends emails to a Debian local user.
But if it tries to send an email "outside", it fails with this message in the security log :
Message from IP address 127.0.0.1, sender <postmaster<_a.t_>mail> rejected: sender domain does not exist !

My machine's uname is mail.kodsi.net and it hosts the KMS...
  •  
sgongola

Messages: 109
Karma: 0
Send a private message to this user
Quote:

The only way for the UPS is to use cmdline "mail" command. It works fine if the UPS sends emails to a Debian local user. But if it tries to send an email "outside", it fails with this message in the security log :
Message from IP address 127.0.0.1, sender <postmaster<_a.t_>mail> rejected: sender domain does not exist !

My machine's uname is mail.kodsi.net and it hosts the KMS...

I can't tell exactly what your are doing from your information or what UPS you have and what it can do. You probably need to set the sending UPS machines networking so that it uses the correct ip address and/or domain in the from address. I don't think the localhost address (127.0.0.1) should be available in the error message and "<_a.t_>mail" should really be the "kodsi.net".

If that is not the problem, then you may want to set relaying so that it does not check for mail coming from inside your network.
  •  
snorlax

Messages: 31
Karma: 0
Send a private message to this user
Yep, that was it.

I had 2 ways to solve this:
1) uncheck "Block if domain sender not in the DNS" option (but I didn't like that...

or

2) change my hostname to fully qualify my machine name

I did the 2nd option and it now works...

The only remaining thing is to be able to specify the sender' name because for now mails are received without the "From:" field, but only with the "Return-Path:"
Previous Topic: Subscribed Calendar in iPhone 3.0 (problem)
Next Topic: iPhone / iPod Touch 2G 3.0 Search Server side emails
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon Nov 20 01:14:36 CET 2017

Total time taken to generate the page: 0.00487 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.