Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » IMAP Performance Issue (IMAP Performance Issue)
  •  
kanedavid

Messages: 10
Karma: 0
Send a private message to this user
Hello we have just moved from Communigate to Kerio MS 6.7.

Our office consists of 8 staff all connected to Kerio MS using IMAP from a Mac using Apple Mail (one user uses Thunderbird)

Some users have laptops and come and go from the office, thus using IMAP over a WAN connection.

The problem is that users are frequently getting very slow IMAP Sync performance in Mail (compared to Communigate). They will also get a number of timeout issues as per this message:

"The Connection to the Server mail.mydomain.com on port 143 timed out"

The Server is a Power Mac G5 Dual 2.0Ghz model.

What is odd is that the old Communigate Server was running on an even older G4 Xserve and we never had these IMAP performance issues so I don't believe the issue is due to the performance of the server hardware. The processor is basically idling on this server.

Can anyone shed some light on why this might be happening? Is there some timeout settings, or number of threads settings that I should change?

Oh, lastly, users do have LOTS of email - typically each user has around 3-6Gb of email in their mailbox consisting of around 15000-25000 email items in total. Some users check 2 mailboxes.

  •  
My IT Indy

Messages: 1262
Karma: 40
Send a private message to this user
Kerio stores each email/contact/calendar item as a separate file. As your mailstore grows, it needs speed. You could be having issues with the drives keeping up with the requests.

I had an install running on a G5 XServe that had 200 users on it and the server kept having speed issues with webmail. We solved the problem by moving the KMS to a Dell PowerEdge 2650 with 5x150GB 15K rpm scsi drives in a RAID 5 that we got for under $500. Scary. The faster drives made all the difference.

-
My IT Indy
Kerio Certified Reseller and Hosted Provider
http://www.myitindy.com
  •  
kanedavid

Messages: 10
Karma: 0
Send a private message to this user
Good point, because we are running the mailstore on a software RAID-1 (Mirror).

Though this doesn't explain why the same mailstore previously worked fine under Communigate on an even slower G4 with a software mirror using slower U-ATA disks?

Perhaps Kerios mailstore data arrangement isn't nearly as refined as Communigate, which I must admit was a very good system - we only moved away from it due to massively increasing costs of ownership, and also lack of certain support for Mac clients for things like a sync'd address book, calendars etc.

Maybe there is a timeout setting for IMAP that I can perhaps increase a bit to give the disks a little more time. Any ideas?


  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
kanedavid wrote on Wed, 03 June 2009 22:25


"The Connection to the Server mail.mydomain.com on port 143 timed out"



Is it related to certain action in the client? Like deleting bunch of emails?

Dual G5 is much more than sufficient for 8 users.
  •  
kanedavid

Messages: 10
Karma: 0
Send a private message to this user
Yes, usually it does happen more often if I am moving large numbers of emails, deleting emails or other tasks on the client. Though I have had it simply when opening Mail.app, and letting it do a re-synchronise to the server. It also happens simply when just trying to open an email message from time to time.

I've checked disks performance and stability (in case there is a dud disk) but all seems OK there.

On the server, when I'm performing tasks in the client such as synchronising or moving emails, the server logs report a number of threads or tasks being 'suspended' then the client seems to stall, and those tasks will mostly show up again as 'resumed' but occasionally, one probably doesn't resume in time hence causing the client to perhaps timeout?

Note that 8 clients isn't many, though they do have quite a lot of email - one user account has about 35,000 items, most others have between 8000 and 15000

A few machines check more than one account.

Oh, Ive also set up a mail client on the actual server itself (thus eliminating 'network' factors, and I can get the same errors.
  •  
stewie

Messages: 106
Karma: 0
Send a private message to this user
JM2C.

We have 50 users some with IMAP mailboxes over 20+ GB. We have Macs, PCs, iPhones, etc. Our performance has been excellent.

We run CentOS5 on a very inexpensive custom rack server (3GHz core 2 duo, 2GB RAM, a pair of fast VelociRaptor mirrored drives using the on-board RAID controller of the ASUS P5Q-E motherboard & a GB NIC).

What's really impressed me is we have some odd things that appear to be Mail.app bugs that just hammer the server. Yet our current 1 minute load average for the year is only 0.34. It's very rare that I get a 1 minute load over 2 (it's monitored with Cacti). Kerio has been very responsive running on this box.

If I recall, weren't there earilier posts from someone with a beefy G5 xserve that was slow? I'm not sure what the issue is, but we fortunately don't have it.

If you have a PC laying around, it would be worth loading up linux, dropping in Kerio & trying out. In so doing, you will have eliminated OSX & the powerPC which are the only platforms I can recall any reports of performance issues.

Good luck.
  •  
stewie

Messages: 106
Karma: 0
Send a private message to this user
Sorry, just saw your latest post & had to mention we're experiencing these "suspended" messages, too. But this is a very recent occurrence. I'm not sure if these messages coincided with the release of Kerio 6.7 or the latest OS X updates.

We're getting messages like:

[04/Jun/2009 13:22:03][9771] {imaps} Task 5 handler SUSPENDED
[04/Jun/2009 13:22:28][9840] {imaps} Task 5 handler SUSPENDED
[04/Jun/2009 13:23:48][10041] {imaps} Task 5 handler RESUMED
[04/Jun/2009 13:24:48][10041] {imaps} Task 5 handler SUSPENDED
[04/Jun/2009 13:25:30][9829] {imaps} Task 5 handler RESUMED
[04/Jun/2009 13:25:48][10273] {imaps} Task 5 handler RESUMED
[04/Jun/2009 13:26:32][9829] {imaps} Task 5 handler SUSPENDED


And then I think they eventually time out. But there's a lot more than 5 tasks. Last time looked there was 90+.

Even so, performance remains very good. And the only recent issue is that 2 users (that I know of) can't create mailboxes anywhere but directly inside their inbox using Mail.app. (Works fine in the web client.)

Hmmm.
  •  
Backspin

Messages: 21
Karma: 10
Send a private message to this user
I had problems with Apple Mail and time-outs as well on some clients.
Especially when copying larger amounts of messages from one folder to another, or from local folders to the kerio store.

Messages like "{imaps} Task 479 handler SUSPENDED" would appear in the kerio debug log.

Finally discovered that this was related to a message in the Drafts folder. Not even the kerio drafts folder, but the drafts folder of a local pop account in Apple Mail.

Deleting this mail solved al the problems. So, for people searching this forum with Apple Mail/imap problems: check and empty your drafts folder(s) first.
  •  
giobbi

Messages: 90
Karma: 0
Send a private message to this user
Have you checked your service (IMAP) limit?
  •  
marook

Messages: 520

Karma: 3
Send a private message to this user
Sounds SCARRY if a local (On My Mac) Draft message from another (POP) account has Anything to do with IMAP connections to Kerio!

Please: bugreporter.apple.com!

Regards,

Jakob Peterhänsel
Consultant - Humac A/S

Apple Certified Support Professional (ACSP)
Apple Certified Technical Coordinator (ACTC)
AppleSeed/CQF member since 1998
Kerio Messaging Partner
  •  
tommie

Messages: 3
Karma: 0
Send a private message to this user
I am using a CRM client which uses PHP builtin IMAP extension. Everything works fine, however some users experience extreme slow connections to Kerio. Settings are the same as any other user and when I logon to their computer, the problem remains.

I've created a new Kerio user last week. She has a lot of lag when it comes to using her account with this IMAP solution. However, her mailbox is next to empty! Any ideas?
Previous Topic: E-mail rejected from good source
Next Topic: Searching contacts by category
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Sep 20 05:52:58 CEST 2017

Total time taken to generate the page: 0.00524 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.