Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » smtp question
  •  
modcar

Messages: 13
Karma: 0
Send a private message to this user
Is there anyway to ignore spam checking of outgoing authenticated smtp users?

Also, if I am offsite, using imap, when I send emails, my local ip is put into the email headers, rather than my servers, so I find, if I am using a dynamic IP (offsite) some emails get bounced.

[Updated on: Mon, 06 July 2009 06:48]

  •  
freakinvibe

Messages: 1552
Karma: 62
Send a private message to this user
Quote:

Is there anyway to ignore spam checking of outgoing authenticated smtp users?

Outgoing mail is not checked. What makes you think it is?

Quote:

Also, if I am offsite, using imap, when I send emails, my local ip is put into the email headers, rather than my servers, so I find, if I am using a dynamic IP (offsite) some emails get bounced.

The header will always contain the IP address where you send your mail from, this can't be changed. But your server's IP address is also in the headers. See more on this topic in the following thread:

http://forums.kerio.com/index.php?t=msg&goto=62186

Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
  •  
modcar

Messages: 13
Karma: 0
Send a private message to this user
freakinvibe wrote on Mon, 06 July 2009 11:01

Quote:

Is there anyway to ignore spam checking of outgoing authenticated smtp users?

Outgoing mail is not checked. What makes you think it is?

I saw in my logs, when I tried to send an email, it said "IP is in SORBS", then rejected the email


Quote:

Also, if I am offsite, using imap, when I send emails, my local ip is put into the email headers, rather than my servers, so I find, if I am using a dynamic IP (offsite) some emails get bounced.

The header will always contain the IP address where you send your mail from, this can't be changed. But your server's IP address is also in the headers. See more on this topic in the following thread:

http://forums.kerio.com/index.php?t=msg&goto=62186



Thanks will have a look at that
  •  
freakinvibe

Messages: 1552
Karma: 62
Send a private message to this user
Quote:

I saw in my logs, when I tried to send an email, it said "IP is in SORBS", then rejected the email

This message is not coming from KMS but from the receiving mail server. It found your server's IP address in the Sorbs blacklist. You should check if your IP address is really on that list and the reason for it.

Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
  •  
modcar

Messages: 13
Karma: 0
Send a private message to this user
KMS in this case was the receiving server, because I was doing the outlook test message

[06/Jul/2009 02:55:47] IP address XXX.XXX.XXX.XXX found in DNS blacklist SORBS DNSBL, mail from <test<_a.t_>domain.com> to <test<_a.t_>domain.com> rejected
  •  
freakinvibe

Messages: 1552
Karma: 62
Send a private message to this user
Sorry, but you wrote

"I saw in my logs, when I tried to send an email, it said "IP is in SORBS", then rejected the email"

So when you send a mail, it goes from KMS to the receiving Mail server (for example Hotmail). Your mail might be rejected, if your KMS server IP address is on a black list.

If you are sending mail from an external server (e.g. Hotmail) to your KMS server and you get a SORBS error, that means that the external server is on the SORBS list. If you don't want that to happen, you can disable the blacklist checking for SORBS on KMS or give it a low spam score.


Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
  •  
modcar

Messages: 13
Karma: 0
Send a private message to this user
OK, i think I might have confused things....

First issue:

If I IMAP from another location, eg internet cafe, if I am sending emails to hotmail or example, some emails are rejected as the internet cafe's dynamic IP is listed on SORBS, not my KMS IP.

Second issue:

If I IMAP from an internet cafe, using my laptop for example, if I try and 'send a test email' in outlook, it fails, when I look in KMS logs, it says its rejected the connection because IP is listed on SORBS.
  •  
freakinvibe

Messages: 1552
Karma: 62
Send a private message to this user
Quote:

First issue:

If I IMAP from another location, eg internet cafe, if I am sending emails to hotmail or example, some emails are rejected as the internet cafe's dynamic IP is listed on SORBS, not my KMS IP.

As I said, you can't suppress the IP from the Internet cafe in the mails headers. But other mail servers should not look in the headers, they should only check the IP address of the connecting mail server (KMS in your case). Are you sure and have you checked that your KMS IP address is not on the Sorbs list?

Quote:

Second issue:

If I IMAP from an internet cafe, using my laptop for example, if I try and 'send a test email' in outlook, it fails, when I look in KMS logs, it says its rejected the connection because IP is listed on SORBS.

In KMS configuration, don't block connections for Sorbs, just add a low spam score.

Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
modcar wrote on Tue, 07 July 2009 11:22

OK, i think I might have confused things....
Second issue:

If I IMAP from an internet cafe, using my laptop for example, if I try and 'send a test email' in outlook, it fails, when I look in KMS logs, it says its rejected the connection because IP is listed on SORBS.



1. Set SMTP trusted relay option to include authenticated users.
2. Do not scan emails from trusted relay group with Spam Filter in KMS (default option).
3. Use authentication when sending the email via SMTP from your laptop.

This way, no email sent by authenticated user will be rejected by KMS due to spam filter.
  •  
sonofcolin

Messages: 483
Karma: 0
Send a private message to this user
Quote:


As I said, you can't suppress the IP from the Internet cafe in the mails headers. But other mail servers should not look in the headers, they should only check the IP address of the connecting mail server (KMS in your case).

But other mailservers do check all the headers and this is where the problem lies. If Kerio offered an option to suppress some of these mailheaders (just like in GMail) I think this would help our mobile users who rely on webmail.

[Updated on: Tue, 07 July 2009 15:01]

  •  
modcar

Messages: 13
Karma: 0
Send a private message to this user
sonofcolin wrote on Tue, 07 July 2009 15:01


But other mailservers do check all the headers and this is where the problem lies. If Kerio offered an option to suppress some of these mailheaders (just like in GMail) I think this would help our mobile users who rely on webmail.



Agreed
Previous Topic: IMAP IDLE with several Accounts at once
Next Topic: Personalize PST location
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Nov 19 11:25:18 CET 2017

Total time taken to generate the page: 0.00560 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.