Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Control » Apache cannot DNS resolve
  •  
hmadsen

Messages: 33
Karma: 1
Send a private message to this user
Hi

I have a kerio firewall computer that has IP 10.0.0.1

I have installed an apache webserver on this computer and if i enter 10.0.0.1 on any client machine it gets the apache allright.

but i want to be able to set up kerio so that if people just type "123" in a webbrowser it will give them this server.

The server is not going to be reachable from the internet, it is strictly an internal website.

I have looked at the DNS tab and it is set to "enable DNS forwarder service" and under resolution cache is enabled..

Also there is a tick in "hosts file" and "DHCP lease table" under "before forwarding a query try to find the name in" part.

This does not work.

So i tried to edit the hosts file to include :

10.0.0.1 123

And after Apply the server itself works fine with the "123" in the adress line of internet explorer

But on the client machines it does not work so it seems that the "edit hosts" will only edit hosts on the server but not look inside it before doing DNS resolution for client machines.

Is this correct ?

If yes, how will i be able to make kerio's DNS resolver point "123" to 10.0.0.1:80

Hmadsen
  •  
hmadsen

Messages: 33
Karma: 1
Send a private message to this user
Am i the only registred kerio user that has an internal intranet server that i want to put into the DNS like this ?

Alternatively, can anyone give me any hints on a forum where i can get the answers ?

hmadsen
  •  
Jan Jezek (Kerio)

Messages: 103
Karma: 0
Send a private message to this user
You configured it correctly on WinRoute side. However your client machines aren't probably using 10.0.0.1 as their DNS server.

[Updated on: Tue, 22 September 2009 20:29]


Jan Jezek
Product Development Manager - Kerio Control
Kerio Technologies
  •  
hmadsen

Messages: 33
Karma: 1
Send a private message to this user
Good idea but i have allready in the setup phase made it so that the DHCP server specifies both default gateway and dns server to 10.0.0.1 so it cannot be that.

Am i right if i say that even though i only add

10.0.0.1 123

To the hosts file on the server it should also check this file when resolving adresses for the client machines ?

hmadsen

[Updated on: Wed, 23 September 2009 07:15]

  •  
Jan Jezek (Kerio)

Messages: 103
Karma: 0
Send a private message to this user
Yes, WinRoute DNS service does exactly that. Check the ipconfig on the client machines that they really have 10.0.0.1 as their DNS server. Then enable DNS logging in the debug log (right click/messages) and observe what's going on.

Jan Jezek
Product Development Manager - Kerio Control
Kerio Technologies
  •  
hmadsen

Messages: 33
Karma: 1
Send a private message to this user
The machine IS using the server for DNS.

[23/Sep/2009 12:31:25] {proto_dns} DNS: query 192.168.1.133:36139 -> 192.168.2.3:53 for 126.12.84.209.in-addr.arpa
[23/Sep/2009 12:31:26] {proto_dns} DNS: query 192.168.1.133:36139 -> 192.168.2.3:53 for 126.12.84.209.in-addr.arpa
[23/Sep/2009 12:31:30] {proto_dns} DNS: query 10.0.0.11:56131 -> 10.0.0.1:53 for time.com
[23/Sep/2009 12:31:30] {proto_dns} DNS: query 192.168.1.133:36139 -> 192.168.2.3:53 for time.com
[23/Sep/2009 12:31:31] {proto_dns} DNS: query 10.0.0.11:60014 -> 10.0.0.1:53 for www.time.com
[23/Sep/2009 12:31:31] {proto_dns} DNS: query 192.168.1.133:36139 -> 192.168.2.3:53 for www.time.com
[23/Sep/2009 12:31:31] {proto_dns} DNS: query 10.0.0.11:54906 -> 10.0.0.1:53 for img.timeinc.net
[23/Sep/2009 12:31:31] {proto_dns} DNS: query 192.168.1.133:36139 -> 192.168.2.3:53 for img.timeinc.net
[23/Sep/2009 12:31:31] {proto_dns} DNS: query 10.0.0.11:62824 -> 10.0.0.1:53 for ajax.googleapis.com
[23/Sep/2009 12:31:31] {proto_dns} DNS: query 192.168.1.133:36139 -> 192.168.2.3:53 for ajax.googleapis.com
[23/Sep/2009 12:31:31] {proto_dns} DNS: query 10.0.0.11:53919 -> 10.0.0.1:53 for admin.brightcove.com
[23/Sep/2009 12:31:31] {proto_dns} DNS: query 192.168.1.133:36139 -> 192.168.2.3:53 for admin.brightcove.com
[23/Sep/2009 12:31:31] {proto_dns} DNS: query 10.0.0.11:54214 -> 10.0.0.1:53 for js.adsonar.com
[23/Sep/2009 12:31:31] {proto_dns} DNS: query 192.168.1.133:36139 -> 192.168.2.3:53 for js.adsonar.com
[23/Sep/2009 12:31:32] {proto_dns} DNS: query 10.0.0.11:58504 -> 10.0.0.1:53 for timecom.122.2o7.net
[23/Sep/2009 12:31:32] {proto_dns} DNS: query 192.168.1.133:36139 -> 192.168.2.3:53 for timecom.122.2o7.net
[23/Sep/2009 12:31:33] {proto_dns} DNS: query 10.0.0.11:54720 -> 10.0.0.1:53 for an.tacoda.net
[23/Sep/2009 12:31:33] {proto_dns} DNS: query 192.168.1.133:36139 -> 192.168.2.3:53 for an.tacoda.net
[23/Sep/2009 12:31:33] {proto_dns} DNS: query 10.0.0.11:61556 -> 10.0.0.1:53 for edge.quantserve.com
[23/Sep/2009 12:31:33] {proto_dns} DNS: query 192.168.1.133:36139 -> 192.168.2.3:53 for edge.quantserve.com
[23/Sep/2009 12:31:34] {proto_dns} DNS: query 10.0.0.11:58161 -> 10.0.0.1:53 for pixel.quantserve.com
[23/Sep/2009 12:31:34] {proto_dns} DNS: query 192.168.1.133:36139 -> 192.168.2.3:53 for pixel.quantserve.com
[23/Sep/2009 12:31:34] {proto_dns} DNS: query 10.0.0.11:62163 -> 10.0.0.1:53 for leadback.advertising.com
[23/Sep/2009 12:31:34] {proto_dns} DNS: query 192.168.1.133:36139 -> 192.168.2.3:53 for leadback.advertising.com
[23/Sep/2009 12:31:52] {proto_dns} DNS: query 10.0.0.11:52264 -> 10.0.0.1:53 for www.google.com
[23/Sep/2009 12:31:52] {proto_dns} DNS: query 192.168.1.133:58563 -> 192.168.2.3:53 for www.google.com


This is from a client machine, first i ask for "www.time.com" and after that it ask for "vkdk" which is the name i want resolved.

The hosts file on the server has these lines :

127.0.0.1 localhost
10.0.0.1 vkdk

If i ask for 10.0.0.1 i get the apache server allright but if i just put vkdk i get nothing and IE does a google search instead as seen on the log in the bottom lines.

So i think that it might be because it will not be possible to resolve vkdk into 10.0.0.1 at all.

hmadsen
  •  
Jan Jezek (Kerio)

Messages: 103
Karma: 0
Send a private message to this user
I don't see the query in the log. So the client did not send it. Perhaps it's in the client's host file?

Jan Jezek
Product Development Manager - Kerio Control
Kerio Technologies
  •  
hmadsen

Messages: 33
Karma: 1
Send a private message to this user
You are right..

If i change the hosts file to vkdk.dk instead of just vkdk it works fine.

So it must be internet explorer that simply does not accept anything that does not end in .dk or .com etc..

hmadsen
Previous Topic: load balance
Next Topic: Enable Messanger on kerio
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Oct 21 21:21:05 CEST 2017

Total time taken to generate the page: 0.00433 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.