Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Fail to configure apache2 proxy for kms (proxy, port, apache2)
  •  
sharkfood

Messages: 3
Karma: 0
Send a private message to this user
Hello, i'm stuck on my kerio configuration.

I run kerio on a linux server that also run apache2 which gave me problems with port 80 and 443 which I use in apache2 so I changed the default port from 80 to 81 and 443 to 82, that gave me the problem with exchange. Mobile phones which not have the ability to change port does not work and I also have to write mail.mydomain.com:81 instead of just mail.mydomain.com.

I heard of apache2 proxys but I don't got it working on my server. The error.log on apache2 just says
[Wed Sep 16 13:34:42 2009] [error] [client 95.209.110.190] client denied by server configuration: proxy:http://localhost:82/


I configured;

NameVirtualHost *:80

<VirtualHost *:80>
    ServerName mail.domain.com
    proxyRequests Off
    proxyPass / http://localhost:82/
    <Location />
        proxyPassReverse /
    </Location>
</VirtualHost>


What am I doing wrong?

If I get this working, will exchange start working to or do I need another IP for that?
  •  
Mousee

Messages: 8
Karma: 0
Send a private message to this user
The problem is that you're trying to forward an HTTP connection to an HTTPS connection.
Basically the way you have it setup right now users browsing to http://yourhost are being sent to Kerio Webmail's HTTPS server (http://localhost:82).

Perhaps that's just a typo on your part though.
It should look like this:

NameVirtualHost *:80

<VirtualHost *:80>
    ServerName mail.domain.com
    proxyRequests Off
    proxyPass / http://localhost:81/
    <Location />
        proxyPassReverse /
    </Location>
</VirtualHost>


The same concept for HTTPS (port 82 in your case), just copy your current VirtualHost line and change the VirtualHost port to 443 and your proxyPass port to 82.

NameVirtualHost *:80
NameVirtualHost *:443

<VirtualHost *:80>
    ServerName mail.domain.com
    proxyRequests Off
    proxyPass / http://localhost:81/
    <Location />
        proxyPassReverse /
    </Location>
</VirtualHost>

<VirtualHost *:443>
    SSLProxyEngine On
    ServerName mail.domain.com
    proxyRequests Off
    proxyPass / http://localhost:82/
    <Location />
        proxyPassReverse /
    </Location>
</VirtualHost>


Notice the addition of "SSLProxyEngine" - this is required to forward HTTPS traffic properly.

See the following Kerio Forums post for more info:
http://forums.kerio.com/index.php?t=msg&goto=46001
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
I would like to warn that connection pool used by mod_proxy in Apache 2.1 and later MUST be disabled. (Option disablereuse).
Previous Topic: continous error in log - folder_manager.cpp
Next Topic: Proper reply-to on aliases
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Oct 21 08:52:36 CEST 2017

Total time taken to generate the page: 0.00399 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.