Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Slow webmail - Slow server
  •  
rleslie70

Messages: 72
Karma: 0
Send a private message to this user
This may be a better topic suited for a forum on Windows servers than kerio...but thought i would give it a shot.

We replaced our kerio mail server a few months ago. We have a little over one thousand users. Webmail is really slow now and the server is acting slow in general...but only during the part of the day when most people are logged in...after hours the server is fine.

I know part of the problem is we should have done raid 10 instead of Raid 5. However, we're experiencing much more latency issues with the new server than we ever did with our old server that was also raid 10.

I downloaded PAL and ran a report based on the memory counters. I chose processor, memory and disk drive (logical and physical). I was expecting to see a lot of issues/alerts on the disk drives...but to my surprise it was memory where the alerts were.

I see the message 'critically low on pool paged memory, less than 20% available.'

The server has 8 gigs of memory; however only 4 gigs show because it's running Windows 2003 server standard 32 bit edition. And only the kernel memory has about 377 mb total and 299 mb for the page pool memory. In my google searches, i ran across an article describing the symptoms if you deplete your page pool memory and they seem to fit our symptoms of sluggishenss.

Should i increase the amount of kernel memory? Has anyone ran into a similar problem? Should i add the /3 gig switch to the boot.ini file?





  •  
rleslie70

Messages: 72
Karma: 0
Send a private message to this user
meant to say that the old server was also raid 5
  •  
freakinvibe

Messages: 1553
Karma: 62
Send a private message to this user
Instead of using any performance tools, have you looked in task manager during high load times? What is the CPU usage, memory usage and network usage? Are your RAID 5 disks constantly active? Have you checked event viewer if any strange warning or error messages occur? Have you checked the KMS warning and error logs for strange entries?

What do you mean by slow? Is only web mail slow? If you are at the server console, opening programs like notepad, eventviewer, is this sluggish or is the performance normal.

If only web mail is slow, sometimes it helps to switch off reverse lookup of IP addresses.

Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
  •  
rleslie70

Messages: 72
Karma: 0
Send a private message to this user
pretty much everything is slow during high peak times. I remote in through RDP, which takes really long to get in. If i go to task manager, it takes a good while to load that. If i go to control panel, that takes a while too. pretty much everything.

It's not the processor....that is running no more than 20 % utilization at peak times. It shows 4 gigs of ram and is using no more than a gig at any one time.

The server is HP ProLiant DL585 G5 - Third-Generation Opteron 8356 2.3 GHz.
  •  
subnet

Messages: 133
Karma: 0
Send a private message to this user
Hi rleslie70,

Check under "Advanced Option" > "Miscellaneous"
Check if "Log hostnames for incomming connections" is disabled. If it is enabled, disable it and check your webmail performance.

Hope this helps.

Regards,

Cliff
  •  
rleslie70

Messages: 72
Karma: 0
Send a private message to this user
Figured out the latency issue. We had installed trend micro on the server and i didn't realize trend was scanning the kmail store folder. Put an exception for the real-time scanner to skip that folder and the performance is like night and day! I always heard that you're not suppose to include your mail folder in the real-time scanning, but didn't realize it made such a difference.

Also, i've read quite a bit on this forum regarding raid 10 versus raid 5. perhaps we would get somewhat better performance if we had raid 10, but i didn't want to sacrifice the hard drive space. and the performance on raid 5 seems fine (now that we've put the exclusion in for officescan) and we have around 1100 users.

thanks

  •  
jstadter

Messages: 13
Karma: 0
Send a private message to this user
Also, check to make sure the volume with your mailstore on it is not fragmented. I ran in to the same issue with very slow performance and constant disk activity and checked on my volume fragmentation. It was severely fragmented.
Previous Topic: public folder new mail alerts
Next Topic: Messages come in late
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon Nov 20 10:49:21 CET 2017

Total time taken to generate the page: 0.00441 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.