Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » [SOLVED] Corrupted Data drive - funny messages in admin console
  •  
p0ddie

Messages: 242
Karma: -3
Send a private message to this user
Hey,

I see strange messages in the Kerio admin console:

mail_folder.cpp: Bad UIDNEXT in folder ~user<_a.t_>domain.com/INBOX incremented: 00000249 -> 0000024a, 13 retries remaining

The user's mailbox couldn't receive mails anymore, people got bounce messages and mails to the user were stuck in the queue.

Got an Xserve with OS X 10.6 Server here. Mailstore is on a RAID6 mounted via iSCSI. For the second time now, the mailstore volume has become corrupted (had to rebuild index with Diskwarrior). Last time, after I restored the volume, I copied the entire mailstore off to another volume, reinitialized the mailstore volume and copied back everything. This has been running fine for 2 months but now there were error messages again.

Seems to be back to normal except for the occasional error message in the log...

The other logical volumes on the phsical RAID6 are very fine, btw.

Halp, what can I do?

[Updated on: Fri, 20 November 2009 14:27] by Moderator

  •  
marook

Messages: 520

Karma: 3
Send a private message to this user
Not sure, but iSCSI would not be my choice to start with...

Regards,

Jakob Peterhänsel
Consultant - Humac A/S

Apple Certified Support Professional (ACSP)
Apple Certified Technical Coordinator (ACTC)
AppleSeed/CQF member since 1998
Kerio Messaging Partner
  •  
p0ddie

Messages: 242
Karma: -3
Send a private message to this user
Well, I am actually quite fond of iSCSI and it rocks. However, this shall not become an iSCSI vs. whatever discussion and I got the info from Kerio already: The above error message was resolved after I repaired the partition and then *again* renamed the index file (thanks Patrick from Kerio Support in Germany, he knows quite a lot Smile ). So, someone please put a [SOLVED] to this thread - thank you!

[Updated on: Fri, 20 November 2009 14:15]

  •  
bigmountain

Messages: 116

Karma: 0
Send a private message to this user
What utility did you use to repair the volume? I am encountering a similar issue and am currently running Apple Disk Utility to repair the volume.

Preferred Kerio Partner and Cloud Solutions Provider - Offering both shared and dedicated Kerio Connect hosting solutions.
Visit us at http://bigmountainmail.com
  •  
p0ddie

Messages: 242
Karma: -3
Send a private message to this user
I used DiskWarrior, basically.
Previous Topic: Initial login issue with new Connect appliance
Next Topic: Does Reset Synchronization on Calendar folder work?
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Nov 21 12:51:51 CET 2017

Total time taken to generate the page: 0.00384 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.