Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » KC7 & KSH crash on OS X 10.5 (Do not run in 64 bit mode on a 32 bit system... ;-))
  •  
marook

Messages: 520

Karma: 3
Send a private message to this user
Hi All,

We have a costumer that runs Kerio Connect 7 (patch1, now) where all clients run 10.5, and after the upgrade to KC7, KerioSyncHelper started to crash a Lot.

It seems it because KSH is running in 64-bit mode (on a 32 bit system) and that's not so great.

If you see this issue, please file a bugreport.
in the meantime, here is a workaround (low level!)

Open Terminal.app on the client.

cd "Library/PreferencePanes/Kerio Sync Helper.prefpane/Contents/Resources/KerioSyncHelpder.app/Contents/MacOS/"
mv KerioSyncHelper KerioSyncHelper.ub
lipo -thin i386 KerioSyncHelper.ub -output KerioSyncHelper


Steps done:
- Move into KSH app folder
- Rename binary
- Create 32-bit-only versin on binary

Hope it helps...

Regards,

Jakob Peterhänsel
Consultant - Humac A/S

Apple Certified Support Professional (ACSP)
Apple Certified Technical Coordinator (ACTC)
AppleSeed/CQF member since 1998
Kerio Messaging Partner
  •  
stewie

Messages: 106
Karma: 0
Send a private message to this user
Marook, that's great info & I'm glad it fixes the problem. It's strange that OS X 10.5 is having an issue since it supports 64-bit apps & processors from the G5 up are 64-bit. So I wonder why this is causing a problem?
  •  
marook

Messages: 520

Karma: 3
Send a private message to this user
Well,

10.5 does support 64bit processes, but Only on the BSD level. The Kernel is 32 bit and the Cocoa SDK is 32 bit! (according to all slides from WWDC)
If you try to run anything that access Cocoa SDK frameworks, it will crash hard (as it does).

It seems strange to me that a 10.5.x sync utility even has a 64-bit target, as it's never going to be needed. At least, I don't hope KSH is going to use over 4GB of RAM to do the sync for a user... !

Regards,

Jakob Peterhänsel
Consultant - Humac A/S

Apple Certified Support Professional (ACSP)
Apple Certified Technical Coordinator (ACTC)
AppleSeed/CQF member since 1998
Kerio Messaging Partner
  •  
clcadmin

Messages: 3
Karma: 0
Send a private message to this user
I tried this in terminal but I got No such file or directory errors.

I had copied and pasted the commands into terminal.
  •  
marook

Messages: 520

Karma: 3
Send a private message to this user
Sorry if there is a typo, but then 'cd' into the folder by typing the path and validating with Tap.
Or maybe the Kerio Sync prefpabe is not installed under your user?

Regards,

Jakob Peterhänsel
Consultant - Humac A/S

Apple Certified Support Professional (ACSP)
Apple Certified Technical Coordinator (ACTC)
AppleSeed/CQF member since 1998
Kerio Messaging Partner
  •  
rbisang

Messages: 3
Karma: 0
Send a private message to this user
Thank you marook, this fixes the problem.

The correct path is:
cd "Library/PreferencePanes/Kerio Sync Connector.prefpane/Contents/Resources/KerioSyncHelper.app/Co ntents/MacOS/ "
  •  
henriok

Messages: 15
Karma: 2
Send a private message to this user
Please Kerio, fix this ASAP!
  •  
pchernoff

Messages: 120
Karma: 0
Send a private message to this user
I was able to get this to work on an Intel iMac running 10.5.8 by turning off SSL. I haven't had any problems on a PowerMac Dual G5 also running Mac OS X 10.5.8.
  •  
clcadmin

Messages: 3
Karma: 0
Send a private message to this user
How do we turn the SSL off and still use our SSL certificate?
  •  
pchernoff

Messages: 120
Karma: 0
Send a private message to this user
Of course that is a major problem. I have to look for the older software to provide to our laptop users and for people to use at home. For local users we will just try not using SSL until Kerio fixes this problem. I was pointing out one possible short-term fix and where the programming error might lie.
  •  
clcadmin

Messages: 3
Karma: 0
Send a private message to this user
I tried turning off the SSL and then running the sync. It lasted a little longer before it crashed, but it did still crash so that didn't solve our problem.
Previous Topic: Kerio Sync Connector crashes since KC7 upgrade
Next Topic: Kerio Webmail and Firefox Corrupt Word Doc attachments
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Sep 19 22:42:18 CEST 2017

Total time taken to generate the page: 0.00509 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.