Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Certificate Problem (Macs and iPhones do not recognize certificate authority.)
  •  
pchernoff

Messages: 120
Karma: 0
Send a private message to this user
We are having a certificate problem. We bought a certificate
from Network Solutions for the mail server. I installed the certificate in KC.
When I connect from an iPhone or a Mac (web browser or Kerio Sync Connector for
Mac or iCal) I get an error that the certificate provider is not recognized. I
look at details and Network Solutions Certificate Authority is the signer and I
am told that "This certificate was signed by an unknown authority." I realize
that browsers and the like have a list of know certificate authorities. How can
Network Solutions be unknown?

When we got the certificate it came in a zip file. In it was 4 files:
AddTrustExternalCARoot.crt
MAIL.WASHINGTONIAN.COM.crt
NetworkSolutions_CA.crt
UTNAddTrustServer_CA.crt

I was only able to install MAIL.WASHINGTONIAN.COM.crt into KerioConnect 7 because the other 3 required keys. Is there another step I need to take for installation?
  •  
marook

Messages: 520

Karma: 3
Send a private message to this user
Seems like the Root or intermediate certificate for Network Solutions is not installed on your Mac & iPhones.

Regards,

Jakob Peterhänsel
Consultant - Humac A/S

Apple Certified Support Professional (ACSP)
Apple Certified Technical Coordinator (ACTC)
AppleSeed/CQF member since 1998
Kerio Messaging Partner
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
You also probably need to install the intermediate SSL certificates (the other files you've got from Network Solutions) into the Kerio Connect: http://manuals.kerio.com/kms/en/sect-kmscert.html (look at the bottom).

[Updated on: Mon, 01 March 2010 15:55]

  •  
pchernoff

Messages: 120
Karma: 0
Send a private message to this user
Thanks for the suggestions. I took the unidentified .crt files into the appropriate directory on the Kerio server, stopped and restarted KerioConnect and all seems to be peachy now.
Previous Topic: Distributed domain
Next Topic: Cisco VoIP
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Nov 24 06:32:25 CET 2017

Total time taken to generate the page: 0.00391 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.