Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Can't disable Archive Folder Access for one user
  •  
OneClick

Messages: 27
Karma: 0
Send a private message to this user
Using the webadmin console I 'm not able to disable
access to the Archive Folder for one user.

Public folder checkbox works as expected and other users have no problems either.

Now the user can see all private messages send by other users trough Apple Mail
Sad
  •  
OneClick

Messages: 27
Karma: 0
Send a private message to this user
I just noticed that the webmail reflects the same problem.
I'm not able to remove the user (button grayed out) or change privileges (popup doesn't exist)

(see attached file)

[Updated on: Mon, 15 March 2010 22:47]

  •  
sedell

Messages: 1168
Karma: 1
Send a private message to this user
You have to edit archive permissions manually. In the archive folder, default is in Kerio\MailServer\store\archive, look for a file named acl.fld. It should contain lines looking similar to the following:

Administrator<_at_>domain.com lrswicda
someuser<_at_>domain.com lrswicda
anotheruser<_at_>domain.com lrs

Delete the line corresponding to the user you want to remove access for. It's been a long while since I've set mine up. I can't remember if the server needs to be offline to make the change, or if you can make it while it's running.

Scott
  •  
OneClick

Messages: 27
Karma: 0
Send a private message to this user
sedell wrote on Tue, 16 March 2010 12:53
You have to edit archive permissions manually. In the archive folder, default is in Kerio\MailServer\store\archive, look for a file named acl.fld. It should contain lines looking similar to the following:

Administrator<_at_>domain.com lrswicda
someuser<_at_>domain.com lrswicda
anotheruser<_at_>domain.com lrs

Delete the line corresponding to the user you want to remove access for. It's been a long while since I've set mine up. I can't remember if the server needs to be offline to make the change, or if you can make it while it's running.


When I opened the file a noticed that there was no entry for the default administrator.
I opened my web-console and sure enough I had disabled
Archive-folder-access even for the admin.

Hence te regular user became the last entry in acl.fld and couldn't be deleted.

I enabled acces for admin again and then was able to remove access for the regular user as expected.

Laughing


  •  
sedell

Messages: 1168
Karma: 1
Send a private message to this user
I hadn't noticed the "Archive Folders" in the new web administration. I just love that they're leaving features/options like this out of the standard admin console. That will make the server so much easier to work with. Going to have to check multiple places for settings now... fantastic!

Scott
Previous Topic: ActiveSync address with distributed domains?
Next Topic: Batch move or delete mail from or to certain email addresses
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sat Oct 21 14:18:10 CEST 2017

Total time taken to generate the page: 0.00427 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.