Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Kerio Connect HTTP service starting automatically after being disabled/stopped
  •  
Tim

Messages: 15

Karma: 0
Send a private message to this user
I have had another thread on here, but the issue never got resolved and I have duplicated the issue on 2 other servers.
I install Kerio Connect.
Stop the http service.
Install SQL Server 2008 Enterprise.
Restart the server.
Kerio Connect http service is enabled.
I have to manually log in to kerio and disable http service again.
Why?
This only happens once. After several reboots and days of operation, I have only had to disable the service again after installing M$ sql 2008.
I uninstall sql 2008 and reinstall, and I again have to stop the http service in Kerio.
I am trying to bring the issue to the attention of anyone that may be able to fix this "issue" in a future version, or at least document it in an FAQ so someone does not have to wonder why IIS is no longer taking port 80 and kerio has it.
Thank you for your time,
Tim

[Updated on: Wed, 21 July 2010 07:51] by Moderator

  •  
Tim

Messages: 15

Karma: 0
Send a private message to this user
So, mod, why did you remove my signature after I added it?

[Updated on: Wed, 21 July 2010 08:18] by Moderator

  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
Tim wrote on Wed, 21 July 2010 08:01
So, mod, why did you remove my signature after I added it?


I'm sorry but I have a feeling that propagating your company is more important than resolving the issue in your posts. I already mentioned that in previous thread.

[Updated on: Wed, 21 July 2010 08:23]

  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
Tim, everything has been already said in the previous topic. It seems you don't want to follow the advice of contacting our technical support for some reason.

Ok. So there is a crucial question which should provide final answer: What do you mean with "Stop the http service"? Did you actually configure it to not start on any IP address or just temporarily disable it?
  •  
Tim

Messages: 15

Karma: 0
Send a private message to this user
Thank you for replying poboy.
I really appreciate it.
To be exact, I logged into Kerio Connect Administration, navigated to configuration then services and edited the http service in properties. I changed it from Automatic to Manual.
I "ok'd" it and got out of the interface.
I have duplicated this issue on 2 other servers.
It may not seem like a major issue, but it is one nonetheless.
I also tried to duplicate the issue by changing the port of the http service from 80 to 8080 and after the sql install Kerio also started the service once again.
Now, I have restarted the servers several times, checking to see if Kerio would change the http service from manual to auto. It did not until I installed SQL 2008 ent.
I am done trying to bring this issue to your attention and I am also finished messing with you about the signature. I understand you don't want people promoting email marketing websites. Perhaps you should mention that if you sell email lists, you will be treated horribly, not taken seriously, continuously insulted and treated like you have the plague.
I hope you take this seriously. I am not trying to cause you or anyone any trouble. I am trying to make a living just like you. I found a flaw in a great program and I am trying to bring it to light.
Have a great night,
Tim
  •  
freakinvibe

Messages: 1554
Karma: 62
Send a private message to this user
Quote:
I install Kerio Connect.
Stop the http service.
Install SQL Server 2008 Enterprise.
Restart the server.
Kerio Connect http service is enabled.

There are two things:

  1. Stopping the service: That only stops the service, but after the next reboot, it starts again
  2. Setting the service to "Manual": The service is still started, but will not start automatically upon next reboot


So what you should do is:

Stop the http service
Set the http service to manual
Click OK, so this setting is saved
If you want to make sure that it sticks, just navigate away from the services screen and then go back to the services screen. It should still show "Manual" and "Stopped".

Then reboot the box. After the reboot, check if the setting is still "Manual" and "Stopped". It should still be, at least it works for me (Windows 2008 Server).

Now install SQL 2008 Enterprise. Reboot. After the reboot, check if the setting is still "Manual" and "Stopped". I have done this and it sticks with me, so maybe something else happens on your server during reboot.

It is clear that SQL2008 does not change anything in the Kerio config, it isn't even aware that Kerio exists. The "Manual" setting is saved in mailserver.cfg in the Kerio directory:

<table name="service-http">
  <variable name="Port">80</variable>
  <variable name="AutoStart">0</variable>
  <variable name="Acl"></variable>
  <variable name="MaxConnections">1000</variable>
  <variable name="MinWorkersCount">0</variable>
  <variable name="MaxWorkersCount">0</variable>
  <variable name="MaxSpareWorkers">5</variable>
  <variable name="MaxTasksHandled">0</variable>
  <variable name="ShutdownTimeout">15</variable>
  <variable name="RecvTimeout">120</variable>
  <variable name="SendTimeout">120</variable>
  <variable name="MaxConnectionsIP">100</variable>
  <variable name="NoLimitAcl"></variable>
  <variable name="Guid">9b467b81-0794-41f3-b177-6118878521b9</variable>
</table>


AutoStart = 0 means that the service is set to manual. There is ABSOLUTELY NO WAY that the SQL installation would change this file in the Kerio folder. So something else must be fishy on your machines.

If you have IIS or any other Web service installed, it might conflict with port 80, so the service that starts first will win and the second will not start.

[Updated on: Wed, 21 July 2010 14:07]


Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
Previous Topic: ActiveSync error
Next Topic: Migrate to Exchange?
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Nov 23 19:49:10 CET 2017

Total time taken to generate the page: 0.00403 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.