Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Kerio reporting host not found trying to deliver to subdomain of primary
  •  
RyeGuyWpg

Messages: 24
Karma: 0
Send a private message to this user
I am in the process of setting up a trial for user of Google Apps and have been unsuccessful in getting Kerio to forward mail to the Google domain. Kerio keeps reporting host not found even though the MX record for the subdomain exists.
Here is how I have it setup;
My domain name is (not real domain name) - domain.com
I have a CNAME record for my subdomain - gtest.domain.com is an alias for google.com in my DNS
I have an MX record for domain.com. This is my primary domain in Kerio and all is well
I have an MX records for gtest.domain.com which points to google's mailservers

If I send emails to user<_at_>gtest.domain.com outside of Kerio (ie: Mobile Me), everything is fine and the mail goes where expected
If I send an email to user@gtest.domain.com through Kerio while logged in as a user of domain.com (ie:user@domain.com), Kerio reports: user<_at_>gtest.domain.com Result: failed, Status 5.4.4 Host not found.

On the Kerio server, if I do an MX lookup for gtest.domain.com, it comes up correctly but for some reason, Kerio can't find it and I can't figure out if it is because I am using a subdomain or not.

I have tried using the Forwarding option for the domain but that didn't change anything. Also, SMTP is set to Deliver using MX DNS Records.

Can anyone offer any suggestions?
I am running Kerio Connect 7 on OS X
  •  
RyeGuyWpg

Messages: 24
Karma: 0
Send a private message to this user
Also, a quick note that we have DNS running on the Kerio server. I added a CNAME record for gtest.domain.com and the reason is that if I didn't, gtest.domain.com definitely wouldn't resolve bu kerio as the internal DNS wouldn't have an A record for gtest.domain.com and the lookup would fail. If I browse to gtest.vtexvsi.com in Safari,it resolves to google.com. Once again, I can do an MX lookup on the Kerio server and it returns google's mailserver address as expected and it works outside of Kerio.
Thx
  •  
freakinvibe

Messages: 1552
Karma: 62
Send a private message to this user
I have tried to send a mail to

user<_at_>gtest.vtexvsi.com

and it finds the server, but obviously not the user as you can se per the error message below. So you must have either a DNS config problem or your firewall doesn't let your Kerio Server send over port 25.

Quote:
The server was not able to deliver your email message

Subject: test gtest.vtexvsi.com
Date: Thu, 29 Jul 2010 17:25:19 +0200

to the following addresses:

<user<_at_>gtest.vtexvsi.com> (ASPMX.L.GOOGLE.com: 550-5.1.1 The email account that you tried to reach does not exist. Please try
550-5.1.1 double-checking the recipient's email address for typos or
550-5.1.1 unnecessary spaces. Learn more at
550 5.1.1 http://mail.google.com/support/bin/answer.py?answer=6596 b7si1073610faq.46)


So the questions is, can you send mail out to any server? (for example a hotmail account)

Dexion AG - The Blackberry Specialists in Switzerland
https://dexionag.ch
Previous Topic: 'Invitees' category is missing in iCal
Next Topic: Filter Help - Match rma but allow other Subject contents
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon Nov 20 08:39:14 CET 2017

Total time taken to generate the page: 0.00424 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.