Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » kimt migration from Mac OS X 10.4 server (It worked for a test user and then fell over...)
  •  
woodgie

Messages: 2
Karma: 0
Send a private message to this user
So here's my problem. I have an old 10.4 server and want to move all the mail from it to the shiny, fresh new Kerio Connect 7.1 install I have on another server.

I'm trying to use kimt to pull the user's data from one mail server to another. My CSV file is parsed OK but I'm getting:

[2954420224]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MeAPI.cpp:128 (testImap): KMS test on IMAP server - cannot connect.


As the second line of the debug log.

It DID work fine when I just chose 2 users and migrated them across to check I had the process right. I took just the first 2 users from my csv file and imported them. That worked a treat. I then deleted those users from Kerio and re-ran kimt with the full csv file and hit problems. On trying to import ANY user (even the 2 who imported correctly in the test) I get log lines like this:

[2954952704]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MigratorThread.cpp:254 (execute): Domain  could not be created, (error=1)!.
[2954952704]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MigratorThread.cpp:255 (execute): Skipping user accounts@


I've even gone as far as to reinstall Kerio from the ground up on a completely fresh Mac OS X 10.5.8 installation to try to ensure there is NO cruft. The annoying thing is that now even a single user won't import (same error as above) let alone the whole lot of them.

Any help greatly appreciated.

Here's the log in it's (almost) entirety:

LogManager initialized successfully; reportFileName='/Users/william/Library/Logs/KimtLogs/08212010_111908/report.txt', debugFileName='/Users/william/Library/Logs/KimtLogs/08212010_111908/debug.log'
[2954420224]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MeAPI.cpp:128 (testImap): KMS test on IMAP server - cannot connect.
Testing IMAP server: 192.168.10.254
IMAP server connection tested successfully.
Source ImapServer greeting: * OK mailgate.vividbrand.com Cyrus IMAP4 v2.2.12-OS X 10.4.8 server ready

[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MeAPI.cpp:198 (testKms): Testing KMS on 192.168.10.249
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MeAPI.cpp:210 (testKms): TinyDB test passed.
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MeAPI.cpp:214 (testKms): KMS version: Kerio Connect 7.1.0 build 1792(Mac OS X (10.5.8), PowerPC)
[2697159936]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:199 (prepareMigration): KMS version: Kerio Connect 7.1.0 build 1792(Mac OS X (10.5.8), PowerPC)
[2697159936]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:158 (start): Kerio IMAP Migration Tool 7.1.0.1792 T0
KMS version: Kerio Connect 7.1.0 build 1792(Mac OS X (10.5.8), PowerPC)
Kerio IMAP Migration Tool 7.1.0.1792 T0
[2954952704]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MigratorThread.cpp:238 (execute): Migration thread started
[2955485184]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MigratorThread.cpp:238 (execute): Migration thread started
[2956017664]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MigratorThread.cpp:238 (execute): Migration thread started
[2956550144]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MigratorThread.cpp:238 (execute): Migration thread started
[2957082624]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MigratorThread.cpp:238 (execute): Migration thread started
[2957615104]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MigratorThread.cpp:238 (execute): Migration thread started
[2954952704]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MigratorThread.cpp:249 (execute): 
[2954952704]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MigratorThread.cpp:254 (execute): Domain  could not be created, (error=1)!.
[2954952704]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MigratorThread.cpp:255 (execute): Skipping user accounts@

<snippity-snip of a trillion users, OK 75 of them all with the same error as the first>


[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:302 (reportTotalStatus): 
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:303 (reportTotalStatus): ************************************************************************************************
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:304 (reportTotalStatus): SUMMARY
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:309 (reportTotalStatus): Migration finished
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:311 (reportTotalStatus): Accounts total: 
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:312 (reportTotalStatus): 	count: 75
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:313 (reportTotalStatus): 	done: 0
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:314 (reportTotalStatus): 	errors: 75
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:316 (reportTotalStatus): Folders total: 
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:317 (reportTotalStatus): 	done: 0
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:318 (reportTotalStatus): 	errors: 0
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:320 (reportTotalStatus): Messages total: 
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:321 (reportTotalStatus): 	done: 0
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:322 (reportTotalStatus): 	errors: 0
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:324 (reportTotalStatus): 
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:326 (reportTotalStatus): Migration start: Sat Aug 21 11:21:24 2010
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:327 (reportTotalStatus): Migration end:   Sat Aug 21 11:21:25 2010
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:329 (reportTotalStatus): 
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:331 (reportTotalStatus): 
[2953850880]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/Migrator.cpp:333 (reportTotalStatus): ************************************************************************************************

************************************************************************************************
SUMMARY
Migration finished
Accounts total: 
	count: 75
	done: 0
	errors: 75
Folders total: 
	done: 0
	errors: 0
Messages total: 
	done: 0
	errors: 0

Migration start: Sat Aug 21 11:21:24 2010
Migration end:   Sat Aug 21 11:21:25 2010


************************************************************************************************

~W
  •  
woodgie

Messages: 2
Karma: 0
Send a private message to this user
I've just been looking at the logs on the Kerio server and I see this in the Security Log:

[21/Aug/2010 11:20:31] Administration: Protocol violation: network error, client failure, wrong client or client doesn't trust us. Peer was connected from 192.168.10.235:53554 to 0.0.0.0:0. Session with ID 12 not established.


Seems to me to be related to the:

[2954420224]	In /Autobuild/Builds/KMS-1792-rEQi6m8/autobuild/mailserver/MigrationTool/Imap/engine/MeAPI.cpp:128 (testImap): KMS test on IMAP server - cannot connect.


error I was getting in the kimt logs

~W
Previous Topic: problems with using OD as directory service
Next Topic: MAc book pro nokia e 72 sync
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Oct 17 11:29:52 CEST 2017

Total time taken to generate the page: 0.00433 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.