Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Problems with mail not showing up in inbox
  •  
andreasw

Messages: 7
Karma: 0
Send a private message to this user
We have problems with kerio 7.1.0 build 1792 and mail not showing up in users inbox och with Apple Mail as client.

Seems like the index.fld is corrupted and it has happned multiple times in the last weeks. I´ve read that the index.fld may be corrupted if the kerio mailserver is shutdown inproperly atleast with older versions. In this case kerio mailserver hasnt been shutdown since the last upgrade and the physical server hasnt been shutdown in maybe 5 month.

Is there any solution to this, i know that the user in question always moves his email to an other folder than the inbox when the email is read this means that it always no read email in his inbox, only unread emails.

Maybe this puts alot of stress to the inbox.fld or no stress at all because the inbox contains only a few emails most of the time ?

The problem occures that new mails is not shown in his INBOX, restart the Apple Mail and then the new mail appers in the inbox folder.



  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
andreasw wrote on Mon, 18 October 2010 10:02

Seems like the index.fld is corrupted and it has happned multiple times in the last weeks.

Does the user see the emails in WebMail? If so, then the index is not corrupted. Forcing folder re-indexation may be destructive action and some irresponsible administrators use this quite often even it there is no problem at all.
Quote:

The problem occures that new mails is not shown in his INBOX, restart the Apple Mail and then the new mail appers in the inbox folder.

Then it's clear this is a client problem. Search this forum. Some other people reported that Apple Mail client is not much reliable particularly when the folder contains many messages.
  •  
andreasw

Messages: 7
Karma: 0
Send a private message to this user
Thanks for you quick reply Kerio_pdobry!

Kerio_pdobry wrote on Mon, 18 October 2010 10:13
andreasw wrote on Mon, 18 October 2010 10:02

Seems like the index.fld is corrupted and it has happned multiple times in the last weeks.

Does the user see the emails in WebMail? If so, then the index is not corrupted. Forcing folder re-indexation may be destructive action and some irresponsible administrators use this quite often even it there is no problem at all.

First time problem occured we shutdown the mailserver and renamed .fld file and the started the mailserver again. For a large organisation restarting mailserver like this is NOT a solution, i couldnt agree with you more. I´ll check the webmail and see if the mails shows up there.

Quote:

Quote:

The problem occures that new mails is not shown in his INBOX, restart the Apple Mail and then the new mail appers in the inbox folder.

Then it's clear this is a client problem. Search this forum. Some other people reported that Apple Mail client is not much reliable particularly when the folder contains many messages.


For large mailboxes this may be a problem, but in this case the INBOX only contains the new unread emails, no old mail at all. This results in maybe maximum 20 or less emails in the INBOX.


I´ll continue to search for this problem.
But the problem dissapeard for 7-8 days when we renamed the index.fld file. Maybe it was luck that the problem stopped for a while after the restart or the problem is the kerio mailserver together with the Apple Mail client trashing the index.fld file.

We have other customers running kerio with Apple Mail(10.5 leopard) with no problems, this problem is isolated to one specific user i our case.




  •  
suppertrupper

Messages: 20
Karma: 1
Send a private message to this user
here same behaviour for some users using apple mail/IMAP on osx 10.5.8
the mails are shown in webmail- yes ! after quitting an restart mail the missing messages are in the inbox !

we have users with quite a lot of mails store up to 8GB !

was searching for a while
I searched with google but didn't get any solution.

is there a file in /library/mail which could be deleted to force mail du a new one ?


thanks for help








  •  
giobbi

Messages: 90
Karma: 0
Send a private message to this user
Try rebuild in menu first. Then you could delete Envelope Index if that doesn't work. But do it as a last resort.
  •  
andreasw

Messages: 7
Karma: 0
Send a private message to this user
I´ve contacted the kerio support, and as usual quick and good respones ! Thank you for that Kerio !

The solution from the support was to change the AutoExpungeOnDelete option i mailserver.cfg. see below for complete response from the support


There is a possibility that auto expunge on delete is causing this issue. Please try the following

Quote:

1. stop the mailserver
2. open mailserver.cfg with text editor
3. find "AutoExpungeOnDelete", change 1 to 0.

You might as well re-index one more time, and see this problem stop.



I´ll let you all know if this solved the problem.

thanks for all responses.
  •  
suppertrupper

Messages: 20
Karma: 1
Send a private message to this user
I got a other response of kerio support, seams to work
sens 2 weeks the affected user haven't ny problems more with there mails!

Close Apple Mail > Stop Kerio Connect Service > Navigate to the user's mailbox folder on the server > Move the "properties.fld" file out of the user's folder > Start Kerio Connect > Create a new Apple Mail Account.


hope it help's
Mic
  •  
andreasw

Messages: 7
Karma: 0
Send a private message to this user
I can confirm that the solution i got from the kerio support still works,

i't may be 2 solutions to the same problem.
Previous Topic: Lost e-mail?
Next Topic: Beta....
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Sep 22 06:39:37 CEST 2017

Total time taken to generate the page: 0.00455 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.