Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Workspace » Mac install broken (1.0.0b5 trial install)
  •  
AdamSteinberg

Messages: 4
Karma: 0
Send a private message to this user
See attachment. I run the installer on my MacBook Pro, 10.6.4, stock, afterwards, the installer opens localhost:80/admin/, and the URL isn't found.

I'm not that versed in UNIX geekery, I'm sure I could probably figure this out, but I don't want to have to do that.

Help! Also see attached install log.

  •  
PeterBarlow

Messages: 24
Karma: 0
Send a private message to this user
Me too!!!
I've been tearing my hair out the last two days trying to get a fresh install completed to start over with a small test group production install after uninstalling the test bench installation we started with.
I thought I was doing something dumb with the install - no.
I thought it was because we are behind an authenticating proxy, when my original sandpit wasn't - no.
I thought it was because I was also testing Mac OS X Server Developer Seed 10.6.5 - no.
I'm now thinking the recent Java 1.6 Update from Apple might be breaking KWS.
I'll test this next.
Can anyone else confirm what is going on here?
As Adam says above, the install seems to complete fully, but the web server doesn't fire up - no Port 80 is opened, and the opening of the admin page URL of course then fails.
My system.log shows repeating lines, until I uninstall KWS, like -
Quote:
Oct 27 06:54:01 PICTS-MBP15-A1783 com.apple.launchd[1] (com.kerio.workspace.application[2885]): Exited with exit code: 1
Oct 27 06:54:01 PICTS-MBP15-A1783 com.apple.launchd[1] (com.kerio.workspace.application): Throttling respawn: Will start in 10 seconds
Oct 27 06:54:11 PICTS-MBP15-A1783 com.apple.launchd[1] (com.kerio.workspace.application[2898]): Exited with exit code: 1
Oct 27 06:54:11 PICTS-MBP15-A1783 com.apple.launchd[1] (com.kerio.workspace.application): Throttling respawn: Will start in 10 seconds
Oct 27 06:54:21 PICTS-MBP15-A1783 com.apple.launchd[1] (com.kerio.workspace.application[2913]): Exited with exit code: 1
Oct 27 06:54:21 PICTS-MBP15-A1783 com.apple.launchd[1] (com.kerio.workspace.application): Throttling respawn: Will start in 10 seconds

... and the install.log I get, a bit different to Adam's, shows -
Quote:
...
Oct 27 06:50:29 PICTS-MBP15-A1783 installd[2565]: ./postflight: + launchctl load /Library/LaunchDaemons/com.kerio.workspace.application.plist
Oct 27 06:50:29 PICTS-MBP15-A1783 installd[2565]: ./postflight: + '[' yes == yes ']'
Oct 27 06:50:29 PICTS-MBP15-A1783 installd[2565]: ./postflight: + (( index=0 ))
Oct 27 06:50:29 PICTS-MBP15-A1783 installd[2565]: ./postflight: + (( index < 300 ))
Oct 27 06:50:29 PICTS-MBP15-A1783 installd[2565]: ./postflight: + '[' '!' -f /usr/local/kerio/workspace/workspace-init.xml ']'
Oct 27 06:50:29 PICTS-MBP15-A1783 installd[2565]: ./postflight: + sleep 1
Oct 27 06:50:30 PICTS-MBP15-A1783 installd[2565]: ./postflight: + (( index++ ))
Oct 27 06:50:30 PICTS-MBP15-A1783 installd[2565]: ./postflight: + (( index < 300 ))
Oct 27 06:50:30 PICTS-MBP15-A1783 installd[2565]: ./postflight: + '[' '!' -f /usr/local/kerio/workspace/workspace-init.xml ']'
Oct 27 06:50:30 PICTS-MBP15-A1783 installd[2565]: ./postflight: + sleep 1
Oct 27 06:50:31 PICTS-MBP15-A1783 installd[2565]: ./postflight: + (( index++ ))
Oct 27 06:50:31 PICTS-MBP15-A1783 installd[2565]: ./postflight: + (( index < 300 ))
Oct 27 06:50:31 PICTS-MBP15-A1783 installd[2565]: ./postflight: + '[' '!' -f /usr/local/kerio/workspace/workspace-init.xml ']'
Oct 27 06:50:31 PICTS-MBP15-A1783 installd[2565]: ./postflight: + sleep 1
... --MANY REPEATS OF THIS-- ...
Oct 27 06:55:29 PICTS-MBP15-A1783 installd[2565]: ./postflight: + (( index++ ))
Oct 27 06:55:29 PICTS-MBP15-A1783 installd[2565]: ./postflight: + (( index < 300 ))
Oct 27 06:55:29 PICTS-MBP15-A1783 installd[2565]: ./postflight: + '[' '!' -f /usr/local/kerio/workspace/workspace-init.xml ']'
Oct 27 06:55:29 PICTS-MBP15-A1783 installd[2565]: ./postflight: + sleep 1
Oct 27 06:55:30 PICTS-MBP15-A1783 installd[2565]: ./postflight: + (( index++ ))
Oct 27 06:55:30 PICTS-MBP15-A1783 installd[2565]: ./postflight: + (( index < 300 ))
Oct 27 06:55:30 PICTS-MBP15-A1783 installd[2565]: ./postflight: + open http://localhost:80/admin/
Oct 27 06:55:30 PICTS-MBP15-A1783 installd[2565]: ./postflight: + echo DONE
Oct 27 06:55:30 PICTS-MBP15-A1783 installd[2565]: ./postflight: DONE
Oct 27 06:55:31 PICTS-MBP15-A1783 installd[2565]: Installed "Kerio Workspace" ()
Oct 27 06:55:31 PICTS-MBP15-A1783 installd[2565]: PackageKit: ----- End install -----
Oct 27 06:55:31 PICTS-MBP15-A1783 Installer[2556]: Removing temporary directory " /var/folders/cH/cHEXYaJ12RaNMk+BYpVjLU+++TM/-Tmp-//Install.2 556TpJGnd "
Oct 27 06:55:31 PICTS-MBP15-A1783 Installer[2556]: Finalize disk "MBP15dat"
Oct 27 06:55:31 PICTS-MBP15-A1783 Installer[2556]: Notifying system of updated components
Oct 27 06:55:32 PICTS-MBP15-A1783 Installer[2556]:
Oct 27 06:55:32 PICTS-MBP15-A1783 Installer[2556]: **** Summary Information ****
Oct 27 06:55:32 PICTS-MBP15-A1783 Installer[2556]: Operation Elapsed time
Oct 27 06:55:32 PICTS-MBP15-A1783 Installer[2556]: -----------------------------
Oct 27 06:55:32 PICTS-MBP15-A1783 Installer[2556]: zero 0.01 seconds
Oct 27 06:55:32 PICTS-MBP15-A1783 Installer[2556]: install 322.13 seconds
Oct 27 06:55:32 PICTS-MBP15-A1783 Installer[2556]: disk 0.01 seconds
Oct 27 06:55:32 PICTS-MBP15-A1783 Installer[2556]: -total- 322.15 seconds
Oct 27 06:55:32 PICTS-MBP15-A1783 Installer[2556]:
Oct 27 06:55:32 PICTS-MBP15-A1783 Installer[2556]: IFDInstallController 10B3B0 state = 5
Oct 27 06:55:32 PICTS-MBP15-A1783 Installer[2556]: Displaying 'Install Succeeded' UI.

My java -version command returns -
Quote:
PICTS-MBP15-A1783:~ peterb$ java -version
java version "1.6.0_22"
Java(TM) SE Runtime Environment (build 1.6.0_22-b04-307-10M3261)
Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03-307, mixed mode)
PICTS-MBP15-A1783:~ peterb$

Help!
I'd really like to be getting KWS back up and running.
  •  
Jarda Snajdr (Kerio)

Messages: 221
Karma: 12
Send a private message to this user
Adam and Peter,

please look at these two log files:

/usr/local/kerio/workspace/logs/kerio-workspace-catalina.log
/usr/local/kerio/workspace/logs/kerio-workspace-catalina.err

If anything failed during the service startup, these files should contain error messages. Please send both files to my email address: jsnajdr<_at_>kerio.com

Thanks
Jarda
  •  
PeterBarlow

Messages: 24
Karma: 0
Send a private message to this user
Hi Jarda,
I have done further testing and sent you the log files as requested.
Seems fairly obvious to me that it is the recent Java 1.6_22 update from Apple that is upsetting something, as I have done a fresh system build, installed KWS and all went fine until I installed that Java update and rebooted.
Cheers, Peter B.
Previous Topic: File library not showing any files
Next Topic: Mac - KWS installer pop up
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Oct 17 11:30:46 CEST 2017

Total time taken to generate the page: 0.00368 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.