Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Workspace » HTTPS broken after update to Beta6
  •  
Mike A.

Messages: 4
Karma: 0
Send a private message to this user
After updating workspace to beta6, I can no longer access it via https.
This is on Ubuntu 10.04 LTS

I think the following may be relevant:
[04/Nov/2010 16:44:55] ERROR: A web application registered the JBDC driver [org.apache.derby.jdbc.AutoloadedDriver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered.
[04/Nov/2010 16:44:55] ERROR: A web application created a ThreadLocal with key of type [org.apache.derby.iapi.sql.dictionary.TableDescriptor$1] (value [org.apache.derby.iapi.sql.dictionary.TableDescriptor$1<_at_ >1ee0880]) and a value of type [java.util.WeakHashMap] (value [{=null}]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
[04/Nov/2010 16:44:55] ERROR: A web application created a ThreadLocal with key of type [java.lang.ThreadLocal] (value [java.lang.ThreadLocal@702936]) and a value of type [org.apache.derby.iapi.services.context.ContextManager] (value [org.apache.derby.iapi.services.context.ContextManager<_at_ >1508f31]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
[04/Nov/2010 16:44:55] ERROR: A web application created a ThreadLocal with key of type [org.apache.derby.iapi.sql.dictionary.TableDescriptor$1] (value [org.apache.derby.iapi.sql.dictionary.TableDescriptor$1<_at_ >1ee0880]) and a value of type [java.util.WeakHashMap] (value [{=null, =null, =null}]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
[04/Nov/2010 16:44:55] ERROR: A web application created a ThreadLocal with key of type [java.lang.ThreadLocal] (value [java.lang.ThreadLocal@702936]) and a value of type [org.apache.derby.iapi.services.context.ContextManager] (value [org.apache.derby.iapi.services.context.ContextManager<_at_ >7ab839]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
[04/Nov/2010 16:44:55] ERROR: A web application created a ThreadLocal with key of type [java.lang.ThreadLocal] (value [java.lang.ThreadLocal@702936]) and a value of type [org.apache.derby.iapi.services.context.ContextManager] (value [org.apache.derby.iapi.services.context.ContextManager<_at_ >d5276a]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
[04/Nov/2010 16:44:55] ERROR: A web application created a ThreadLocal with key of type [java.lang.ThreadLocal] (value [java.lang.ThreadLocal@702936]) and a value of type [org.apache.derby.iapi.services.context.ContextManager] (value [org.apache.derby.iapi.services.context.ContextManager<_at_ >13b23d6]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
[04/Nov/2010 16:44:55] ERROR: A web application created a ThreadLocal with key of type [java.lang.ThreadLocal] (value [java.lang.ThreadLocal@702936]) and a value of type [org.apache.derby.iapi.services.context.ContextManager] (value [org.apache.derby.iapi.services.context.ContextManager<_at_ >e4d7f7]) but failed to remove it when the web application was stopped. To prevent a memory leak, the ThreadLocal has been forcibly removed.
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0xb44b9af4, pid=23043, tid=3022523248
#
# JRE version: 6.0_20-b02
# Java VM: Java HotSpot(TM) Client VM (16.3-b01 mixed mode, sharing linux-x86 )
# Problematic frame:
# C [libapr-1.so.0+0x1aaf4]
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid23043.log

  •  
Jarda Snajdr (Kerio)

Messages: 221
Karma: 12
Send a private message to this user
Hello Mike,

are you sure this started happening only after upgrade to beta 6? Didn't you also upgrade some system packages?

The Workspace server crashed inside a native C code that handles SSL connections. We didn't change anything significant in this area in beta 6.

Does this happen every time you try to connect to the server using HTTPS? Or is it a random problem that happens intermittently?

Anyway, we'll try to reproduce the problem on Ubuntu 10.04.

Jarda
  •  
Mike A.

Messages: 4
Karma: 0
Send a private message to this user
We haven't installed any updates on the server hosting kerio workspace recently. I'm positive that up until we installed this update, SSL worked fine (with exception of file uploads /w self signed cert).
I dont think the errors I posted get generated on every attempt to access, but rather on startup - I found them in kerio-workspace-catalina.err.

Do you think there is anything I can check to narrow down the list of possible problems?
  •  
Jarda Snajdr (Kerio)

Messages: 221
Karma: 12
Send a private message to this user
Hello Mike,

the log messages are not related to the HTTPS problem. What's interesting is the crash report you attached: it says that the server application crashed while establishing a SSL connection.

Can you confirm that the server crashes every time you try to access the HTTPS service?

Jarda
  •  
Kris

Messages: 145
Karma: 5
Send a private message to this user
my upgrade of Workspace (alternative ports) has broken my running Kerio Connect running on standard ports. It was fixed after restarting the server.
  •  
Micric

Messages: 4
Karma: 0
Send a private message to this user
No issues here, though I am running on 10.04 LTS x64.

The problems posted above are the same as I saw the first time I installed, 10.04 LTS X86 at this point. The difference is that I got this on both HTTP and HTTPS. Due to time constraints I was forced to reinstall though. Second time round, still on 10.04 LTS X86, I installed in exactly the same fashion but the errors did not occur. I logged all keystokes to ensure I could recreate my procedure.
  •  
Ghiyath

Messages: 21
Karma: 0
Send a private message to this user
Same here, I just uninstall/install it again.. Smile
Previous Topic: Kerio Workspace/Connect
Next Topic: Back-up is too small to cantain uploaded files
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Sep 22 01:09:27 CEST 2017

Total time taken to generate the page: 0.00440 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.