Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Control » Appliance High CPU Usage (compared to windows version)
  •  
MichaelP

Messages: 17
Karma: 0
Send a private message to this user
Hi,

I moved from a Windows test installation to a APPLIANCE installation I notice a lot of more use of CPU on the appliance side.

Kerio Firewall eats always a minimum of server (VMWARE ESXi with Dual xeon) CPU cycles when not passing any traffic! With windows version (inside the ESXi) this is not the case, CPU is alway very low (0%,2%) not passing any traffic, and merely 3, 4% when working hard. I used to think that appliance was faster because of less overhead over KFW over a full windows installation, but is not the case!!!

Now I evaluating again the windows version of Kerio Control, or, if things goes bad i'll try a new application.

Can someone explain this behavior on Appliance? Is there any trick to make CPU usage more regular and similar as windows version? Also, VMWare tools seem a lot outdated maybe are they the problem?

PS I noticed that kerio-console process alone is VERY CPU unary in the appliance, is it normal?

Thanks!

[Updated on: Tue, 09 November 2010 18:24]

  •  
MichaelP

Messages: 17
Karma: 0
Send a private message to this user
Someone from kerio can give me a reply?
  •  
MichaelP

Messages: 17
Karma: 0
Send a private message to this user
No reply? Sorry to see this community forum almost dead...
  •  
styson

Messages: 29
Karma: 0
Send a private message to this user
I don't run the appliance in a virtual environment but installed on a Dual Core Atom (D330) I do not get this behavior. Have you contacted Kerio Support and opened a ticket with them?
  •  
MichaelP

Messages: 17
Karma: 0
Send a private message to this user
In my opinion is something related to VMWARE ESX. Some one can confirm this?
  •  
styson

Messages: 29
Karma: 0
Send a private message to this user
Have you checked the processes running on the appliance to verify which one is having problems? It is possible it's not the Kerio Control Process
  •  
MichaelP

Messages: 17
Karma: 0
Send a private message to this user
Kerio Console process is very process hungry...
  •  
MichaelP

Messages: 17
Karma: 0
Send a private message to this user
I attached 2 pic, one from EXS performance report and one from appliance console.
How you can see my cpu is alway maxed out by the appliance (I forced a 500MHZ limit), in top cpu is 80% idle.

Strange....

index.php?t=getfile&id=2103&private=0

  • Attachment: top.png
    (Size: 35.20KB, Downloaded 1936 times)

[Updated on: Tue, 16 November 2010 10:51]

  •  
MichaelP

Messages: 17
Karma: 0
Send a private message to this user
This is the second one.

Thanks for your help..

index.php?t=getfile&id=2104&private=0

[Updated on: Tue, 16 November 2010 10:52]

  •  
jamec9869

Messages: 1
Karma: 0
Send a private message to this user
In my opinion is something related to VMWARE ESX. Some one can confirm this?




  •  
Goran

Messages: 326
Karma: 5
Send a private message to this user
I know that VmWare using alloooot of cpu usage when he using Virtual networks, can be that.

I also notice that Intrusion (IPS) using cpu to much... for example when is connected more that 15 players on game server, IPS using 100% of CPU and game stat to laging... And stupid is that there you cant exclude ports from checking. Like in QOS you cant give privileges to some port. What all other software firewalls have.

Question cannot be stupid, but some of the answers can.
  •  
MichaelP

Messages: 17
Karma: 0
Send a private message to this user
I'm using testing version 6.7.1, with doesn't include IPS. 500Mhz of continus CPU usage is incompressible for a firewall passing few kilobytes of traffic.

I Hope kerio look into this.


regards
  •  
styson

Messages: 29
Karma: 0
Send a private message to this user
Try testing the latest Beta, they have made many improvements to the product in the 7.x version
  •  
MichaelP

Messages: 17
Karma: 0
Send a private message to this user
Same behavior with last beta... Embarassed
MichaelP

Messages: 17
Karma: 0
Send a private message to this user
OK, just tried 7.1rc in Parallels (using preconfigured appliance). I get 100% CPU utilization in HOST CPU, guest cpu is ZERO! There is something really wrong with the appliance.... Sad

I'm ready to give up with kerio kontrol and move to Endian...

Sorry
Previous Topic: Xbox 360 RROD - Again !
Next Topic: Kerio Control Traffic Shaper
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Sep 20 07:53:31 CEST 2017

Total time taken to generate the page: 0.00548 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.