Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Possibility to set "from address" in backup settings?
  •  
blackjub

Messages: 10
Karma: 0
Send a private message to this user
Hello,

I would like to mail to an external address when a backup schedule completes.
(As defined in "Archiving and backup", "backup" tab)

Between the Kerio Connect server and the Internet, there is a SMTP relaying server, which role is to filter spam/viruses, and such.

Here is the problem I'm getting : my SMTP relay doesn't allow empty "From: <>" or "Return-Path: <>" fields.
(It considers such e-mails as spam)
And of course, I am not allowed to change this behavior from the SMTP Relay...


Here are the messages I get from the Kerio logs :
Service: Backup, From: <>, To: <recipient<_at_>ext-domain.com>, Size: 761, Report: backup
Recipient: <recipient<_at_>ext-domain.com>, Result: failed, Status: 5.1.1 550 Delivery is not allowed to this address.


=> You could say that the recipient's account has a problem, or the recipent's mail server doesn't allow delivery, but this is not the case : if I mail to the same recipient from any Kerio mail account, everything goes fine.


Here is an extract from the SMTP relay when the backup service sends an e-mail :
"SMTPD" 3712 6152 "2011-01-11 23:00:23.734" "192.168.1.254" "RECEIVED: MAIL FROM:<> SIZE=756"
"SMTPD" 3712 6152 "2011-01-11 23:00:23.734" "192.168.1.254" "SENT: 250 OK"
"SMTPD" 3532 6152 "2011-01-11 23:00:23.734" "192.168.1.254" "RECEIVED: RCPT TO:<recipient<_at_>ext-domain.com>"
"SMTPD" 3532 6152 "2011-01-11 23:00:23.734" "192.168.1.254" "SENT: 550 Delivery is not allowed to this address."
"SMTPD" 2044 6152 "2011-01-11 23:00:23.749" "192.168.1.254" "RECEIVED: QUIT"
"SMTPD" 2044 6152 "2011-01-11 23:00:23.749" "192.168.1.254" "SENT: 221 goodbye"


And here is an extract when I mail to the same recipient, but from a Kerio account :
"SMTPD" 2044 6113 "2011-01-11 22:22:16.192" "192.168.1.254" "RECEIVED: MAIL FROM:<test-user<_at_>kerio-machine.com> SIZE=1366"
"SMTPD" 2044 6113 "2011-01-11 22:22:16.192" "192.168.1.254" "SENT: 250 OK"
"SMTPD" 3684 6113 "2011-01-11 22:22:16.192" "192.168.1.254" "RECEIVED: RCPT TO:<recipient<_at_>ext-domain.com>"
"SMTPD" 3684 6113 "2011-01-11 22:22:16.192" "192.168.1.254" "SENT: 250 OK"
"SMTPD" 3684 6113 "2011-01-11 22:22:16.192" "192.168.1.254" "RECEIVED: DATA"
"SMTPD" 3684 6113 "2011-01-11 22:22:16.192" "192.168.1.254" "SENT: 354 OK, send."
"SMTPD" 1940 6113 "2011-01-11 22:22:16.270" "192.168.1.254" "SENT: 250 Queued (0.016 seconds)"
"SMTPD" 3712 6113 "2011-01-11 22:22:16.270" "192.168.1.254" "RECEIVED: QUIT"
"SMTPD" 3712 6113 "2011-01-11 22:22:16.270" "192.168.1.254" "SENT: 221 goodbye"



Well, the only variation, before the mail submission is accepted or denied, is the "from address" field value...

Of course, if I set the recipient to an internal Kerio account, everything goes fine.
=> When I open the Kerio account's webmail, I can see that the message comes from "Mail Delivery Subsystem", and the "from address" appears as "postmaster<_at_>kerio-machine.com"...
(However, in the mail source, the "return-path" field is empty)


Any thoughts, regarding this issue?
(Is there some way to fix the "from address" field when using the send-mail-after-backup function?)

Many thanks in advance for any helpful answer!
  •  
blackjub

Messages: 10
Karma: 0
Send a private message to this user
(I forgot to specify that I'm running Kerio Connect 7.1.3 b2461 on a Windows 2008 R2 server)
  •  
d.

Messages: 169
Karma: 0
Send a private message to this user
Hi there.

Can you send to an internal email address (e.g. bob<_at_>domain.com) that has a forward set in place, that goes to your external address?

Cheers,
D.

  •  
blackjub

Messages: 10
Karma: 0
Send a private message to this user
Thank you for your answer.

However, the trick didn't work...
(The "From" address is still blank, and the "Return-path" field too)

I think there should be some option to hard code this address (shouldn't it always be "postmaster<_at_>mydomain.com", anyway?), or maybe dev team could add such an option.
  •  
d.

Messages: 169
Karma: 0
Send a private message to this user
That's fine... Another option is to use Kerio Connect's filters to do the work.


  • Login to webmail of the destination (internal) account... That's the stepping-stone account, that will then send the message externally.
  • Click on Settings -> Mail Filters.
  • Create a new filter, and give it a meaningful name shortly when you save it (bottom of rule window)
  • For the first option (conditions), select the 'from' address of 'postmaster<_at_>domain.com' (enter your own domain)
  • For the second option (action), select the Send Notification option.
  • In the window below (section 3), enter the 'to' address, and then click the 'message text' (red) link.
  • Leave the message text as-is. And click OK to save it.
  • The Rule description should now say 'send notification to address (destination<_at_>domain.com) with original subject. Message text: $from$: $subject$...
  • Name the rule (step 4) meaningfully.
  • Click OK to save the rule.
  • Run a backup (or redirect an existing postmaster message to that destination (internal) account)

and you should now receive a message, addressed 'from' that internal account you used, not postmaster.

Let us know how you go...

Cheers,
D.



[Updated on: Thu, 13 January 2011 02:40]


  •  
blackjub

Messages: 10
Karma: 0
Send a private message to this user
Thank you again for this smart tweak.

However, it doesn't work with postmaster messages...
(If I set the rule to send a notification for messages received from any other mailbox, it works like a charm)

If I set the rule to perform any other action (when the mailbox gets a message from postmaster), it works OK.
(Inducing that mail filters are working OK with postmaster messages in most circumstances)

I think some variables can't be interpreted for postmaster messages when using "send notification" actions.
(Let me guess : $from$ variable? *cough*)

I also tried to remove the "$from$: $subject$..." part from the notification, and replace it with a simple "hello world" message : no result either...
(Nothing showing in the Kerio logs)


Well, I guess it's a dead end until dev team adds an option for these matters, isn't it? Sad
  •  
d.

Messages: 169
Karma: 0
Send a private message to this user
Hi there.

Ah yes, good point. No, not a dead end. Bing! I had another idea.

Instead, change the Postmaster address by using a mailing list...

Try this:

  • Go to Domain Settings, Mailing lists.
  • Set up a new mailing list. E.g. BackupAlerts
  • Configure all the usual / appropriate settings, and put adequate protection on to protect the mailing use from misuse etc.
  • On the POSTING tab, change the "Reply-to" address to "Other address"
  • Specify another address, e.g. Bob<_at_>domain.com
  • You can also add a prefix to the subject, e.g. [Backups]
  • TICK the "Hide sender's address and replace it with an address of the list"
  • Make sure you add some members to the mailing list. I assume this will include internal addresses (yours?) and the external address you are trying to reach
  • Click OK, and Apply the new list (to save it)
  • Go to the Archiving & Backup section, Backup tab.
  • Set the mailing list address as the 'to' address for notifications.

This same method can also be used to re-direct postmaster messages in general to another (external) domain if necessary. Although, you may have to use other aliases and/or Mail filters still (or general account forwarding) to achieve that too, although with a mailing list. I tried it for forwarding bounced messages, and that worked for me nicely too Smile.

Let us know how you go with redirecting your backup alerts... But that did the trick for me in my tests Smile.

Happy redirecting your postmaster...

Cheers,
D.

[Updated on: Fri, 14 January 2011 02:23]


  •  
blackjub

Messages: 10
Karma: 0
Send a private message to this user
Thanks a lot, it works like a charm!

(I also had to add "postmaster@kerio_machine_fqdn" as a moderator to allow the system messages to be posted to this mailing list)


Well, that's some very good news!
Thanks again!
  •  
d.

Messages: 169
Karma: 0
Send a private message to this user
Hi there. Excellent, you're most welcome. Glad to hear that worked for you!

Cheers,
D.

Previous Topic: BlackBerry issues
Next Topic: Reciptients get double mails
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Oct 19 14:55:06 CEST 2017

Total time taken to generate the page: 0.00447 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.