Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » fetchmail and Kerio incompatible...?
  •  
p0ddie

Messages: 238
Karma: -1
Send a private message to this user
Hi,

just a haunch, could it be Kerio has some kind of setting in it's IMAP implementation that prevents fetchmal from successfully downloading mails?

Trying to set up a mail archive, figured I could just download all the mails with fetchmail (tried on Ubuntu 10.04 and OS X 10.6.7). This is what I get, (yes, German, essentially a timeout):


root<_at_>mailarchiva:/home/derp# fetchmail -a -k -v -u "admin" -S localhost/8091 -p imap mailserver.de
fetchmail: WARNUNG: Vom Betrieb mit root-Rechten wird abgeraten.
Geben Sie das Passwort für admin<_at_>mailserver.de ein:
fetchmail: 6.3.9-rc2 fragt mailserver.de ab (Protokoll IMAP) um Mo 16 Mai 2011 16:07:20 CEST: Abfrage gestartet
Versuche, mit 212.121.212.212/143 zu verbinden...Verbindung fehlgeschlagen.
fetchmail: Verbindung zu mailserver.de:imap [212.121.212.212/143] fehlgeschlagen: Die Wartezeit für die Verbindung ist abgelaufen.
IMAP-Verbindung zu mailserver.de fehlgeschlagen: Die Wartezeit für die Verbindung ist abgelaufen
fetchmail: 6.3.9-rc2 fragt ab mailserver.de (Protokoll IMAP) um Mo 16 Mai 2011 16:07:41 CEST: Abfrage beendet
fetchmail: Abfragestatus=2 (SOCKET)
fetchmail: normale Beendigung, Status 2
root@mailarchiva[/email]:/home/derp#


Tried with two different Kerio servers, no dice. Tried with a Cyrus IMAP server, fetchmail works like a charm.

I have set up these two Kerio servers, is there some security setting I have set preventing fetchmail so work?

Thanks!

[Updated on: Mon, 16 May 2011 16:14]

  •  
Radek Sip (Kerio)

Messages: 1137
Karma: 34
Send a private message to this user
it should work - I tested it now with 7.2.0 RC2

Is the non-encrypted IMAP service running? Is it available on given hostname - what IMAP server reports if you try in terminal:
telnet mailserver.de 143
additionaly you can try login with:
001 login admin <password>
and it should be successful

Try also enable IMAP server debug module (Webadministration -> right click to the Debug log area -> Messages...) to see more
Previous Topic: Bind Kerio to a specific IP for outgoing mails on multi-homed servers
Next Topic: KC reject password from IPhone4
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Oct 22 09:55:44 CEST 2014

Total time taken to generate the page: 0.01578 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.