Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Failed dependency upon RH install of 7.2.2
  •  
12lee

Messages: 4
Karma: 0
Send a private message to this user
I'm trying to install 7.2.2 on a RH box.

rpm -Uvh kerio-connect-7.2.2-4528-linux.rpm

yields:

error: Failed dependencies:
libstdc++.so.6(GLIBCXX_3.4.6) is needed by kerio-connect-7.2.2.4528-1.i386

however, the package that provides that dependency is already installed.

# up2date --whatprovides=libstdc++.so.6
libstdc++-3.4.6-11.el4_8.1.i386


# up2date -i libstdc++
**snip**
The following packages you requested are already updated:
libstdc++


A little baffled and would appreciate a steer. I've already followed the knowledge base article entitled :

"I get a 'Failed Dependencies' error when I try to install Kerio MailServer on Red Hat Linux"

with no effect Sad

Thx

Lee.

[Updated on: Sat, 23 July 2011 10:47]

  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
What RH version do you use?. Please follow the system requirements. Supported version is RedHat Enterprise Linux 5 and higher.

[Updated on: Sun, 24 July 2011 13:00]

  •  
12lee

Messages: 4
Karma: 0
Send a private message to this user
We're on ES4. Path to follow is all clear and we'll update the OS.
  •  
AndreaF

Messages: 8
Karma: 0
Send a private message to this user
I have the same error on CentOS 4.6.
I used the "YUM" command but can't resolve ....

Help ??!
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
AndreaF wrote on Thu, 11 August 2011 16:53
I have the same error on CentOS 4.6.
I used the "YUM" command but can't resolve ....

Help ??!


Same advice. Upgrade your system.
Please follow the system requirements. Supported version is CentOS 5 and higher.
  •  
  •  
AndreaF

Messages: 8
Karma: 0
Send a private message to this user
Yes. I will upgrade next Sept. Sad
Thanks for advices.
  •  
lkacian

Messages: 71

Karma: 4
Send a private message to this user
Did anybody try install Kerio Connect 7.2.2 on CentOS 6 ?
After dependency hell with libstdc++ last state is :
error: Failed dependencies:
libuuid.so.1 is needed by kerio-connect-7.2.2.4528-1.i386
libz.so.1 is needed by kerio-connect-7.2.2.4528-1.i386

Before this I must install compat library and too libstdc++-4.4.4-13.el6.i686.rpm

But what else ? Why libuuid which is installed. And where is libz ?

Lubor Kacian
FONET Slovakia
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
lkacian wrote on Sun, 21 August 2011 15:42
Did anybody try install Kerio Connect 7.2.2 on CentOS 6 ?
After dependency hell with libstdc++ last state is :
error: Failed dependencies:
libuuid.so.1 is needed by kerio-connect-7.2.2.4528-1.i386
libz.so.1 is needed by kerio-connect-7.2.2.4528-1.i386

Before this I must install compat library and too libstdc++-4.4.4-13.el6.i686.rpm

But what else ? Why libuuid which is installed. And where is libz ?


You probably forgot to mention that your CentOS is 64-bit...
Please consult the manual for your operating system to find out how to run 32-bit application there.

For this case, run:
sudo yum install glibc.i686 libglibc.i686 libuuid.i686 zlib.i686 libstdc++.i686
  •  
lkacian

Messages: 71

Karma: 4
Send a private message to this user
Many thanks. You are right as usually.
Problem was successfully located between chair and kbd.

Lubor Kacian
FONET Slovakia
  •  
Lionel Hutts

Messages: 14
Karma: 0
Send a private message to this user
What about support for CentOS 5.6?
For security reasons I would like to update the OS (CentOS 5.5).
Previous Topic: KOC Manual Removal
Next Topic: Track Contact Activities in Outlook
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Tue Sep 26 03:46:51 CEST 2017

Total time taken to generate the page: 0.00502 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.