Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Outlook Deletes or Moves not showing on Blackberry BES 5.0.3.41 (email sync fails when deleting from outlook inbox, stays on bb)
  •  
bradley

Messages: 6
Karma: 0
Send a private message to this user
BES 5.0.3
Kerio Connect 7.2.2 on Windows Server 2008 R2 x64
Kerio Blackberry Connector 7.2.2 on Windows Server 2008 R2 x64
Blackberry 9780 Bold 6.x OS
Blackberry 8320 5.x OS


Deletes and moves from either Outlook or Webmail do not sync to the Blackberry device(either one).

Deletes on BB sync to outlook/webmail just fine.
Reads on either BB or outlook/webmail also sync fine.

Blackberry is stumped on this one.

We even enabled Hard deletes, and cycled the BES Dispatch service. Hard deletes (shift+del) in outlook do not sync to BB either.

Anyone got any ideas?

[Updated on: Thu, 28 July 2011 00:04]

  •  
bradley

Messages: 6
Karma: 0
Send a private message to this user
RIM is telling me that there is a problem with MAPI:

from BlackBerry Technical Support to All Participants:
[20675] (07/27 10:13:27.245):{0x1214} {aaaa<_at_>aaaa.com} Error creating OOF Rule in GetOOFRule (OpenProperty failed) (0x80004002)
[30147] (07/27 10:13:27.246):{0x1214} {aaaa<_at_>aaaa.com} MAPIMailbox::GetOOFInfo - GetOOFRuleEntryID (0x80004002) failed
[40115] (07/27 10:13:27.246):{0x1214} {aaaa<_at_>aaaa.com} FolderState not found for FolderId=0
[40115] (07/27 10:13:27.246):{0x1214} {aaaa<_at_>aaaa.com} FolderState not found for FolderId=0
from BlackBerry Technical Support to All Participants:
List of Extended MAPI numeric result codes:

support microsoft /kb/238119
  •  
bradley

Messages: 6
Karma: 0
Send a private message to this user
Since the Kerio Blackberry connector installs MAPI, I will have to downgrade BES from 5.0.3 to an older version to get a match.
  •  
nhoague

Messages: 853
Karma: 18
Send a private message to this user
Hello, I'm curious. Were you able to downgrade 5.0.3 to 5.0.2? When I try to do the same I am unable to use BAS. And when reinstalling BES it tells me that the the version BES I am installing is older than the database, probably because the database upgraded to 5.0.3.

So, how did you do it?
  •  
bradley

Messages: 6
Karma: 0
Send a private message to this user
Downgrade, we did not do, we just did a fresh install at the lower version.

All in all, the problem was with the Kerio Blackberry Connector, it was totally screwed up on that version.

We stayed with BESx 5.0.3 and once we upgraded to the latest version of the Kerio Blackberry Connector, our major issues got resolved.

We still have several minor sync issues, and once I have a good block of time, I'll do some detailed testing on it and issue a new case with Kerio to get the smaller issues resolved.

There must not be many folks using the Blackberry connector, else we would have heard alot of fuss, as this issue had a major negative impact on our Blackberry customers, and one large one left over it.(Kerio owes me on that one!)
  •  
nhoague

Messages: 853
Karma: 18
Send a private message to this user
Ouch man I feel your pain. Although I don't place total blame on the KBC. Granted the last version did have some sync problems, but once that was fixed we seem good to go.

My issue now is that after this major Blackberry outage, I can't get a phone to activate on 5.0.3. Just a week ago I had no problem. I can activate the same device on 5.0.2, hence my reasoning for wanting to downgrade.

Regardless I am just now reinstalling 502 to try and upgrade to 503 and see if I can't get this to work.

I still am not a big fan of Blackberry, but the world loves them.
  •  
bradley

Messages: 6
Karma: 0
Send a private message to this user
You may already know this, but we have had to reinstall the blackberry connector at times to get it to work right. It is fine for months and then all of sudden fails to respond to activations. A reinstall right over the top of it, and a reboot seem to be our standard response when it wont respond correctly.

Let us know how it goes, I just hate having to learn this all on my own.... Smile
  •  
nhoague

Messages: 853
Karma: 18
Send a private message to this user
Haha ah yes, the casual uninstall and reinstall of MAPI and the KBC. I have my server set to reboot on a weekly basis just to keep it clean.

We have 53 users on our BES and it seems to work rather well, but your right it could just crash all of a sudden. It was worse before Kerio Connect 7.2 when the store.fdb contained all the users. Now that it is split into different files for each user it is much faster.

It is odd though how traffic will work, but activations don't. I am doing a clean install now to see what happens.

I agree, BES has been a challenge that if I would have known ...

Previous Topic: Sendmail changes in KC 7.2 tip for working with PHP's mail function
Next Topic: All Items in Public Folders formatted like emails
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Nov 19 19:10:02 CET 2017

Total time taken to generate the page: 0.00522 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.