Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » OSX Lion queries
  •  
rickblackdog

Messages: 55
Karma: -1
Send a private message to this user
Hi all, I have a small client who has bravely allowed me to upgrade them to lion server. They use macs but mostly run XP in boot camp or using parallels due to the nature of their business.

A few bugs I've found and I'd be interested to hear how you are handling these:

Apache seems to be integrated with a number of the services in lion. I don't see a simple way of changing the default port from port 80 so in order to allow kerio to start http services have had to disable apache using this:

sudo launchctl unload -w /System/Library/LaunchDaemons/org.apache.httpd.plist


After doing that I (obviously) can't load profile manager, web server, etc.

Also discovered that you can't run pre office 2010 documents from the SMB share. I suspect it's related to hidden files. Would love to hear from anyone who encountered that?

Aside from that, has anyone else made the leap?
  •  
Kedar

Messages: 1320
Karma: 48
Send a private message to this user
Unfortunately terminal commands are required for Lion's web server (Apache), it seems GUI doesn't work :-/ There is related short KB article: http://support.kerio.com/index.php?_m=knowledgebase&_a=v iewarticle&kbarticleid=632

If you need both, you should reconfigure Apache or Kerio Connect to alternative ports. Or configure second IP address for the server and start Kerio Connect's HTTP/HTTPS services and Apache each with own IP address only.

examples of Apache starting/stopping commands:
start service:
sudo launchctl load /System/Library/LaunchDaemon/org.apache.httpd.plist

start service (enable if it is disabled):
sudo launchctl load -w /System/Library/LaunchDaemon/org.apache.httpd.plist

stop service:
sudo launchctl unload /System/Library/LaunchDaemon/org.apache.httpd.plist

disable service (stop and completely disable):
sudo launchctl unload -w /System/Library/LaunchDaemon/org.apache.httpd.plist
  •  
rickblackdog

Messages: 55
Karma: -1
Send a private message to this user
Hi, if I was to change the ports of my mail server, are there any particular recommendations as to which ports I should use as an alternative?
  •  
perennialdesign

Messages: 120
Karma: 3
Send a private message to this user
My KCS 7.3.1 is working on 80 and 443 currently. Should I disable Apache as mentioned above to prevent problems?
  •  
Memnon

Messages: 384
Karma: 84
Send a private message to this user
perennialdesign wrote on Tue, 27 December 2011 03:56
My KCS 7.3.1 is working on 80 and 443 currently. Should I disable Apache as mentioned above to prevent problems?


I personally try to keep these things separated to prevent a mess.

If you're confident with adjusting the ports then it should be possible without problems. But chance is that you're going screw it up down the line anyway.

I'd run your web server (IIS, Apache) on a different VM or machine.

[Updated on: Tue, 27 December 2011 16:19]


- https://shop.kerio.nl the Netherlands
- https://shop.kerio.be Belgium
- https://shop.kerio.lu Luxembourg
  •  
Memnon

Messages: 384
Karma: 84
Send a private message to this user
rickblackdog wrote on Tue, 13 September 2011 10:48
Hi, if I was to change the ports of my mail server, are there any particular recommendations as to which ports I should use as an alternative?


Not really, anything that suits your purposes but just be careful to avoid ports that are intended for other stuff.

Here's a comprehensive overview [link]

The list also contains some alternate suggestions.

[Updated on: Tue, 27 December 2011 16:21]


- https://shop.kerio.nl the Netherlands
- https://shop.kerio.be Belgium
- https://shop.kerio.lu Luxembourg
  •  
MacPhisto

Messages: 11
Karma: 0
Send a private message to this user
Im not sure if my solution is stabile or if apples SU is going to override it, but for me it works for now...

start terminal
1. sudo su
2. pico /private/etc/apache2/sites/virtual_host_global.conf

edit:
Listen *:443
NameVirtualHost *:443
Listen *:80
NameVirtualHost *:80

to:
Listen *:444
NameVirtualHost *:444
Listen *:80
NameVirtualHost *:80

ctrl x and Yes to save

**reboot**

apache is no listening on 444 and not the 443 port after reboot.
Please comment if this solution has any drawbacks!!
Previous Topic: Contact Public Folders and Mac Address Book?
Next Topic: Benutzernamen ändern
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Oct 22 08:27:47 CEST 2017

Total time taken to generate the page: 0.00504 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.