Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Change primary email address on Kerio server (AD username should not be deployed as email address)
  •  
plillelund

Messages: 4
Karma: 0
Send a private message to this user
Hi Forum

We have an AD integration where users are being validated with username and password from AD. This will lead to automatic generation off an email address which is based on the login name and our domain name. See this example:

User login name in AD = john
Full name in AD = john doe
Existing email address = jd<_at_>contusa.com
Domain: contusa.com

This will lead to an export from AD to Kerio, where an automatic mail address is generated like = john<_at_>contusa.com

The export can not see the existing email address. This is also acceptable if one could add an email alias, and configure this as the primary email address. But this is not possible from the configuration, at least I can not do it.

I know it is possible from the web interface and maybe also from KOC, but I would rather do it on the server.

Any ideas ??

  •  
TorW

Messages: 769
Karma: 9
Send a private message to this user
This has been discussed (and solved) before: look at this.
  •  
plillelund

Messages: 4
Karma: 0
Send a private message to this user
I don't agree, this solution doesn't work on my VmWare appliance. What ever changes I made do not change anything in the email address on my imported users. I have tried the following correction in gal_ads.map:
<variable>
<name>Name</name>
<value><attribute>mail</attribute></value>
</variable>
But the email field is still constructed as the login@domainname, but it should be initials<_at_>domainname. I have changed both values under user and group.

In between my testing I stop and restart the Keriomail service, but it seams as though it does do any difference. And it seams to met that even though the solution could work, it is a workaround that can not be describe as the right way to do it. Kerio should instead use the mail field in the AD if it is not empty.
  •  
Karthik

Messages: 40

Karma: 0
Send a private message to this user
hi,

i too have similar situation and looking for a solution or work around, were you able to get this fixed..?

anyone else with similar scenario and got it fixed..? i have checked http://forums.kerio.com/index.php?t=rview&goto=52324& ;th=13232 this thread and still no luck..

Thanks and Regards,
Karthik S.
Previous Topic: Number of recipients restriction
Next Topic: Problems with Spam Filter
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Wed Sep 20 11:27:38 CEST 2017

Total time taken to generate the page: 0.00429 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.