Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » iPhone contacts missing (Some Contacts Don't Sync)
  •  
GazzaBot

Messages: 112
Karma: 0
Send a private message to this user
Hi,

I have a client who syncs to the Public Folder\Domain Contacts. Some contacts that were on his phone are no longer there although they are on the server Public Contact folder. If I create a new contact on phone or server it appears immediately on both sides.

Anyone else having issues or know how to resolve this??

Many thanks

Gary
  •  
mcollien

Messages: 21
Karma: 2
Send a private message to this user
We've also seen this behavior with iPhone contacts with public contacts. iOS 4.3.5 and Kerio Connect 7.2.3 patch 1

We've tried removing the iPhone contacts and re-adding them and we then get to see some that were missing. Others still not visible on phone. All can be found via the live global contact search in the iPhone contacts app.

Also the missing contacts are visible in AddressBook on Mac.

--
Mark Collien
Technolutionary, LLC
Kerio Preferred Partner
  •  
GazzaBot

Messages: 112
Karma: 0
Send a private message to this user
Are you running Kerio Connect and Kerio Control on the same machine? We are, just wondering if this has any role to play in the issue.
  •  
marook

Messages: 520

Karma: 3
Send a private message to this user
GazzaBot wrote on Tue, 04 October 2011 09:12
Are you running Kerio Connect and Kerio Control on the same machine? We are, just wondering if this has any role to play in the issue.


Why should it?

Either you have a connection esatblished, or not. Kerio Control does not make deep-packet filtering - does it??
I think this might be a prblem with the content in the contact..

Regards,

Jakob Peterhänsel
Consultant - Humac A/S

Apple Certified Support Professional (ACSP)
Apple Certified Technical Coordinator (ACTC)
AppleSeed/CQF member since 1998
Kerio Messaging Partner
  •  
mcollien

Messages: 21
Karma: 2
Send a private message to this user
Nope - this box is dedicated to Connect.

--
Mark Collien
Technolutionary, LLC
Kerio Preferred Partner
  •  
GazzaBot

Messages: 112
Karma: 0
Send a private message to this user
I imported their contact folder to Excel to compare the fields. The only difference between 1 I know did not sync and 1 that does sync was the Priority field - Low vs Normal.

I then imported the specific contact that does not sync at the client onto our Kerio server and did a sync on the same model iPhone and it works.

They have over 3600 contacts in that folder with a lot of duplicates, although the problem contact is not duplicated. I think I will try to clean the contact folder up and retry.

Thanks for the responses

Gary
  •  
GazzaBot

Messages: 112
Karma: 0
Send a private message to this user
We seem to have sorted the contacts problem out. It has to do with using SSL rather than straight HTTP.

Because our Control and Connect servers are on the same machine I had to disable Clientless VPN on Control in order to enable the HTTPS service on the Connect server.

I then created an SSL certificate for the public HOST name.

On the iPhone I had to go to the webmail page and below the blue logon window is a link to 'Setup my Device'.
Here you are able to download / install the certificate.

Then go to the activesync account and change it to SSL, might be prompted to accept the certificate.

Then let the sync run.

Lots of thanks to the Kerio support guys, very helpful. And thanks to the forum guys who always provide information and assistance.

Take Care
Gary
  •  
mcollien

Messages: 21
Karma: 2
Send a private message to this user
GazzaBot wrote on Fri, 07 October 2011 15:03
We seem to have sorted the contacts problem out. It has to do with using SSL rather than straight HTTP.

Because our Control and Connect servers are on the same machine I had to disable Clientless VPN on Control in order to enable the HTTPS service on the Connect server.

I then created an SSL certificate for the public HOST name.

On the iPhone I had to go to the webmail page and below the blue logon window is a link to 'Setup my Device'.
Here you are able to download / install the certificate.

Then go to the activesync account and change it to SSL, might be prompted to accept the certificate.

Then let the sync run.

Lots of thanks to the Kerio support guys, very helpful. And thanks to the forum guys who always provide information and assistance.

Take Care
Gary


We've always been using SSL and a real certificate for the FQDN on the Kerio Connect server. Still missing contacts - and not always the same contacts.



--
Mark Collien
Technolutionary, LLC
Kerio Preferred Partner
  •  
Shawn B.

Messages: 3
Karma: 0
Send a private message to this user
We've also seen this behavior running a similar setup.
Does seem to be related to the data itself.

Thanks,
Shawn
  •  
mcollien

Messages: 21
Karma: 2
Send a private message to this user
What's fixed it for one person so far...

Delete Exchange account on iPhone. Delete mobile profile for that user's iPhone in kerio. Create new Exchange account on iPhone. Wait for 4500 contacts to make their way to iPhone... It appears they are all there now. Total number of contacts matches what's in the public Contacts folder.

Will apply this fix to others as they come up.

--
Mark Collien
Technolutionary, LLC
Kerio Preferred Partner
  •  
Shawn B.

Messages: 3
Karma: 0
Send a private message to this user
I will try your suggestion and report - thank you.
How do you delete a mobile profile in Kerio?

Thanks,
Shawn
  •  
mcollien

Messages: 21
Karma: 2
Send a private message to this user
Shawn B. wrote on Wed, 19 October 2011 20:48
I will try your suggestion and report - thank you.
How do you delete a mobile profile in Kerio?


Log into the admin console.

Go to Users

click on the user in question,

Look for the More Actions button at the bottom of the window and select Mobile Devices.

You can then use the remove button to delete the device from the user's account.

Proceed at your own risk!

--
Mark Collien
Technolutionary, LLC
Kerio Preferred Partner
Previous Topic: Mailweiterleitung für nicht angelegte Benutzer einer Domain
Next Topic: New Kerio admin: Mac client setup help requested
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Mon Nov 20 16:45:06 CET 2017

Total time taken to generate the page: 0.00501 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.