Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » AD name to short (Shorter usernames after migration from OD t o AD)
  •  
OneClick

Messages: 27
Karma: 0
Send a private message to this user
After I migrated our domain from Open directory to Active directory
I can't use the long accountname anymore
"myverylongoriginalusername"

KC truncates it to the "Pre Windows 2000" username "myverylongoriginalus" which seems very strange these days. Confused

emailaccounts in our company take the form
firstnamesurname<_at_>ouremaildomain.com and the 20 characters just are not enough.
I could always create an internal KC account but that way I would lose the single signon ability.

What am I missing here?

regards
  •  
blackbox

Messages: 82
Karma: 0
Send a private message to this user
I'm curious, has anything been hashed out with this issue?
  •  
OneClick

Messages: 27
Karma: 0
Send a private message to this user
nope KC-accounts only work with the short username
  •  
MarkK

Messages: 454
Karma: 46
Send a private message to this user
You don't have to create an internal user, you can just create an Alias. I created an alias for my email that was 40 characters long and it worked fine. You could then go into what ever mail client you are uisng and set the reply-to address to the super long username name. None of this would interfere with the user authentication.
  •  
OneClick

Messages: 27
Karma: 0
Send a private message to this user
Correct however an alias doesn't allow the user to login to webmail.
He/she needs to type the abbreviated accountnaam and that causes confusion.
  •  
MarkK

Messages: 454
Karma: 46
Send a private message to this user
"He/she needs to type the abbreviated accountnaam and that causes confusion."

You can work around this. In the Connect Admin console, do a Create New Local User, enter in the LLLLOOOONNNNGGGG name, then change the Authentication setting to Kerberos 5.

I just tried this out by creating a network AD account with a 30 character name (123456789012345678901234567890), did the create in Connect thing above, and everything works like you want. I sent and received mail using the long name.

Email address is 123456789012345678901234567890<_at_>mysite.com
Username to sign in both on network and web mail is 123456789012345678901234567890

I believe that this should work exactly as you need. Just a couple of extra steps on the Admin side to create the account. You may want to test with a couple of accounts first to make sure that there are not any other gotcha's with it.

  •  
OneClick

Messages: 27
Karma: 0
Send a private message to this user
Just checked this and it doesn't seem to work for me
(again I'm testing the webmail here)
Sad
  •  
MarkK

Messages: 454
Karma: 46
Send a private message to this user
I just tried the steps again with a 50 character login name and it worked. Login name for web mail was:
12345678901234567890123456789012345678901234567890

Now, I am creating everything new, both the network account and the Kerio user. In my test, the user does not have a current email user account. Don't know if that would have any affect on this.

In Kerio, are you selecting "Add Local User", typing the LONG username, then switching to Kerberos authentication? Those are the only two things I did when I created the user.
  •  
OneClick

Messages: 27
Karma: 0
Send a private message to this user
What version of KC are you on now?
because it is not working for me. :cri:

The local account works with the local password-database
but fails as soon as switch to Kerberos.
However Kerberos itself is fine and is used for other services.

  •  
MarkK

Messages: 454
Karma: 46
Send a private message to this user
I am running Windows KC 7.24, on a Win2008R2 network with the forest at 2008 level.

Sounds like you are trying to convert an existing account. I have not tried that since I don't have any users witht hat long of a name. Have you tried creating a new network account? When creating the network account, the login name (not pre-{whatever}) is the full long name?

Previous Topic: Where to view users mailbox
Next Topic: BlackBerry Enterprise Server Express error state: "faild to start"
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Nov 24 19:30:42 CET 2017

Total time taken to generate the page: 0.00456 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.