Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » Incoming calls are muted
  •  
jverheyen

Messages: 12
Karma: 0
Send a private message to this user
Hi every one,

I have a little problem and i don't know how to resolve it.

I'm working with Kerio operator 1.1.2 build 4228, and when i receive a call the person who's calling me can't hear me but i can hear him.

I've not this problem with outgoing calls.

My firewall is totally opened.

In the warning logs i can see this:

08/Nov/2011 14:50:24] VOIP asterisk[1716]: WARNING[1785]: chan_sip.c:2082 in retrans_pkt: Maximum retries exceeded on transmission 29a3a1234bf77e1519e1c3b324871151<_at_>217.111.202.80:5060 for seqno 102 (Critical Response) -- See doc/sip-retransmit.txt.

The answer seems to be in the file sip-retransmit.txt but i can't access to it.

Could someone help me?
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Hi,

The file you are looking for is in the source code of Asterisk: see for example here.

It looks like some SIP messages (most likely ACK) are blocked somewhere - either by your firewall or by another one further down the road.

What does a totally open firewall mean? Do you use NAT?

The best way to diagnose the issue is to capture the packets using Operator's built-in packet sniffer (System -> Network). Once you have the packet dump, open it in Wireshark, go to Telephony -> VoIP Calls and display the graph for your call. It will show you what's wrong.

Vladimir
  •  
jverheyen

Messages: 12
Karma: 0
Send a private message to this user
Hi,

Thanks for your answer.

Yes i use a NAT and what a totally opened firewall means ==> nothing in this firewall is blocking the VOIP. All rules are correctly done.

I've diagnosed it through WireShark and it seems that an ACK is missing but why?

Jonathan
  •  
ICT and Me

Messages: 940

Karma: 53
Send a private message to this user
Jonathan,

You are saying that you are using NAT, but do you have also make port-forwarding rules.
Because outgoing is working but incoming isn't. There for I think that you dan't have port-forwarding or not all port that are used forward to the Operator.


ICT and Me
Carlo Turk
The Netherlands
www.ictandme.nl
  •  
jverheyen

Messages: 12
Karma: 0
Send a private message to this user
Hi ICT,

Yes i use a NAT and i also have made the port forwarding rules.
All port used are forwarded to the operator.

It's for that i don't understand what's happening
  •  
ICT and Me

Messages: 940

Karma: 53
Send a private message to this user
This are the ports to be forwarded:
PING
RTP
SIP
TCP 5090
UDP 5090
UDP 5065
UDP 8000
UDP 8002
UDP 10000-20000

Make sure thos are right.

ICT and Me
Carlo Turk
The Netherlands
www.ictandme.nl
  •  
jverheyen

Messages: 12
Karma: 0
Send a private message to this user
They are right :s
  •  
ICT and Me

Messages: 940

Karma: 53
Send a private message to this user
Had it worked before?

ICT and Me
Carlo Turk
The Netherlands
www.ictandme.nl
  •  
jverheyen

Messages: 12
Karma: 0
Send a private message to this user
  •  
ICT and Me

Messages: 940

Karma: 53
Send a private message to this user
Then the problem could be caused be wrong setting of the SIP trunk.
Can you send me with PM a screen shot of your siptrunk setting (call routing).
I start to think that the problem will be found there. Which provider/country?
I had the same problem when i started but found the solution with Vladimir at that time.

ICT and Me
Carlo Turk
The Netherlands
www.ictandme.nl
  •  
jverheyen

Messages: 12
Karma: 0
Send a private message to this user
Hi,

I've taken off the firewall.

It doesn't work :s.

What can i do?
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Hi,

Why are you forwarding the ports? Does your SIP carrier require that you run on a public IP address?

Vladimir
  •  
ICT and Me

Messages: 940

Karma: 53
Send a private message to this user
@Vladimir,
Are you asking my?

ICT and Me
Carlo Turk
The Netherlands
www.ictandme.nl
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Sorry, this was a question for jverheyen.

Vladimir
ICT and Me

Messages: 940

Karma: 53
Send a private message to this user
@Jonathan,
Please send a screenshot of your SIP trunk setting (Call Routing).
I still think there lays the problem. If you have forward the ports within the router/firewall to operator it must work, but if the SIP trunk isn't well connected then have problem.
@ Vladimir, it sounds same problem you had when trying the Breeze SIP trunk. Don't you think?

ICT and Me
Carlo Turk
The Netherlands
www.ictandme.nl
Previous Topic: Canadian SIP Providers
Next Topic: Dropped calls
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Nov 19 15:29:56 CET 2017

Total time taken to generate the page: 0.00631 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.