Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » restore from a backup, remote phone not working anymore
  •  
ser1998

Messages: 81
Karma: -1
Send a private message to this user
Hi,

i tried to restore a backup, everything's went smoothly except for my remote phone.

i have a vpn between 2 networks and the remote phone appears as offline in kerio

why?
  •  
ser1998

Messages: 81
Karma: -1
Send a private message to this user
need help thanks!

[Updated on: Thu, 19 January 2012 19:10]

  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Hi,

Did you try to restart the phone? If that does not help, enable SIP messages in the debug log to see if Operator receives anything from the phone. Or you can use the built-in packet sniffer to see what is the communication between the phone and Operator.

Vladimir
  •  
ser1998

Messages: 81
Karma: -1
Send a private message to this user
yes i've rebooted the phone, it's saying unauthorized!



[20/Jan/2012 13:26:03] {sip} Operator asterisk[1661]: VERBOSE[1735]: <--- Transmitting (no NAT) to 192.168.1.117:5060 ---> SIP/2.0 100 Trying Via: SIP/2.0/UDP 192.168.1.117:5060;branch=z9hG4bK-6be68e98;received=192.168. 1.117 From: \"Mr. X\" <sip:11p1@192.168.0.181>;tag=73b88de02c030c23o0 To: \"Mr. X\" <sip:11p1@192.168.0.181> Call-ID: 6694e354-1a0b8df7<_at_>192.168.1.117 CSeq: 43997 REGISTER User-Agent: Kerio Operator Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO Supported: replaces Content-Length: 0 <------------>
[20/Jan/2012 13:26:03] {sip} Operator asterisk[1661]: VERBOSE[1735]: <--- Transmitting (no NAT) to 192.168.1.117:5060 ---> SIP/2.0 401 Unauthorized Via: SIP/2.0/UDP 192.168.1.117:5060;branch=z9hG4bK-6be68e98;received=192.168. 1.117 From: \"Mr. X\" <sip:11p1@192.168.0.181>;tag=73b88de02c030c23o0 To: \"Mr. X\" <sip:11p1@192.168.0.181>;tag=as055ae84c Call-ID: 6694e354-1a0b8df7<_at_>192.168.1.117 CSeq: 43997 REGISTER User-Agent: Kerio Operator Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO Supported: replaces WWW-Authenticate: Digest algorithm=MD5, realm=\"asterisk\", nonce=\"0760a99e\" Content-Length: 0 <------------>
[20/Jan/2012 13:26:03] {sip} Operator asterisk[1661]: VERBOSE[1735]: Scheduling destruction of SIP dialog \'6694e354-1a0b8df7<_at_>192.168.1.117\' in 32000 ms (Method: REGISTER)
[20/Jan/2012 13:26:03] {sip} Operator asterisk[1661]: VERBOSE[1735]: Really destroying SIP dialog \'2937b9650261c2df1ae4b5f569fb3527<_at_>209.217.85.78\' Method: OPTIONS
[20/Jan/2012 13:26:07] {sip} Operator asterisk[1661]: VERBOSE[1735]: <--- SIP read from 192.168.1.117:5060 ---> REGISTER sip:192.168.0.181 SIP/2.0 Via: SIP/2.0/UDP 192.168.1.117:5060;branch=z9hG4bK-6be68e98 From: \"Mr. X\" <sip:11p1@192.168.0.181>;tag=73b88de02c030c23o0 To: \"Mr. X\" <sip:11p1@192.168.0.181> Call-ID: 6694e354-1a0b8df7@192.168.1.117 CSeq: 43997 REGISTER Max-Forwards: 70 Contact: \"Mr. X\" <sip:11p1<_at_>192.168.1.117:5060>;expires=3600 User-Agent: Cisco/SPA504G-7.4.7v26 Content-Length: 0 Allow: ACK, BYE, CANCEL, INFO, INVITE, NOTIFY, OPTIONS, REFER, UPDATE Supported: replaces <------------->

  •  
ser1998

Messages: 81
Karma: -1
Send a private message to this user
also, i realise that if the remote phone isn't plug into the local network at least one time which has a dhcp with the parameter 66 poiting to my kerio server, then it wouldn't auto provision, is there a way to send him the instruction to where it should auto provisioning ?? on a cisco spa504g
  •  
ser1998

Messages: 81
Karma: -1
Send a private message to this user
i reinstall everything and now i can't connect my remote phones, it tells me SIP/2.0 401 Unauthorized, which settings i forgot to enable ??
  •  
ser1998

Messages: 81
Karma: -1
Send a private message to this user
here's what i got from another remote phones :

[20/Jan/2012 15:22:39] {sip} Operator asterisk[1664]: VERBOSE[1730]: Sending to 192.168.3.161 : 5060 (no NAT)
[20/Jan/2012 15:22:39] {asterisk} Operator asterisk[1664]: NOTICE[1730]: securityModule.h:252 in int resKerioSecurityCheck(sockaddr_in*, char*): KerioSecurity check 192.168.3.161 (uri:\"Mr. X\" <sip:10<_at_>192.168.0.181>)
[20/Jan/2012 15:22:39] {sip} Operator asterisk[1664]: VERBOSE[1730]: <--- Transmitting (no NAT) to 192.168.3.161:5060 ---> SIP/2.0 100 Trying Via: SIP/2.0/UDP 192.168.3.161:5060;branch=z9hG4bK-e5f29517;received=192.168. 3.161 From: \"Mr. X\" <sip:10@192.168.0.181>;tag=abcebed61646a106o0 To: \"Mr. X\" <sip:10@192.168.0.181> Call-ID: 235d915d-86330f6e<_at_>192.168.3.161 CSeq: 49324 REGISTER User-Agent: Asterisk PBX Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO Supported: replaces Content-Length: 0 <------------>
[20/Jan/2012 15:22:39] {sip} Operator asterisk[1664]: VERBOSE[1730]: <--- Transmitting (no NAT) to 192.168.3.161:5060 ---> SIP/2.0 401 Unauthorized Via: SIP/2.0/UDP 192.168.3.161:5060;branch=z9hG4bK-e5f29517;received=192.168. 3.161 From: \"Mr. X\" <sip:10@192.168.0.181>;tag=abcebed61646a106o0 To: \"Mr. X\" <sip:10@192.168.0.181>;tag=as16e85891 Call-ID: 235d915d-86330f6e<_at_>192.168.3.161 CSeq: 49324 REGISTER User-Agent: Asterisk PBX Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO Supported: replaces WWW-Authenticate: Digest algorithm=MD5, realm=\"asterisk\", nonce=\"55648a41\" Content-Length: 0 <------------>
[20/Jan/2012 15:22:39] {sip} Operator asterisk[1664]: VERBOSE[1730]: Scheduling destruction of SIP dialog \'235d915d-86330f6e<_at_>192.168.3.161\' in 32000 ms (Method: REGISTER)
[20/Jan/2012 15:22:39] {asterisk} Operator asterisk[1664]: NOTICE[1730]: chan_sip.c:20449 in securityPostAuth: Kerio security: securityPostAuth - AUTH_CHALLENGE_SENT.
  •  
ser1998

Messages: 81
Karma: -1
Send a private message to this user
i tried a softphone from my remote network and it worked, the problem is really on the cisco phone, i've done a factory reset and it's doing the same thing, also when i look in provisioned phones, it still shows the phone online with his previous IP

[Updated on: Fri, 20 January 2012 21:33]

  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
What Operator version are you using? What phone models do you have?
  •  
ser1998

Messages: 81
Karma: -1
Send a private message to this user
Operator latest one i think 1.1.3

Phone cisco spa504g

[Updated on: Mon, 23 January 2012 15:59]

  •  
ser1998

Messages: 81
Karma: -1
Send a private message to this user
solved my problem, i was using the operator on a hyper-v vm with a legacy network card and i think there was a problem with it.

so i reinstall everything on a physical pc and I reinstalled the server, reimported my backup and my remote phones reconnected like it should have done

thanks
  •  
ser1998

Messages: 81
Karma: -1
Send a private message to this user
i get the same problems on a physical pc, i have a phone over vpn tunnel that is saying SIP/2.0 401 Unauthorized

everything's was working before until i reboot my kerio operator

why ?

i tried to reboot the phone and it's saying the same thing
Previous Topic: Import Users
Next Topic: cisco spa303 admin section password added by kerio
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Nov 23 17:38:10 CET 2017

Total time taken to generate the page: 0.00470 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.