Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Workspace » Firefox 10 (Problem with updated browser)
  •  
Florian

Messages: 21
Karma: 0
Send a private message to this user
Hi,

I've updated firefox to v.10 and now it seems that I am no longer able to open any pages in KWS. Whenever I try I get an exceptional error.
I have no problems browsing through spaces. However, if I select a page I get this error message.

If I use firefox 9.0.1 (same computer) or IE9 it works fine.

Does anyone else has the same problem or a hint what I should change in order to use firefox 10?

Thanks and kind regards - Florian
  •  
Jarda Snajdr (Kerio)

Messages: 221
Karma: 12
Send a private message to this user
Hello Florian,

this is a bug in Workspace. We're going to release a patch. There is no simple workaround at this moment.

Jarda
  •  
Florian

Messages: 21
Karma: 0
Send a private message to this user
  •  
juergen852

Messages: 120
Karma: 3
Send a private message to this user
This problem also exists with FF 11.x and 12.x
I am testing Kerio with Aurora Versions of FF.

(Unfortunately my tests are mostly for Kerio Connect. Haven't had Workspace on my List..)

Please fix/check for 11 and 12 too.
  •  
Jarda Snajdr (Kerio)

Messages: 221
Karma: 12
Send a private message to this user
Here is an instant fix:

1. Open file ${WS_INSTALL_DIR}/Tomcat/webapps/ROOT/web/client/client.min. js in a text editor. The file has Unix LF line endings, so Windows Notepad won't display line breaks. But it's still doable. Backup the file before doing any edit.

2. Go to line 219 - it begins with this string:

else if(Ext.isGecko){gecko=(/rv:([\d].[\d])(.([\d].[\d]{2}))?/).

3. Change it to:

else if(Ext.isGecko){gecko=(/rv:([\d]+.[\d])(.([\d].[\d]{2}))?/).

I.e., the whole edit is adding a "+" after the first "[\d]"

4. Save the file and reload the page in your Firefox 10.

Jarda

[Updated on: Tue, 31 January 2012 20:47]

  •  
asieber

Messages: 40
Karma: 4
Send a private message to this user
The correct path in our Windows environment is:
${WS_INSTALL_DIR}\Tomcat\webapps\ROOT\client\client.min.js

I've tested the fix with FF 10 and everything is working.

Andreas
  •  
FloFMS

Messages: 23
Karma: 0
Send a private message to this user
  •  
Florian

Messages: 21
Karma: 0
Send a private message to this user
Thank you for the patch. I've updated KWS on Wednesday and now it works fine with Firefox 10. However, we are experiencing since that moment problems with our SSL certificate. All browsers are mentioning a certificate error when entering KWS. Firefox is the only browser that does not show this error.
We are using a certificate from Thawte Inc. which is valid until end of 2012. Before the update all browsers worked fine with it.

Has anyone an idea what has happened to the certificate?
Thank you - Florian

[Updated on: Fri, 10 February 2012 17:50]

Previous Topic: Editing workspace from a android device
Next Topic: Administer All Content--not allowing administration
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Sun Sep 24 06:59:45 CEST 2017

Total time taken to generate the page: 0.00520 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.