Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Operator » Call Routing
  •  
blamire

Messages: 21
Karma: 1
Send a private message to this user
We are experiencing an issue with call routing on our kerio box!

Basically the issue I am having is that when we register the SIP trunk to voipfone.co.uk and all of the DDI's using the comma separated syntax the trunk registered successfully and I can call in. However when we try and call a DDI even though it is setup to route to a particular extension it only ring the entire ring group.

Basically we have no call routing?

We have tested with sipgate and everything works successfully?


Anyone any ideas as voipfone say because we can get calls in to the system the rest is down to our PBX!

Any help would be great??




  •  
silars

Messages: 429
Karma: 59
Send a private message to this user
I know you posted first, but this topic appears to be similar to:

http://forums.kerio.com/t/21602/voipfone-co-uk-call-routing- problem/

If they aren't the same problem, my sincere apologies. I do believe my previous thread on this topic does address your problem.
  •  
blamire

Messages: 21
Karma: 1
Send a private message to this user
Looks like someone else is also having exactly the same issue as me! I have tried the To field also but still no luck.

Anyone else any ideas?

  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
As suggested in the other thread, the best idea is to capture the communication between you and your SIP provider using the built-in packet sniffer.

Vladimir
  •  
blamire

Messages: 21
Karma: 1
Send a private message to this user
Hi All

I have done as requested and i have attached the logs.

Thanks in advance

  • Attachment: Logs.zip
    (Size: 22.35KB, Downloaded 208 times)
  •  
silars

Messages: 429
Karma: 59
Send a private message to this user
Your INVITE and To: lines are the same (30138623). You would need to perform call routing on that number. It looks like they are stripping off the first 3 digits (area code?) in your full DDI.

[Updated on: Tue, 20 March 2012 14:37]

  •  
blamire

Messages: 21
Karma: 1
Send a private message to this user
Sorry for my ignorance but can you please explain exactly what i need to do in Kerio in order to get this working?

Thanks
  •  
silars

Messages: 429
Karma: 59
Send a private message to this user
One way, you will need to set your external number to 30138623 (not xxx30138623, for instance). This will allow you to set the call routing properly. You may have to play with the Rewriting rules for outbound calls though.

Another method could be trying to play with Rewrite rules on the inbound numbers. Would need Vladimir, or someone else, to comment on whether that is viable. I only know what has worked for me.
  •  
Vladimir Toncar (Kerio)

Messages: 1696
Karma: 39
Send a private message to this user
Hi,

Our experience is that once you discover the phone number format your SIP carrier is using, it's pretty straightforward from there. I would remove the current SIP interface and the rule for routing of outgoing calls and and then I would start over, using 30138623 as the external number.

Some providers expect you to use an ID that differs from the telephone number (the interface edit dialog has an option for that) but I guess this is not your case.

Vladimir
  •  
blamire

Messages: 21
Karma: 1
Send a private message to this user
Hi Vladimir

Thanks for your reply, i cant get this working at all! We have 10 numbers and as it stands we don't have any call routing so we cant call any DDI's. I have attached some images so you can see exactly how we are connecting at the moment.

Thanks
Adam

  • Attachment: Kerio.zip
    (Size: 63.76KB, Downloaded 214 times)
  •  
silars

Messages: 429
Karma: 59
Send a private message to this user
That doesn't look good, and appears this problem has gotten a bit more difficult.

Voipfone isn't sending any dialed information relative to your actual numbers, thus, no call routing. Since you'll need to work with Kerio (potentially) and Voipfone (definitely) to resolve this, I'm backing out of this thread and just monitoring.

I didn't want you to think I just bailed when it got hard. I'd stick in, but I think I'd just complicate things.

In the meantime, you may want to give Voipfone a call and ask them how they expect you to do call routing with the information they provide in the SIP request packets. This will be helpful to the Kerio support folks going forward. It will also fill some time voids as everyone's schedules and timezones sync up.
  •  
blamire

Messages: 21
Karma: 1
Send a private message to this user
UPDATE:

Basically from what we can gather from Voipfone when any telephone number within our account is dialled it is presented to the Kerio PBX as an account number rather than the telephone number that has been dialled. In our case the account number for voipfone is: 30138623. We have the following telephone numbers with our voipfone account (01539898020,01539898021,01539898022,01539898024,01539898027 ,01539898028,01539898029,01539898030) and have created a SIP trunk with all these telephone numbers in it. We have then setup the trunk to direct the DDI's to our internal extension numbers accordingly. The problem is that when anybody calls in on any of our telephone numbers the incoming number is presented to the PBX as: 30138623 (both the INVITE & TO field). Due to this no call routing is taking place and all calls are being directed to the ring group (in our case number: 600).

What we need to do is setup virtual extension numbers within our voipfone account, direct each respective DDI at these virtual extension numbers and then create SIP trunks within the Kerio PBX that registers to the virtual extension numbers so that we can route DDI's accordingly. This works on other PBX manufacturers systems and we use this method regularly) on other PBX's. The format of the virtual extensions is in the form of 'accountnumber*extension number' and in our case; 30138623*200 or 30138623*201 etc etc. When we try and create a new SIP trunk in the Kerio PBX, it won't allow us to have this format in the External Numbers section or within the User ID section as it does not like the * character. Because of this we can't register the SIP trunk to voipfone and in turn still can't route our DDI's.

In an additional SIP trunk we need to be able to have a field such as this in the telephone number's box: 30138623*200

OR

We need create the new trunk, put in the telephone number of the DDI in the External Numbers box (e.g. 01539898021) and then the system needs to allow us to tick the boxes that says: "User ID differs from the telephone number" and "Use SIP user ID in REGISTER request only (Advanced Tab) and then have the system allow us to have a User ID such as this: 30138623*200 (in the General tab bottom dialog box).

We have used SSH to access the system and tried to edit the SIP.conf file to edit the fields accordingly. Although this allows to add in the * when the system is rebooted the settings from the GUI (in the Call Routing section) simply overrides the SSH edit.

Any fixes/ideas appreciated
Thanks
  •  
silars

Messages: 429
Karma: 59
Send a private message to this user
Another option could be to just assign the extensions as the DDIs (200, 201, 202, ...) and try to use the Rewrite rules to strip the leading 9 characters and do call routing on the final 3 (the extension). This would negate the need to have Operator understand the "*" character (i.e. code change/upgrade).

I know Operator has Rewrite rules for "Called" and "Calling" numbers. I just haven't played with Rewriting enough to know if it is processed before call routing occurs.

[Updated on: Wed, 21 March 2012 14:55]

  •  
blamire

Messages: 21
Karma: 1
Send a private message to this user
thanks for such a quick response but this wont work. if we dont use additional trunks registered to virtual extensions in our voipfone control panel we cant route the calls as the PBX is only presented with the incoming number of 30136823 and so we dont know what DDI has been originally dialled.

because we can't register to the virtual extension from the PBX, as the PBX wont allow the * character when the DDI is directed to the virtual extension in the voipfone control panel (and our PBX isnt) the call wont even make its way into the PBX for routing.

does this make sense?

Thanks again for your help to date.
silars

Messages: 429
Karma: 59
Send a private message to this user
Ah, yes. I had read it that you could configure Voipfone to enable the passing of virtual extension information. Error on my part.

It looks like the Kerio folks will have to address the capability to register to the virtual extension. Based on what we've learned, this appears to be the best route. Unless Voipfone can configure their SIP trunks differently. My SIP provider supported multiple options for SIP routing.

Has Voipfone said this is the only way it will work?
Previous Topic: Broadvoice and Operator?
Next Topic: Connect Cisco 7961 IPphone
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Thu Nov 23 02:32:41 CET 2017

Total time taken to generate the page: 0.00522 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.