Connect. Communicate. Collaborate. Securely.

Home » Kerio User Forums » Kerio Connect » Outlook 2011 - Duplicate Messages being sent (multiple copies of emails being sent)
  •  
stothers

Messages: 89
Karma: 0
Send a private message to this user
Occasionally (not reproducible) when one of my users sends a message (from Outlook 2011, OSX 10.6.Cool multiple copies of the message get delivered to all recipients.

In this specific example:

1. Log files show message queued and delivered at 11:26:41 with queue-ID xxxxxx

2. Thirty seconds later, message queued and delivered (same message with attachment) with a different queue-ID.

3. Eighteen minutes later, messaged queued and delivered (same message, same size attachment) with yet another queue-ID.


the attachment is only 21k, so that shouldn't be the issue.

any ideas?

EDIT: should -> shouldn't

[Updated on: Tue, 27 March 2012 21:01]

  •  
stothers

Messages: 89
Karma: 0
Send a private message to this user
A little more investigation leads me to some clues. I'll write them here to get some opinions/input on the situation.

The user has over 22,000 items in the Outlook "Sent Items" folder. Clearly, too many, but could that be the reason?

Assuming that the user clicks send, the software then needs to write that file in to the "Sent Items" folder, but if the folder can't be opened/indexed fast enough (due to the enormous number of items), would the software assume the message did not send and then attempt to resend?

thoughts?

  •  
mathieuf

Messages: 9
Karma: 0
Send a private message to this user
This same problem has been reported by 3 out of our 290 users. Like in your case it is not easily reproducible. Have you had any luck in finding a potential cause?
  •  
stothers

Messages: 89
Karma: 0
Send a private message to this user
The problem still continues.

Not reproducible, but very embarrassing when it happens.

Anyone else have any ideas?

  •  
travisdcc

Messages: 16
Karma: 0
Send a private message to this user
I'm having the same issue with one of my users. Not reproducible, as with the others. Has anyone found a fix? Thanks.
  •  
vomsupport

Messages: 132
Karma: 3
Send a private message to this user
Any chance do you have multiple email addresses?

We see the problem in users that have an KOC connector and an IMAP account both from different domains.

Server 6.2 Centos, Kerio 7.3.3

[Updated on: Thu, 07 June 2012 07:08]

  •  
OkO99

Messages: 1
Karma: 0
Send a private message to this user
  •  
Paupport

Messages: 2
Karma: 0
Send a private message to this user
stothers, I'm assuming that you did try and trim down the users "sent" folder.

  •  
stothers

Messages: 89
Karma: 0
Send a private message to this user
Hi,

Yes. We tried to trim down the sent items, but it wasn't really the issue. I feel it was more a matter of the server. I believe if the server was overwhelmed (busy) doing a lot at once, it was more likely to double up the messages.

I gave up trying to troubleshoot and have since moved to Office365.

  •  
Paupport

Messages: 2
Karma: 0
Send a private message to this user
Thanks for the response.

I did have some luck with one of our users who had her "Drop duplicate messages" unchecked in Configuration -> POP3 Download. However we still have another user who still sends duplicate emails every now and then. What a weird issue.

Hope this link will help somebody. --Edit-- (evidently new users can't use links.)

--QUOTE--

Why am I getting multiple copies of an email?
Answer:

You can change this behavior in the Configuration -> POP3 Download -> (Select account) -> Edit -> Drop duplicate messages option.

Discussion:

If you use a single POP3 mailbox from your ISP for all your users, then sort them into separate mailboxes at Kerio Connect, there are some limitations to be aware of.

If you select "Drop duplicate messages" in the POP3 Account settings, then mails to multiple users on the server will only be delivered to one recipient. Alternatively, if you do not select "Drop duplicate messages" then all recipients will receive a copy for each recipient specified.

If you switch to receiving mail directly with SMTP, you will not see this issue at all. Also, you could use ETRN to collect your mail, but this must be supported by your ISP.
  •  
nhoague

Messages: 853
Karma: 18
Send a private message to this user
Sorry to bump this thread, but I am experiencing this same problem now. Only users with Outlook 2011 using EWS. Messages can get sent 2x to 8x. There is no rhyme or reason and they are getting irritated. Sad

Any ideas? We are on Connect 8.0.2 on Ubuntu 12.04.
  •  
cik

Messages: 15
Karma: 1
Send a private message to this user
I would sugest you to get one pc, install Outlook 2011, Wireshark and look at communication between pc and server
  •  
Pavel Dobry (Kerio)

Messages: 5245
Karma: 251
Send a private message to this user
nhoague wrote on Wed, 17 April 2013 14:54
Sorry to bump this thread, but I am experiencing this same problem now. Only users with Outlook 2011 using EWS. Messages can get sent 2x to 8x. There is no rhyme or reason and they are getting irritated. Sad

Any ideas? We are on Connect 8.0.2 on Ubuntu 12.04.


I recommend to check the server logs for potential journal.db errors. Outlook seems to be in unsynchronized state and repeat the synchronization. Or there is some network timeout issue probably.
  •  
nhoague

Messages: 853
Karma: 18
Send a private message to this user
I don't see any errors pertaining to the affected users about journal.db. But, how could I reset it manually?

Is it user specific or server wide?

Thanks!
Pavel Špalek (Kerio)

Messages: 287
Karma: 37
Send a private message to this user
Sending messages (CreateItem request) can be blocked by locked Sent Items folder (message copy is saved to this folder). You would see longlasting CreateItem request in debug log (more then 3 mins).
Gather these logs a send them to us:
http://kb.kerio.com/product/kerio-connect/os-x/logging-micro soft-outlook-2011-for-mac-with-kerio-connect-1053.html
There is also useful info about journal.db in this article, please read it.

Pavel Špalek
developer - Kerio Connect
Previous Topic: Webmail Search does not works!
Next Topic: Updating from 7.3.1 to 8.0.2 android phones
Goto Forum:
  


Disclaimer:
Kerio discussion forums are intended for open communication between forum members and may contain information and material posted by members which may be useful in learning about Kerio products. The discussion forums are not intended to provide technical support for any specific product. Any information implied or expressed in the discussion forums is that of the posting member. Kerio is in no way responsible for the information posted in the forums, or its accuracy. Kerio employees may participate in the discussions, but their postings do not represent an offical position of the company on any issues raised or discussed. Kerio reserves the right to monitor and maintain the forums to promote free and accurate exchange of information.

Current Time: Fri Aug 18 14:52:34 CEST 2017

Total time taken to generate the page: 0.00566 seconds
.:: Contact :: Home ::.
Powered by: FUDforum 3.0.4.